Why do I need the latest Flash version to play videos??

Discussion in 'OS X El Capitan (10.11)' started by bigpoppamac31, Oct 23, 2016.

  1. bigpoppamac31 macrumors 68000

    Joined:
    Aug 16, 2007
    Location:
    Canada
    #1
    So I'm on Safari browser and video on sites like YT will not play unless the latest Flash version is installed. Why is this?? I have ClicktoFlash enabled so that it doesn't load automatically. I just get a black video viewer on YT.
     
  2. Bruno09, Oct 23, 2016
    Last edited: Oct 23, 2016

    Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    It might be because you have ClickToFlash enabled that you get a black video viewer.

    For testing purpose, go to Safari Preferences, disable ClickToFlash and test Youtube again.
     
  3. bigpoppamac31 thread starter macrumors 68000

    Joined:
    Aug 16, 2007
    Location:
    Canada
    #3
    If I disable ClickToFlash then the video works. But it's Flash video and I don't want that. With CTF on it should default to HTML5. This only happens when a Flash update comes out.
     
  4. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #4
  5. bigpoppamac31 thread starter macrumors 68000

    Joined:
    Aug 16, 2007
    Location:
    Canada
    #5

    If I disable CTF then any website which uses Flash will load it. I don't want that hence why I have CTF installed. If I uninstall Flash then websites that use it won't work properly.

    This is what I get right now if I right click on a video in YT.

    Screen Shot 2016-10-24 at 7.07.15 AM.png
     
  6. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #6
    I have no problem watching this HTML5 (not Flash) video, again I do not have Flash Player on my computer, and CTF is disabled.

    http://hpics.li/f763632

    I think that your right click capture shows that CTF is not disabled.
    Here is mine (in French) : http://hpics.li/defae95

    Sure, some sites still use Flash and you might need Flash Player for them.

    But not for Youtube.
     
  7. bigpoppamac31 thread starter macrumors 68000

    Joined:
    Aug 16, 2007
    Location:
    Canada
    #7
    Yeah I saw the page like that when I briefly disabled CTF. But I figure YT is using Flash by default. Lots of sites still use Flash. I also have AdBlock installed and some sites like news sites tell me I can't proceed unless I disable AdBlock.
     
  8. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
  9. bigpoppamac31 thread starter macrumors 68000

    Joined:
    Aug 16, 2007
    Location:
    Canada
    #9
    Okay so I figured out I can enable/disable CTF on a given site but keep CTF installed. So I'm gonna just do it like that. YT works now. Thanks.
     
  10. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #10
    Yes exactly, forgot to say it, sorry.
     
  11. bigpoppamac31 thread starter macrumors 68000

    Joined:
    Aug 16, 2007
    Location:
    Canada
    #11
    No worries. One thing that's annoying is that I can't skip ads that play before a video. With CTF enabled I didn't see the ads at all. They are very intrusive. Also I notice that when I load a YT page there is a red line going across the top of the page to indicate that the next page is loading.
     
  12. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #12
    I do not see any ad before Youtube videos.

    I have uBlock installed, try with it (disable AdBlock during the test).

    You can prevent the HTML5 player from loading the next video : click on the gear icon (Settings), and uncheck Automatic reading (don't know the wording in English).

    Here in French, first line on top "Lecture automatique" (=Automatic reading) is disabled : http://hpics.li/6b8369b
     

Share This Page