why does ATV take so long when trying to rent a movie?

Discussion in 'Apple TV and Home Theater' started by mrjayd, Jan 23, 2013.

  1. mrjayd macrumors regular

    Jun 17, 2009
    Before the last upgrade, i could rent something and watch it instantly. But since the last update, its seems to take forever like it has to download the whole movie or something first. How can I fix this or remove the last update.
  2. waw74 macrumors 68030

    May 27, 2008
    i remember seeing something here about an upgrade and wired ethernet not playing well together, not sure if that's been fixed yet or not.
    Try unplugging the ethernet cable and going wi-fi.

    also for good measure, reboot your modem and router.
  3. mrjayd thread starter macrumors regular

    Jun 17, 2009
    Well I did have that issue when doing the update. And when I unplugged the ethernet it updated just fine. But wired or wireless, it still takes hours before I can watch a movie I selected to rent.
    Is there any way of downgrading the firmware back to the old version?
  4. Jetson macrumors 6502a


    Oct 5, 2003
    My, that is an annoying problem.

    Complain to Apple. It might help.
  5. Avatar74 macrumors 65816


    Feb 5, 2007
    One thing to check... Run speedtest.net. There are occasions when the problem is my ISP narrowing the bandwidth, throttling users, etc. and other times when I'm getting 30Mbps throughput but the movie is still taking forever.

    In the latter scenario, try an obscure release... If every release you try to rent takes forever, then Apple's pipe is clogged. If only a particular movie does it (and I've noticed this with popular new releases) then there may be a large number of users trying to access that file (however many times it may be mirrored it's still finite).
  6. mrjayd thread starter macrumors regular

    Jun 17, 2009
    Thanks I just moved and I am getting pretty consistent 18M connection. And it happens on every movie I have tried. And again, it all started with the last update. Before the update, It never did this once to anything I rented. Everything was instant. Click "but movie" and watch it in seconds.
  7. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
    I rented two movies on my MBP within minutes of each other, one Samsara took almost 4 hrs before it was ready to play, the other Taken 2 took only a few minutes.

    It could be a problem at the source.
  8. Avatar74 macrumors 65816


    Feb 5, 2007
    What format are you defaulting to? 720p? 1080p? If 1080p, have you tried bumping down to 720p as a test?

Share This Page