why does homepod appear on mac os x volume output if cant be used?

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by kate9, Feb 9, 2018.

  1. kate9 macrumors newbie

    Joined:
    Aug 14, 2008
    #1
    im trying to understand how airplay works with homepod... itunes is fine and works from its own airplay icon as usual.

    however i assumed it can play from youtube etc/system audio (maybe not the feed back effects) on a mac since its choosable as an airplay speaker from the title bar. when you do this you get no sound. if this isnt supported what is it there for?

    alternatively, even in safari youtube has its own icon for airplay, when you click these it says no devices found.

    i assumed since on the homepod specs it says under sources 'airplay speaker from ios/mac' that these would work?
     
  2. daveak macrumors 6502

    Joined:
    Jun 28, 2009
    Location:
    Durham, UK
    #2
    Works fine for me, I just picked the HomePod from the menu bar as the speaker, went to netflix in safari and the audio came from the HomePod.
     
  3. sam2428 macrumors 6502

    Joined:
    Mar 8, 2011
    Location:
    Houston, TX
    #3
    Any latency issues noticeable when watching Netflix or youtube?

    Would like to keep a homepod on my desk as my main speaker and for listening to music if possible.
     
  4. daveak macrumors 6502

    Joined:
    Jun 28, 2009
    Location:
    Durham, UK
    #4
    Just tried with youtube, quite bad, about a second or two out of sync.
     
  5. vipergts2207 macrumors 68000

    vipergts2207

    Joined:
    Apr 7, 2009
    Location:
    Columbus, OH
    #5
    How old is your Mac?
     
  6. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #6
    My super power is that my brain can compensate for very large audio sync issues (specifically lip sync) so I can only notice them for a couple minutes before I feel it fixed itself. Ya, my super power sucks.

    I have a 2013 iMac and I tested it and initially it was about 150-200ms delay in audio with youtube.

    Then I tried from my iPhone 6S to my HP and it was near enough I would consider it near perfect.

    Then I went back to the iMac and it was still there. As I was watching videos I noticed it getting better, assuming this was just my super powers kicking in...ladies... I went back to a test video and sure enough it was practically spot on.

    At first I didn't see what was happening but when I paused the video sound kept coming out of the HomePod so I thought there would be a massive sync issue. However when I restarted the video there was a massive delay prior to the HP outputting audio. Now its obvious it was allowing it to buffer and resync but I didn't time them to check for an inconsistency and of course its working.
     
  7. sam2428 macrumors 6502

    Joined:
    Mar 8, 2011
    Location:
    Houston, TX
    #7
    Dang that’s a bummer.... I really didn’t want extra clutter on my desk. Would have been nice to just have simple speaker with a clean look.
     
  8. kate9 thread starter macrumors newbie

    Joined:
    Aug 14, 2008
    #8
    That's good it does nothing for me still after a restart, removing and re adding. I'm wondering if its because im on an older imac perhaps its an older bluetooth thing.
    --- Post Merged, Feb 9, 2018 ---
    im thinking its because its a pretty old imac now.. mid 2010. still on high sierra and other airplay options work though... and it shows up.
     
  9. vipergts2207 macrumors 68000

    vipergts2207

    Joined:
    Apr 7, 2009
    Location:
    Columbus, OH
    #9
    That's why, your Mac needs to be from 2012 or newer.

    https://www.macrumors.com/roundup/homepod/#compatible_devices
     

Share This Page

8 February 9, 2018