Why does Internet Sharing on Leopard suck so badly?

Discussion in 'macOS' started by younify, Sep 18, 2008.

  1. younify macrumors newbie

    Joined:
    Oct 24, 2007
    #1
    I love my Mac, and I love that it normally "just works", but on Leopard, internet sharing does not just work.
    I'm using a usb wireless modem, and sharing my internet to my wife's G4 laptop via airport.
    The settings are correct, via internet sharing etc.... I know they're right because EVENTUALLY we get the ibook to connect, after turning airport on and off twenty times, resetting passwords, turning airport off, restarting....
    This is madness!!!
    Latest update of Leopard seemed to do nothing...
    Can anyone be of any assitance?
    Using a Huwei wireless (3G) modem in Australia, provider is three....
     
  2. tdhurst macrumors 68040

    tdhurst

    Joined:
    Dec 27, 2003
    Location:
    Phoenix, AZ
    #2
    Huh?

    Wait, what? You're connecting how with your computer? USB? Ethernet?
     
  3. gretafour macrumors regular

    Joined:
    Aug 26, 2006
    Location:
    Rochester, NY
    #3
  4. thejadedmonkey macrumors 604

    thejadedmonkey

    Joined:
    May 28, 2005
    Location:
    Pa
    #4
    Try using WEP encryption instead of WPA, it could be that the iBook can't connect using WPA encryption if it's too old.
     
  5. davidwarren macrumors 6502a

    Joined:
    Aug 28, 2007
    #5
    I was having just this problem today, I was trying to wirelessly share my ethernet connection with an xp laptop. It would eventually connect at 2mb, but couldn't get on the internet.
     
  6. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #6
    Working perfectly for me under Tiger (Ethernet to Wireless) and in Leopard (Wireless to Ethernet). :confused:
     
  7. younify thread starter macrumors newbie

    Joined:
    Oct 24, 2007
    #7
    Changing encryption length seemed to work

    Hey guys,
    Right after I posted, I changed the encryption type on the password.
    Answer earlier question: sharing USB wireless modem connection, sharing the connection over Airport, to iBook.
    I always had plain WEP password selected, but changing the type of password to
    WEP 40/128-Bit ASCII
    seemed to work straight away
    (as opposed to just "WEP Password")

    Those settings are as they appear in Tiger, when you connect to the airport. In Leopard, in Internet Sharing Options, obviously have a tick next to:
    Enable encryption (using WEP)
    and then under the password, change WEP Key Length: to 128 bit.

    Just turned it off and on again, to test, and the iBook automatically reconnected... I think that's all it needed...
    Thank goodness! Fingers crossed for continued smooth operation....
    Sigh of relief!
     
  8. blouis79 macrumors member

    Joined:
    Jun 7, 2005
    #8
    WEP key generation still sucks. Why is that different manufacturers can implement the theoretically same algorithm and get different answers??

    http://support.apple.com/kb/HT1344

    Obviously, WPA is better.

    The solution if you are forced to use WEP to internet share OSX->Windows (in a hotel environment for instance) is to use something like WEP Key Maker to generate the common hex keys which can be entered on both Windows and OSX (preceded by $ on OSX).
     

Share This Page