Why does MacOSX Mavericks 10.9.5 need SpeechSynthesis in order to start up?

Discussion in 'OS X Mavericks (10.9)' started by im-not-a-robot, Mar 7, 2018.

  1. im-not-a-robot macrumors newbie

    Joined:
    Mar 7, 2018
    #1
    Can somebody explain to me why are the following two files necessary for MacOsX 10.9.5. to start up?
    Ran across this while I was altering all Speech-related files since I don't need that function. I'm just interested why they are necessary. After altering these files' names, system crashed while opening. First thing to crash was a HuaweiDataCard, but after I disconnected it, some other things kept crashing too in the start up.

    The files are located at: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/SpeechSynthesis.framework/Versions/A/

    Their names are:
    SpeechSynthesis (an exec file without extension)
    SpeechSynthesisServer.app

    Thanks for educating me already in advance :)
     
  2. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Educated guess: The OS goes through a checklist during startup. If a file that's been deemed as "required" isn't there, startup fails.
     
  3. im-not-a-robot thread starter macrumors newbie

    Joined:
    Mar 7, 2018
    #3
    Is there a way to monitor which processes require which files in the startup?
    Maybe that way I could try to guess the purpose and turn it off if it seems unneeded?
     
  4. casperes1996 macrumors 68040

    casperes1996

    Joined:
    Jan 26, 2014
    Location:
    Horsens, Denmark
    #4

    Well, I don't know about monitoring during startup, but the lsof command (stands for list open files), can show you any and all processes accessing a particular file
     
  5. im-not-a-robot, Mar 9, 2018
    Last edited: Mar 9, 2018

    im-not-a-robot thread starter macrumors newbie

    Joined:
    Mar 7, 2018
    #5
    Thank you! I found a complete list of all processes that use the SpeechRecognition.framework in my macOSx's Carbon.framework. Now the problem is that even my /usr/sbin/coreaudiod uses the SpeechRecognition.framework. So how can I disable or destroy it without breaking my system? I already tried renaming it and it wasn't a good idea.

    In fact while I was recovering my computer from that renaming in single user mode, I renamed the file back to original, something strange happened. There was a message that a 'VM Swap Subsystem is on'. Should I be worried about it? I am already reading about disabling virtual memory, is that a stupid thought?

    edit: and what was also weird was that while rebooting after fixing that filename for SpeechRecognition, there was some lines relating to bluetooth which don't normally occur, then there was that 'VM Swap Subsystem is ON" and then the computer started _without_ the starting sound. This is not what normally happens while rebooting from single user mode.

    edit2: it really feels akward that I have turned this recognition off in my preferences, but that it is still on and is being used and cannot be deleted easily. As a customer I am not happy.
    --- Post Merged, Mar 9, 2018 ---
    It really gets weird. Now I did a "sudo shutdown -h now" and the computer failed to shutdown immediately, there was some single user style lines about a Virtualbox.

    I also found in my System/Library/LaunchAgents directory an ssh-agent that creates a socket just like described in wikipedia security risks for ssh agents. Sorry for little unrelated stuff, I'm still learning and going through what is the state of my privacy at the computer.
     
  6. im-not-a-robot thread starter macrumors newbie

    Joined:
    Mar 7, 2018
    #6
    I feel like there is something seriously wrong. I tried multiple ways resetting PRAM and VRAM for example by holding option+command+P+R while starting and I also disconnected the powercord and held powerbutton pressed for 20 seconds. When I then started up, the computer still remembers where I left on my desktop! It is also connected in the internet although there is no internet and wifi is turned off and by sampling the DNS process it seems it is using wifi and device-to-device and sending small packets. Both syslog and DNS processes are fairly small but have both +2GB virtual memory so the reset didn't happen! Can somebody explain or give a recommendation?
     
  7. im-not-a-robot thread starter macrumors newbie

    Joined:
    Mar 7, 2018
    #7
    I think I found some **** that came few years ago from a program called gramblr.app that was meant for instagram uploads from desk computer. It seems not easy to erase this.

    I changed my password and disabled all sharing if possible, and now I get a notification that Messages Agent would like to access my keychain all the time. Also while logging in it asks something like should I do a new keychain, revert to the old or just continue logging in, so I chose logging in.

    It is also a possibility that I messed something up but there definitely was also some harmful stuff in a /opt folder. I even found a text file describing weak points of different systems and how to authenticate without password :D I'm not sure if I got it completely erased.

    Edit: the precise message I get while logging in is "The system was unable to unlock your login keychain" --> "continue login" or "update keychain" or "create new keychain"
     

Share This Page

6 March 7, 2018