Why does MAIL keeps deleting my gmail email on server?

svkrzn

macrumors regular
Original poster
Dec 8, 2009
212
9
Hello, i know what by default, the mail downloaded through IMAP let you to keep it on the server marked as read. MAIL, when it recieves emails from gmail, deletes it definitively from server (it's not even in trash!). How do i stop that? I hope i was clear..

Thanks.
 

ttopp

macrumors regular
Mar 1, 2007
237
0
in mail go to preferences, then to accounts.

in there there is a tick box to "remove copy from server" after a select amount of time. check to see if its set to "remove immediately" in the drop menu..
 

svkrzn

macrumors regular
Original poster
Dec 8, 2009
212
9
in mail go to preferences, then to accounts.

in there there is a tick box to "remove copy from server" after a select amount of time. check to see if its set to "remove immediately" in the drop menu..
This option is available only for POP accounts. Mine is IMAP..:confused:
 

palebluedot

macrumors 6502a
Jun 29, 2008
716
77
The junk mail filter in your Mail.app should be disabled. Other than that look at the first options and follow those.

The second screen shot shows what you should do for each folder under the [GMail] server tab. Click the GMail "All Mail" folder then go to Mailbox -> use mailbox for and make each mailbox line up, i.e. Sent Mail and Drafts for Sent Mail and Drafts.

If you follow these settings now when you press delete it will simply remove the INBOX tag from your Gmail via IMAP but the message will remain in GMAIL-> ALL MAIL instead of being moved to GMAIL -> Trash. If you want to delete something or mark it as spam you just move the message to [Gmail]Trash or [Gmail]Spam under the server folders.

More info is also here: http://mail.google.com/support/bin/answer.py?answer=78892#
 

Attachments

svkrzn

macrumors regular
Original poster
Dec 8, 2009
212
9
If you follow these settings now when you press delete it will simply remove the INBOX tag from your Gmail via IMAP but the message will remain in GMAIL-> ALL MAIL instead of being moved to GMAIL -> Trash. If you want to delete something or mark it as spam you just move the message to [Gmail]Trash or [Gmail]Spam under the server folders.
Hello, i followed your instruction, indeed now if i recieve email, it's not deleted from server. My suspects are for deleted mail. If i press delete, as you said it goes in ALL MAIL. But it's permanently deleted from server! But why do i have to do so:
Move deleted messages to the Trash mailbox > NOT selected
Why can't i just leave it selected so the mail goes to the trash in Mail.app and trash on server? I'm completelly confused with Mail.app.

EDIT: after lookin thru the web, i found this nice and clear guide: http://complexdiagrams.com/2009/01/19/imap-for-gmail-mailapp-iphone/
It works almost like i wanted to, the only thing is that all the deleted mail on server, has 2 labels 'INBOX' and 'TRASH'. How do i get rid of the first label?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.