Why does Mail periodically forget my passwords?

jbrown

macrumors 6502a
Original poster
Jul 7, 2002
994
4
London
This happens a couple of times a week…and is annoying.

When using Mail I'll get a pop-up window telling me my password is not recognised, and there is a field to re-enter it.

This I'll do, and sometimes thats enough ( for a while ), but sometimes when
I re-enter it it still won't work.

I'll then need to go to Mail's preferences, and re-input my password.

Any ideas?

Thanks:)
 

Alrescha

macrumors 68020
Jan 1, 2008
2,157
315
Mail may not be forgetting your password, but rather may be having trouble talking to your mail provider. It fails to get you logged in (for any of several reasons) but falls back to 'enter your password' on the error. I've seen this occur during network outages, and clear right up when the network problems were fixed.

A.
 

Bear

macrumors G3
Jul 23, 2002
8,089
4
Sol III - Terra
Most often what I've found is that it's trouble connecting to the mail server. If you hit cancel when the window pops up, it remembers your saved password.
 

firedept

macrumors 603
Jul 8, 2011
5,606
458
Somewhere!
Usually is a problem with your internet provider as stated. Had this problem with my provider when they were changing out optic lines over several months. Asked for password on some occasions. Not always. Once my provider was done updating cables, password problems ceased.
 

Obi Wan Kenobi

macrumors 6502
Mar 9, 2011
461
273
London, UK
Having a total shut down can help as well.

Shut down and unplug your Mac, and switch off your router for a minute or two.

It allows everything to reset.
 

GovtLawyer

macrumors 6502
Sep 6, 2008
294
9
Same here

I was just about to start a new thread with this same problem. While searching for the appropriate forum to post it, I found this.

For around the last three weeks I have been having same problem. I have six different emails I use with AOL. I get a message that mail cannot connect to the AOL account, and it asked me to enter my password which is already in the space and is correct. If I enter it again or simply hit okay it seems to correct, although sometimes it doesn't. The interesting thing is it happens each time for a different account. So it seems as if mail is searching the server for all of my email accounts and I never know which one is going to pop up.

This is very very annoying and it has only been going on for around the last three weeks. However, it happens every single day sometimes multiple times each day and it usually cycles through the accounts. I am perplexed because it appears as if the other accounts find the server and one doesn't.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.