Why does my iphone not have all of my email?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by FiremanMike, May 21, 2011.

  1. FiremanMike macrumors regular

    Joined:
    Jan 26, 2011
    #1
    I have 3 accounts on my phone, and settings to allow it to keep up to 200 messages. 1 of them is gmail and set up as an exchange, and I think this is the only one I'm having a problem with.

    As I'm headed to an important interview yesterday, I pull out my iphone to review the email from the interviewer, just to make sure I had the office number correct. Of course the email is no where to be found, but there are emails both before and after that email. I am certain this email was not deleted. I load up gmail through safari and sure enough, there it is.

    This happens somewhat frequently, and I think it's only with gmail (but not positive, my gmail is just my most active email). Why is this happening and how can I stop it?
     
  2. Dave Felix macrumors 6502a

    Dave Felix

    Joined:
    Apr 9, 2011
    Location:
    Scranton, Pennsylvania
    #2
    same here, I have three email accounts on my macbook pro and when the phone synced the email accounts it only copied the Gmail accounts and left out my Microsoft exchange one that I use for college.:(
     
  3. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #3
    What is your Account setting for "Mail Days to Sync"? If it's not "No Limit", change it, send yourself a message, and see if the re-sync clears it up.
     
  4. FiremanMike thread starter macrumors regular

    Joined:
    Jan 26, 2011
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_7 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8E303 Safari/6533.18.5)

    I will try that, ideally what should it be set to?
     
  5. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
  6. FiremanMike thread starter macrumors regular

    Joined:
    Jan 26, 2011
    #6
    Mine was set to 3 days, switched it to "No Limit" and it fixed it.

    Thanks!!
     
  7. Nicki Fielding macrumors newbie

    Joined:
    Jan 8, 2013
  8. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #8
    Settings>Mail, Contacts, Calendars>Accounts (Select Account)>Mail Days to Sync
     

Share This Page