Why does the screen change brightness level?

Discussion in 'Mac Basics and Help' started by laughingbabe16, Jun 1, 2008.

  1. laughingbabe16 macrumors member

    Joined:
    Jun 2, 2006
    #1
    So I have noticed a few times already, that the screen on my white macbook flickers to change the brightness level. It can do this while the computer is plugged in and charging, or if it's off the charger. It is definitely noticeable as it causes me to just watch what the screen is doing.

    Any ideas or what might be causing this to happen?

    Thanks.:eek:
     
  2. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
  3. laughingbabe16 thread starter macrumors member

    Joined:
    Jun 2, 2006
    #3
    flickers the brightness level for a few minutes but eventually goes to the level it was before.
     
  4. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #4
    Loose logic board connector? That's the only thing that I can think of, but then the whole displayey part of the display would be having problems. Could be your backlight giving out...
     
  5. Teh Don Ditty macrumors G4

    Teh Don Ditty

    Joined:
    Jan 15, 2007
    Location:
    Maryland
    #5
    I've had this problem myself. I went to the Genius Bar and of course they could no reproduce it. They still took my computer (Applecare FTW) and sent it out for repair. Apple replaced just about everything and it still happens to this day.
     
  6. laughingbabe16 thread starter macrumors member

    Joined:
    Jun 2, 2006
    #6
    Interesting.

    If it continues to get worse or happens more frequently I'll take it in. I still have AppleCare until Aug 09, so no worries on that! :)

    Thanks!
     
  7. theqiezi macrumors newbie

    Joined:
    Jul 21, 2008
    #7
    I also have the same problem. Changing the screen brightness back to the previous level doesn't work, since as it just goes back to the old brightness settings in 30 sec -- a few minutes. I find the brightness being changed on my MBP to be very annoying. I thought initially it might be the light sensor for the backlit keyboard that was doing it, but it was not. Anyone else notice how the macbook air keyboard backlight is triggered from the iSight camera and on the MBP it is _under the keyboard_. I.e. you can't hold your finger over the iSight camera in order to engage the keyboard backlight controls. Which I _hate_. ;)) Can you put tape over the under-keyboard sensor somehow??

    Ok. It is a feature. I just took a lamp and shined it over the keyboard and the screen started lighting up, then dimmed down when I took the lamp away. So dear readers, it appears you are in some lighting setting between two of the settings the MB(P) is using, and it keeps going between those two settings.

    I still want to turn on the keyboard backlight by blocking off the iShit.
     
  8. abhi2023 macrumors newbie

    Joined:
    Aug 25, 2008
    #8
    Solution

    I encountered the same problem few days after I got my MBP. And I guess someone said in this thread about MBP trying to adjust brightness in response to ambience light level. I think THAT is the cause. However, this is too sensitive a response since I do not notice any change in ambience light level in my room :) if you know what I mean. Here is what I propose. Go to System Preferences and choose Displays. You would see a box "Automatically adjust brightness as ambient light changes" and most likely, it will be checked. Uncheck it and it should help. I just did that like 10 min ago and since then the screen has not flickered. Hope THIS is the solution.
     
  9. techlover828 macrumors 68020

    techlover828

    Joined:
    Jun 28, 2007
    #9
    [​IMG]

    you guys sure "Automatically adjust brightness" isn't checked, that'll do it if you put your hand over the sensor or something.
     
  10. howie1108 macrumors newbie

    howie1108

    Joined:
    Dec 8, 2007
    Location:
    Melbourne, Australia
    #10
    Lol, thats what I was just about to suggest... :D

    - CaptHowie
     
  11. odaiwai macrumors member

    Joined:
    Nov 30, 2006
    Location:
    Hong Kong
    #11
    MacBooks don't have a light sensor, that's only in the MacBook Pro.
     
  12. zim macrumors 65816

    zim

    Joined:
    Jan 5, 2002
    #12
    AH! Thank you!!! I just got my MacBook Pro and noticed that the screen was changing based on where I had my hands (I was in a dim room). Now that I know about the option I am going to leave it on... it feel so much better knowing that it is a function and not a defect.
     
  13. Brôtkvest macrumors newbie

    Joined:
    Feb 2, 2008
    #13
    At least my Macbook (2.0GHz Alu) seems to have a light sensor.
    If I put my hand in front of the iSight, the screen brightness changes if i have the auto adjust brightness setting on.

    Just adding this reply to the thread for the record if someone, as me, would have had some time of wondering if there is something wrong with their MacBook screen or with their eyes...

    Lucky me it was neither ;-)
     
  14. TMK044 macrumors newbie

    Joined:
    Sep 2, 2010
    #14
    How to Turn Off Automatic Brightness

    I assume you are using OS X 10.6. I had the same issue on my Macbook Pro. While i didn't experience "flickering", I did notice changes in brightness while typing an email. At first I thought I just might be going crazy. But it seems that just moving toward and away from the screen through changes in my posture was enough to trigger a change in ambient light as far as the computer was concerned. Another compounding factor was that I had turned off the main overhead light in the room above the computer table. A few feet behind and above me, I had two skylights turned on so small movements on my part really affected the amount of light getting to the computer's sensor, wherever that might be.

    I was able to find the setting to change it to manual brightness. Here's how to do it:

    Go to System Preferences | Displays | Displays tab
    just under the Brightness slider is a checkbox for "Automatically adjust brightness as ambient light changes." Uncheck that, and the problem should stop.

    I must admit, it's a neat feature, but I like to adjust brightness settings manually, especially if I'm working on some graphics.
     

Share This Page