Why Does The Witness Run Like Absolute Crap?

Discussion in 'Mac and PC Games' started by peglegjack, Nov 1, 2017.

  1. peglegjack macrumors 6502

    peglegjack

    Joined:
    Jul 30, 2011
    Location:
    Brooklyn, NY
    #1
    I have high end stock 2015 5K Retina iMac with the M395 card and 2TB Fusion drive. I know it's not a beast or anything, but I can't hardly even play The Witness on the lowest resolution (720p). Half the island is an absolute slideshow, which doesn't make sense as I have higher than the recommended settings.

    Nothing about this makes any sense to me. Can anyone who has this game tell me what their performance is? It just seems pathetic to me that my iPad Air 2 could be a better option when it has a far inferior GPU.
     
  2. Janichsan macrumors 65816

    Janichsan

    Joined:
    Oct 23, 2006
    #2
    Sounds weird. I played the game on my 2016 15" rMBP with the less powerful Radeon Pro 460 and could run it at the highest settings and 1440x900 just fine. It wasn't always really smooth, as the framerate occasionally dipped somewhat below 30 fps, but it was always well playable.
     
  3. peglegjack thread starter macrumors 6502

    peglegjack

    Joined:
    Jul 30, 2011
    Location:
    Brooklyn, NY
    #3
    It goes beyond not being smooth, sometimes the game will just crash. And my system is fine; I've played plenty of games that have looked amazing and played well. Is it a Steam thing? When I load the game it defaults me to 720p at medium settings, and that just isn't happening in certain areas like the swamp.

    Maybe I should download those unofficial drivers and check it on the Windows side? Though I don't really have time for that.
     
  4. jeanlain macrumors 65816

    Joined:
    Mar 14, 2009
    #4
    That's most likely a driver bug. What's your OS version?
     
  5. peglegjack thread starter macrumors 6502

    peglegjack

    Joined:
    Jul 30, 2011
    Location:
    Brooklyn, NY
    #5
    The latest, 10.13.1
     
  6. Even Longer macrumors 6502

    Even Longer

    Joined:
    Dec 12, 2012
    Location:
    Head of a pin
    #6
    Try to restart a couple of times and reset PRAM, - this seems to have helped others here experiencing FPS drops in various games in High Sierra. Seems very banal, but I read here in the gaming section, that after 3 restarts FPS went back to normal.

    Craig Federighi seems to busy exchanging animojis with his OSX developer team... ;)
     

Share This Page