Why does Time Machine slow down my iMac?

Discussion in 'iMac' started by ks-man, Sep 24, 2009.

  1. ks-man macrumors 6502a

    Joined:
    Sep 25, 2007
    #1
    I have a 6 month old top of the line iMac. I always can tell immediately if Time Machine is running b/c the computer becomes choppy. This lasts for the duration of the backup. It is most noticeable when I move my mouse. The mouse starts to act jumpy rather than gliding.

    In activity monitor it shows during the backup that I still have 50-80% idle so I don't understand why I take such a performance hit.

    I do backup wirelessly to a Time Capsule. Is this the issue? It is often backing up large amounts (though I'm not quite sure why). I'll download about 100MB of pictures and it will do an 800MB backup.

    I just can't shake the feeling that something isn't correct. I've noticed this back on regular Leopard and now on Snow Leopard.

    Apart from this issue my iMac works perfectly. Please let me know if others see this or if you have any ideas what the problem is. Also, if I can't fix this, is there anyway to slow down Time Machine backups (without hacking type stuff) so it only runs once or twice a day? I really don't need hourly backups.

    Thanks.
     
  2. bstreiff macrumors regular

    Joined:
    Feb 14, 2008
    Location:
    Austin, TX, USA
    #2
    It has to compute what's changed since the last backup. That computation doesn't come for free.

    Also, it will back up all files that have changed since the last backup (except for folders that you've excluded from backup). This might include things like your browser cache (which changes all the time).
     
  3. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #3
    Are you running Parallels or VMware fusion? IIRC anytime the VM changes time machine backs up the whole VM that's on disk. If you are running those, try excluding the VM directory. I have a 24" iMac and the only thing I notice about time machine is that I hear the external disk spinning up. I have a few things excluded, especially all external disks.
     
  4. ks-man thread starter macrumors 6502a

    Joined:
    Sep 25, 2007
    #4
    I am running VM Fusion through a Bootcamp directory. How do I make sure to exclude that?
     
  5. crackbookpro macrumors 65816

    crackbookpro

    Joined:
    Feb 25, 2009
    Location:
    Om nom nom nom
    #5
    I notice the same thing. But for me, it is such an important backup system that I can't complain... ;)
     
  6. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #6
    Click on the time machine icon, then on open time machine then on Options then you get a window of "Do not back up:".. I tell it to not look at all external disks plus a work directory where I temporarily save web page images.

    There was another thread a while back about people complaining of the size of time machine backups when running VM/Parallels. You could find it via an mroogle search.
     
  7. ks-man thread starter macrumors 6502a

    Joined:
    Sep 25, 2007
    #7
    I'm not sure if this is the thread you were talking about:
    http://forums.macrumors.com/showthread.php?t=391445&highlight=time+machine+fusion

    I think my situation is different since I'm running VM off of a Bootcamp partition. The bootcamp partition is in the Exclude list. My VM application folder isn't but it isn't that large (only 120MB). I guess I can include that folder but I wonder if the problem I'm having is related to something else.

    Is anybody else doing a wireless backup and not noticing slowness?
     
  8. ks-man thread starter macrumors 6502a

    Joined:
    Sep 25, 2007
    #8
    Any other ideas on why Time Machine completely slows down my computer since my Bootcamp partition isn't included in the backup?

    Thanks.
     
  9. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #9
    Technically what's happening is that your computer has to handle WiFi hardware down at the bit and byte level inside a part of the OS they call an interrupt handler. Once inside there it stays until the job is done. So if your mouse happens to move while the computer is dealing with an interrupt from the network hardware the software that updates the cursor just has to wait.

    another way to look at it. If the CPU is 50% busy doing stuff that can't be interrupted then when it comes time to move the cursor on the screen there is a 50% chance the CPU will be tied up doing something else that is more important.
     
  10. ks-man thread starter macrumors 6502a

    Joined:
    Sep 25, 2007
    #10
    So I guess this may be the answer to the original question I had. It sounds like the reason I am having this problem is b/c I am doing wireless backups. I read a lot of other people not noticing any slowdown when doing TM backups, but you are saying that people should expect it with wireless backups?

    Assuming that is all correct, is there a way to slow down my backups to either every 6,12 or 24 hours? I don't mind the slowdown if it is due to wireless backups (which makes everything a lot cleaner), but I don't want to have to constantly deal with the slowdown or manually stop the backup. Ideally I can tell it to backup less frequently.

    Thanks.
     
  11. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #11
    Time Machine indexes the back up with Spotlight that's usually why it slows down a bit.
     
  12. rtrt macrumors 6502a

    Joined:
    Jan 19, 2008
    #12
    try timemachine editor to space the backups out
     
  13. Tyr. macrumors member

    Joined:
    Aug 1, 2007
    Location:
    Antwerp, Belgium
    #13
    It's probably the disk access. Time machine has to read files from all over your HD to send to the backup, if you're doing something else that requires a lot of disk access, like running a virtual machine for example (which will be doing its own disk I/O in its drive image on another part of the drive) the drive heads have to shift position back and forth all the time causing a drop in I/O performance which will become a bottleneck for your system.
     
  14. Alka-sneltzer macrumors newbie

    Joined:
    Oct 26, 2009
    #14
    I have the exact same problem with my Imac 24 running 10.6.1 with a 2.8 GHz Intel Processor, 4GB RAM, and more than enough hard drive for a lifetime. Time capsule is brand new, out of the box 2TB. Have a new Macbook Pro with the 3.08GHz processor, same RAM, and comparable hard drive. Runs all the same programs. Back ups are not even noticeable on the Macbook. Wonder if this issue is isolated to DDR2 processors. Any guesses?
     

Share This Page