Why don't my computers detect my iPhone's personal wifi hotspot immediately?

Discussion in 'iPhone' started by slapple, Mar 15, 2017.

  1. slapple macrumors 6502

    Joined:
    Jul 25, 2008
    #1
    When I tell my iPhone SE to enable the Personal Hotspot (with T-Mobile), it seems like my computers (both Windows and Mac) don't show the iPhone in the list of available Wifi networks immediately. Sometimes it takes 5-10 minutes before the iPhone finally shows up, even when the iPhone is physically right next to the computer. Does this happen to anyone else?
     
  2. addamas macrumors 6502

    addamas

    Joined:
    Apr 20, 2016
    #2
    Well, I also have to reenable hotspot on my SE 10.2 JB to make it visible on Windows 8. So you are not alone
     
  3. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #3
    Weird, mine comes up within 5-10 seconds.
    Did you try refreshing your computers network list so it looks and scans again for available networks?
     
  4. boltjames macrumors 68030

    boltjames

    Joined:
    May 2, 2010
    #4
    Took me awhile to find the answer to this question which is:

    You need to be on the Settings > Personal Hotspot screen of your iPhone when you make the initial attempt to connect. Once your iPhone is awake and on that screen, it shows up in seconds and connects flawlessly until the next time your computer disconnects (say you put it to sleep or shut it down for the night).

    Go to the Settings > Personal Hotspot screen for the connection each time your computer is disconnected or re-awoken, problem solved. Make sure wi-fi on your iPhone is turned on, of course.

    BJ
     
  5. noobinator macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Los Angeles, CA
    #5
    Mine never shows up reliably. I toggle it off and on on my phone and refresh my wireless connections on my computer and eventually it shows up.
     
  6. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #6
    On the Mac you should be able to find an Instant Hotspot without even enabling it on the phone nearly....instantly....
     
  7. posguy99 macrumors 6502

    Joined:
    Nov 3, 2004
    #7
    As long as both machines are logged into the same iCloud account.
    --- Post Merged, Mar 15, 2017 ---
    Nope, it doesn't matter where you are in the iPhone GUI, it matters whether the iPhone has determined that there are no clients and has shut down the hotspot. But that time is measured in minutes, not seconds.

    All you're doing by staying on the hotspot settings screen is ensuring the phone doesn't shut the hotspot down.
     
  8. boltjames macrumors 68030

    boltjames

    Joined:
    May 2, 2010
    #8
    What I can tell you is that I was suffering from the same frustration as the OP until I left the personal hotspot screen in the foreground. From that moment forward, I've had 100% connectivity, I must be 50 for 50 right now, batting 1.000.

    When I did what I thought was intuitive- navigated to the personal hotspot screen, turned it on, then closed it and switched to the home screen, email, etc.- I could not connect, I was 0 for 50, was very frustrating.

    What I think you may be overlooking here is that it's the initial handshake that's the problem. Once you're connected for the first time in a given day it sticks just fine. But booting a computer up cold in the morning and trying to locate your iPhone hotspot, doesn't ever happen for me unless I have the personal hotspot screen in the foreground.

    Perhaps it's a Windows 10 quirk. Most iPhone users aren't MacOS users by quite a wide margin.

    BJ
     
  9. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #9
    Manually turning my iPhone wifi hotspot on devices detect it nearly immediately and always on their first wifi refresh (MacOS ~10 seconds so = or <10 seconds), AppleTV and PS4 see it nearly immediately (I think they must refresh faster). If I use a wifi monitor its there about a second or two after I enable it.

    Since its happening on Mac and PC if you haven't already I would try reseting the phone (iPhone SE home + lock buttons until you see the Apple logo) see if that makes a difference. Might want to try rebooting the Mac and PC too just because...wifi gremlins....
     
  10. deano1972 macrumors 6502a

    deano1972

    Joined:
    Sep 16, 2016
    Location:
    United Kingdom
    #10
    This always works for me on my iPhone 7
     
  11. yep-sure macrumors 6502

    yep-sure

    Joined:
    Sep 21, 2012
    Location:
    Melbourne, Australia
    #11
    Because it's really unreliable and was poorly designed/implemented.

    It's why I switched over to a cellular iPad from wifi. The iPhone personal hotspot is just way too temperamental to use in the real world, and cannot be relied upon.
     
  12. MacVault macrumors 65816

    Joined:
    Jun 10, 2002
    Location:
    Planet Earth
    #12
    No matter what I seem to try I cannot get the Personal Hotspot feature to work. Call Apple last week, they finally told me to do a software restore, I did restore to iOS 10.3.2 yesterday. Cannot connect via Wifi, Bluetooth or USB!! Call Apple today, spoke with Senior level tech, he's stumped and reaching out to their engineers. I've confirmed with AT&T that my plan allow for hotspot teathering. I've pulled my SIM out of iPhone, inserted it into a new Google Pixel phone and hotspot works great from Pixel phone. Put it back into iPhone and cannot get hotspot to work in any fashion. WTH!! ?? So damn frustrating!! Client devices see the wifi / bluetooth hotspots, seem to connect to the wireless network layer but do not get IP address and therefore end up with self-assigned 169.... address. I've tried assigning statically the 172.20.10.0 network but still nothing. Cannot connect via USB either. It shows up in the Windows 10 network settings window but has a red X. Does anyone know how to fix this??
     
  13. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #13
    This may not help you, but it's the only thing I found.

    https://forums.att.com/t5/Data-Mess...nal-Hotspot/m-p/3361825/highlight/true#M60495
    http://www.qdinformation.com/iphone/is-your-personal-hotspot-not-working-try-this

    Second link is based off the first (same solution).

    No idea if doing this will help you or not, but worth a shot at this point.

    A self-assigned IP address means you are connecting to the hotspot. You're just not getting a gateway and a proper IP because the device isn't passing the network on.

    If this does not work I hope Apple support can find a solution for you.
     
  14. MacVault macrumors 65816

    Joined:
    Jun 10, 2002
    Location:
    Planet Earth
    #14
    eyoungren, thanks for the tip, however, after turning off facetime under cellular i still have same problem. Apple is suggesting it's a problem with my SIM although the same SIM does hotspot just fine in my Google Pixel phone.
     

Share This Page