Why has the new Epson Printer Drivers killed my Epson Stylus DX4400 printer? Help!!

Discussion in 'Mac Accessories' started by mogzieee, Oct 14, 2009.

  1. mogzieee macrumors 6502a

    Joined:
    Feb 8, 2008
    Location:
    London, UK
    #1
    Right folks.

    The day before yesterday, I had a perfectly normal working Epson Stylus DX4400 printer that worked seemlessly with my MacBook Pro. I was happy.

    Yesterday, I downloaded the newest Epson Printer Drivers (the one linked from this Page 2 article), installed them fine.

    Today, I go to print using the DX4400, and it doesn't work... at all. There is an error that appears in the printer dialog box (screenshot below)

    [​IMG]

    Not good eh. However, incidentally, I tried using an Epson Stylus Photo R300 printer today, and that worked absolutely fine, which didn't work at all (wasn't recongized) the day before yesterday. Great.

    Having done a little reseach on this Apple support article, it turns out the the DX4400 has an asterisk to say that the printer's software has been updated recently... so it should be working!?

    But if anyone knows how to cure this problem (given the error in the screenshot above) that would have massively helpful.

    Thank you very much, in advance.


    Edit: For those interested, this issue is for all types of documents I try printing - not just the document in the screenshot. Also, when I try using the scanning function on the DX4400, I just get an "error occurred during scanning" message. While the printer does make noise, and sounds to be preparing for a scan/print like it normally would, the document is just not being sent through.
     
  2. mogzieee thread starter macrumors 6502a

    Joined:
    Feb 8, 2008
    Location:
    London, UK
    #2
    Problem solved.

    Folks, I solved the problem, so here is how you fix the problem should anyone else have the same problem.

    In the printer dialog box (as in the screenshot above), click on Printer Setup.

    On this, select the Driver tab.

    You should see a currently selected "Epson DX4400 Series" option. This is the bit that's wrong!

    Click on the drop down, and select Select Printer Software.

    From the big long list here, select the big long option Epson Stylus DX4400 - Gutenprint v5.2.3

    Press OK and you're good to go. :)
     
  3. dancoxdrums macrumors newbie

    Joined:
    Nov 2, 2009
    #3
    I've had the same error. I tried the fix above and the printer has functioned a couple of times, albeit very, very slowly and somewhat erratically, but now is telling me I have no ink (which I do). Supply levels on the utility app are apparently not available.

    Sounds like these 'gutenprint' drivers are probably foreign and will only provide limited functionality.. anyone got any ideas?
     
  4. quantum003 macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #5
    Snow Leopard? One of my co-workers does a ton of commercial printing for his business and claims his Macs stopped talking to his Epson printers when he upgraded to 10.6. He says he's done all the printer updates available both from Epson and from Apple but no success. I showed him how to boot up Leopard from an external drive, now he boots into 10.5 every time he needs to print from one of his Epsons as a workaround.
     
  5. JanB macrumors newbie

    Joined:
    Oct 3, 2007
    #6
    Have tried the fix - so far so good. Very slow but there again the printer is a slow printer anyway.
     

Share This Page