Why IMAP? It's such a mess!

Discussion in 'Mac Apps and Mac App Store' started by Nostromo, Nov 8, 2011.

  1. Nostromo macrumors 65816

    Nostromo

    Joined:
    Dec 26, 2009
    Location:
    Deep Space
    #1
    I never had any problems with gmail when it still worked with POP.

    IMAP=problems.

    It used to be that all emails were at Gmail's servers, and you downloaded the emails. When you deleted them, they were gone from your computer.

    Now, with IMAP, it's the other way round.

    Gmail stores all the mail on my computer. I once deleted the thousands of mails - and the next day they were all back. I have no interest in keeping a copy of every email. I want them gone.

    I cannot find any preference that says: don't store "all mail" on my computer.

    Or has anybody found a way to tame IMAP (it installed about 24 mailboxes on my computer, six per email address). It's a mess!
     
  2. orest macrumors newbie

    Joined:
    Jun 9, 2011
    Location:
    Austria
    #2
    Under the accounts > advanced tab try "don't keep copies of any messages" in the offline viewing settings.
     
  3. HellDiverUK macrumors 6502

    Joined:
    Oct 24, 2009
    Location:
    Belfast, UK
    #3
    IMAP has been fine for everyone else for 20 years, so you're obviously doing something wrong.
     
  4. johnmacward macrumors regular

    johnmacward

    Joined:
    Jul 12, 2011
    #4
    I agree, it's absolutely prefect for me through iPhone mail and OS X Mail and I've used it no problem with Thunderbird in Windows either. Now if you're using it with Outlook, then welcome to ****ing hell because it's implementation of IMAP is horrendous.

    Within the Apple ecosystem you should use the simple Gmail wizard that's provided to set it up, not do it manually with mail servers, port numbers, authentication because it's damn complicated that way.
     
  5. hinchesk macrumors member

    Joined:
    Nov 29, 2007
    Location:
    Canada
    #5
    IMAP used to be a bit of a problem with Apple Mail so you needed articles like this.

    Now since Apple included automated account setup in Lion under System Preferences > Mail/Contacts/Calendar, things have gotten a lot easier. Upgrade to Lion if you haven't yet... it'll make things easier and how can you go wrong with the price.
     
  6. Nostromo thread starter macrumors 65816

    Nostromo

    Joined:
    Dec 26, 2009
    Location:
    Deep Space
    #6
    Thanks for the article.

    My settings are the same as the article recommends, but the key difference as for me:

    a. not a single email is in my gmail inbox

    b. All mail, even deleted mail, is present in one copy in the "All Mail" folder. (thousands of them. When I delete them, they are back the next day. So THE MESSAGES MUST BE ON THE SERVER - but the inbox doesn't show them. Show inbox is on by default).

    I would like to have it as it used to be a year ago.


    1. Have only emails on my computer which I did not delete.

    2. Have all mail in the gmail inbox on the server.

    I read all the articles about ideal settings and copied them, but I can't see why it still doesn't work.
     
  7. Kenndac macrumors 6502

    Kenndac

    Joined:
    Jun 28, 2003
    #7
    That's not how IMAP works. The idea of IMAP is that everything is in sync with each other. The "inbox" on your computer and the "inbox" in Gmail is actually the same thing with IMAP.
     
  8. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #8
    Just curious, but do you have your IMAP path prefix set to [Gmail] in the Advanced settings? Reading the description of your issues, it sounds like you don't.
     
  9. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #9
    The All Mail in Gmail is an odd one compared to other mail services, the idea of this is that it contains everything (included deleted mails)

    If you go to the Gmail website and the settings for mail, you can tell it to hide the All Mail folder from IMAP clients, this makes it look like other IMAP services
     
  10. Nostromo thread starter macrumors 65816

    Nostromo

    Joined:
    Dec 26, 2009
    Location:
    Deep Space
    #10
    Does this mean that all those mails are actually stored on my computer?

    Why don't they show up on the gmail server (Inbox always empty).

    This may be the info I need.

    Could you explain what this IMAP path prefix is, and how I set it up?

    Much appreciated!

    I was exactly looking for that, went through the "recommended settings", but could not find it.

    If you have a link how to make the "All Mail" box disappear, it would be much appreciated!
     
  11. radek42 macrumors regular

    Joined:
    May 27, 2008
    Location:
    Here, there, and everywhere
    #11
    I used to use POP3 in the past, but switched to IMAP when my University switched to gmail apps. I keep all e-mail on the server ... nothing on my computer. I use thunderbird under Linux. I think of IMAP (Outlook, TB, etc.) as a nice(er) web mail application; that's all it is.

    I think when you say "emails are back" it only means they are still on the server; perhaps with delete flag. I'd try emptying trash and see. Also you might try using webmail client to check what is going on.

    I believe when you delete message under gmail it is not really deleted; it receives "delete" flag. I think it's gone once you empty your e-mail trash ...

    Btw, I tried setting up IMAP under Outlook 2011 on my wife's MBP ... not good! Not at all. That was a mess. I never used Outlook so I cannot comment if it's Outlook itself or its Mac version ... i tried to get copies of her email stored locally, but I could not find an easy way. At the end I went for custom actions on all incoming mails and made a copy to a local folder ... still, not good. If you execute that action you get multiple copies .... brrr.

    Well, enough said :)

    Have fun! R>
     
  12. Le Big Mac macrumors 68020

    Le Big Mac

    Joined:
    Jan 7, 2003
    Location:
    Washington, DC
    #12
    The problem here is not IMAP but rather gmail's implementation of IMAP.

    Gmail doesn't believe in a trash can. Instead it "archives" messages. That means even when you delete them they are stored in the "all mail" folder. I personally hate that as well.

    So, you have to tweak the settings in gmail online,

    Under labels tab: hide the "all mail" folder.
    under IMAP access tab select "when message is marked as deleted . . . move to trash"

    ----------

    Settings-->labels.

    See my post above for further instructions.
     
  13. Nostromo thread starter macrumors 65816

    Nostromo

    Joined:
    Dec 26, 2009
    Location:
    Deep Space
    #13
    The lavel for "all mail" has been on "hide" for a long time - the "all mail" folder was still on my computer.

    Now I switched "auto-expunge" off - you have to do that in order to choose the option "move deleted mail to trash", which setting I turned on now.

    With the existing email, there is no change. Looks like I have to delete a few thousand emails by hand in order to clean up my mail.


    I just wonder why there is no response to "hide all mail in imap"? It's still showing.
     
  14. Nostromo thread starter macrumors 65816

    Nostromo

    Joined:
    Dec 26, 2009
    Location:
    Deep Space
    #14
    Well, I tried everything that was suggested in this thread, and still: my "All Mail " folder is big and fat on my Mac, and the inbox at gmail/google apps mail is still empty.

    I have also posted a question on the Gmail/google help forum (which is a waste of time as no questions there ever get answered).

    I'm sick with this "free stuff": free email, free everything, and when something goes wrong there is no one you can contact.

    Google is the nightmarish company of the future that has no customer service, and you can endlessly try to fix problems with their products.

    I'd rather pay for an email service every month.
     
  15. waynep macrumors 6502

    Joined:
    Dec 31, 2009
    #15
    It's not hard. Check this out . . http://email.about.com/od/macosxmailtips/qt/et_gmailosxmail.htm

    I use gmail with the Mac Mail app all the time.

    IMAP = sync'ing your mail. What you see via the web interface is what you are going to get in the Mac mail app. If you have 2GB of mail in you gmail account, you will be able to see all that in your Mail app.
     
  16. Nostromo thread starter macrumors 65816

    Nostromo

    Joined:
    Dec 26, 2009
    Location:
    Deep Space
    #16
    None of my key problems is mentioned in this article.

    1. Why is there not a single email message in my gmail account?

    2. All messages show up in "All Mail".

    When I delete all messages in "All Mail" and restart Mail, they are all back.

    So the messages are on the gmail server, but they don't show in the inbox.


    I want them to show on the gmail server, but I don't want all those messages in "All Mail" on my computer.

    So far, I have not found anything on the web that could solve this basic problem.
     
  17. jdavtz macrumors 6502a

    Joined:
    Aug 22, 2005
    Location:
    Kenya
    #17
    Maybe there's something corrupt with your gmail account... or perhaps Apple Mail folders somewhere.

    How about trying a brand new gmail account, on a brand new user profile on your computer?

    If that works as expected, then either try your old gmail account in the new user profile, or the new gmail account in the old user profile, and see if you can isolate what's going wrong.

    As everyone else says, it works fine for the rest of us so it's not a generic gmail/apple mail problem; there's something specific to your setup or account or computer that's making it behave abnormally.
     
  18. Nostromo thread starter macrumors 65816

    Nostromo

    Joined:
    Dec 26, 2009
    Location:
    Deep Space
    #18
    I have an old gmail, and a new google apps gemail account, and both behave the same odd way.

    So I'll look into the user profile thing that you mentioned.

    Thanks for the tip!
     
  19. djc6 macrumors 6502

    Joined:
    Aug 11, 2007
    Location:
    Cleveland, OH
    #19
    There are a whole bunch of quirks to getting IMAP working for Gmail because of differences between folders in IMAP and labels on Gmail. I could never get it working 100% so I ended up going webmail only.

    Here is some information about how deleting a message via IMAP in Gmail works - it only removes the label corresponding with the IMAP folder the message is located in, it doesn't actually move the msg to the trash:

    https://mail.google.com/support/bin/answer.py?hl=en&answer=78755&topic=1668961

    More reading for you - these were once optional settings (enabled by using a 'google lab' called advanced imap controls) but these settings are now built into gmail:

    http://groups.google.com/group/Gmail-Help-POP-and-IMAP-en/browse_thread/thread/0e294c5b3cf59a6e

    I suspect you want to make the following changes to your account:

    Go into Gmail (webmail) settings and the click "Forwarding and POP/IMAP" tab and look under "IMAP Access"

    For "When I mark a message in IMAP as deleted" select "Auto-Expunge off - Wait for the client to update the server."

    For "When a message is marked as deleted and expunged from the last visible IMAP folder" select "Move the message to the Trash".
     
  20. Nostromo thread starter macrumors 65816

    Nostromo

    Joined:
    Dec 26, 2009
    Location:
    Deep Space
    #20
    I did both of the changes you mentioned a few days ago, and it didn't make a difference.

    The only thing that made a difference was "store Junk on the server". Now the junk is gone from my Apple Junk Inbox - but it doesn't show on the server.

    I only have 2 email messages there (within 2 months!), one from Google confirming my report of the problem, and one email from a Google help forum.

    All the other mail is there, but it's "hidden".

    Why I know it's still there: when I delete everything in the "All Mail" folder, and restart Apple Mail 4 - all the messages are back (including the ones I deleted).

    I guess I'll have to change the setting from "move deleted messages to trash" to "delete messages right away".

    I'll also look into my account on my Apple - maybe there's a bug there.
     
  21. djc6 macrumors 6502

    Joined:
    Aug 11, 2007
    Location:
    Cleveland, OH
    #21
    You should hide "All Mail" from IMAP (go into webmail, settings, labels). I don't expose it to Mail.app as it has no equivalent in IMAP parlance - there is no folder on an IMAP server that contains the mail of your entire email hierarchy. Plus its unnecessary to sync via IMAP "All Mail" - those messages should exist in other folders.

    Any deleting from All Mail should be done via the webmail interface (IMHO). I'm not sure what happens when you delete a msg inside All Mail via IMAP - Gmail's documentation indicates that deleting a msg via IMAP removes the corresponding label, but there is no "All Mail" label - so its not going to remove anything. If you want to delete your All Mail msgs, you'll need to do it from webmail.

    Those settings changes you made will only matter for emails received after you made the settings changes. Emails you've previously deleted have had their labels removed and the msgs have been archived. To delete, you need to go into All Mail *via webmail* and delete them.
     

Share This Page