Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors 6502
Original poster
May 1, 2007
I have been using iPhone in the car. I choose shuffle everytime. However, I always get the same songs (not the same order). And there are lots of songs that never have played..
Is that iPhone's shuffle problem??


macrumors regular
Sep 14, 2007
Are you sure you are not asking it to shuffle the contents of just one playlist? Make sure you have selected songs on the bottom row of options when you open iPod. If you have, then I assume its just selecting the same songs randomly.


macrumors 65816
Aug 24, 2007
Are you sure you are not asking it to shuffle the contents of just one playlist? Make sure you have selected songs on the bottom row of options when you open iPod. If you have, then I assume its just selecting the same songs randomly.

I too have this problem - I have a 500 song playlist and it probably plays 50 songs 75% of the time. I get repeats of several songs all the time, and there are dozens of songs it's never played.

I've already performed a hardware reset. I also tried taking that playlist and instead of making it just all my favorites, making it limited to 500 exactly (out of around 550 possible songs) hoping that the fact that the list would change constantly, that would help. Of course, it never seems like that 500 limit actually causes 50 songs to be removed from and added to the list at all. :(


macrumors newbie
Sep 15, 2007
"Best iPod ever" my A$$!

I'm experiencing the same 'psuedo-shuffle' bollocks. Another bloke I know with an iphone is as well. I've tried everything I can think of (including hardware reset). In fact, I just got a brand new unit (genius swap out) and the problem remains. Any help?

While I'm on the subject of ways in which the iPhone's ipod sucks my ass, has anyone noticed the following: When the title of a song or album is too long to fit on the screen, on my nano the full title will scroll across like a banner. This does not happen on iPhone, not in any of the viewing formats. Bollocks. This is especially annoying when you might have 4 or 5 different remixes of the same song, for instance: "The New Definition of War (featur....." Where the nano (and all other iPod's) would scroll the full title across, the iPhone just sits there; staring back at you.

Best iPod ever, my ASS!


macrumors newbie
May 29, 2008
fix constant repeat of song on iphone

This was driving me nuts and I just found the resolution on another site and thought I'd share it here since there was not any resolution here.

Once you have your playlist displayed start the first song. Tap on the album art and the Playhead will appear. The Playhead tells you how much time the song is in minutes:seconds; elasped time on left, remaining time on right.

On the left side of the Playhead is the Repeat icon (it looks like a race track). Tap it to make a selection.

Black=repeat one song
Blue=repeat all songs
Blue with black head=set to repeat current song
Black and white=not set to repeat songs

On the right side is the shuffle incon (it looks like two crossed lines with arrows to the right). Tap it to make a selection.

Black=play songs in order
Black and white=set to play songs in order
I found the fix here


macrumors newbie
Mar 25, 2009
True Shuffle can help you out!

I wrote True Shuffle to help out with the problem of iPods/iPhones playing the same songs over and over... True Shuffle lets you listen to every song you own, without any repeats, until you've heard them all! And you can ban any songs you don't like.

Check it out -


macrumors 65816
Nov 17, 2010
Bumping this old thread, it looks like they've fixed it in the latest update. When I random all my songs and a studio track comes up, the live track isn't the next one or vise versa.


macrumors member
Sep 29, 2009
Same problem here

I have had the same problem with iPhone, iPhone 3G, and iPhone 3GS. I have had each version of iOS along the way, and I haven't seen any improvements.

I ended up working around it by making smart playlists in iTunes that contain songs with 0 plays or 1 play, etc. I sync these playlists to iPhone so that I can hear some songs that my phone never plays when in shuffle.

I have 3686 songs on my iPhone, and it's a shame that it seems to play the same songs each day when I have it on shuffle. Gets old after a while.


macrumors newbie
May 14, 2011
I've had this exact same issue. I have about 900 songs. After updating to 4.2.1 I recopied all the songs to my iPhone and initially when I started playing them I noticed it would play the same versions of the song (like live or by another singer in succession). After a few days I once again deleted the songs and copied them again. Now I used the shuffle option and started playing them. For some time it worked out great. It played about 250 songs and there were no repeats. Recently again it started playing the same versions of the song in succession. That annoyed me. So I went in and hit shuffle again. Now, almost 9 out of the 10 songs it's playing are repeats of the 250 or so songs it's already played. This thing is getting on my nerves. Why the * can't apple give an option that says "Don't play the same again until all other songs have been played"?

Never been an apple fan and this was my first purchase (and possibly last). I only bought the iPhone due to it's lovely screen but since Apple just loves to control everything so much (and also given the fact that android is always improving and apple refuses to add bells and whistles to their iOS...lets see if they add some good features to iOS 5) I'm seriously thinking of ditching them when it's time to buy my next phone.


macrumors newbie
Aug 3, 2011
Potential Solution

From what I understand, shuffle is not "Random" because it gives priority to tracks with a higher play count (it assumes you like them best which is a poor assumption). Sadly, there is currently no way to turn off the play counter. The best you can do is go into iTunes, reset the counters and then sync your phone. This will give you a "blank slate" for shuffle. but very quickly you will begin to see the same ones reappearing so you will need to reset the counters continuously... not cool.

Another solution i'm looking into is to make a playlist called "All songs" and hit the "Add all songs" button. The goal of a playlist is to play every track on it, without repeats so this may be a better option. Yet, whether it will continue to give order priority based on the play counter I cannot yet say. I will continue to investigate... but so far so good.

If you want to use the playlist "solution" don't forget to delete your playlist and make a new one after every sync otherwise it will be missing any new songs/albums you added since the last sync! (This just occurred to me.)

Hope this helps someone somewhere... :)
Last edited:


macrumors newbie
Dec 13, 2011
Final solution

Helllo guys,
I bought new apple shuffle for my gym purpose... i faced the same prob :)
I really wondered when i start to play the songs, it was playing songs fine till i touch the VoiceOver button :)
The real problem is it has default playlist called ALL SONGS which contains a single sample song..... so when i press the VoiceOver button
i mistakenly pressed the rewind(|<<) button also. so what happened is it selected the previous playlist called ALL SONGS. Then only i got to know that we can have multiple playlist in Apple shuffle. If you want to switch to another playlist, just hold the VoiceOver button and press rewind or forward button to move next playlist while its saying the playlist name :) ..
i have seen in this forum that some of the guys want to hear repeat song:)
so they can use this method :) they can create new playlist and place the song which they want.. and they can select the playlist and can enjoy
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.