Why is copy and paste in Safari so flaky on iOS 8?

Discussion in 'iOS 8' started by saintforlife, Nov 30, 2014.

  1. saintforlife, Nov 30, 2014
    Last edited: Nov 30, 2014

    saintforlife macrumors 6502a

    Joined:
    Feb 25, 2011
    #1
    I am on the latest version of the iOS on my iPhone. Sometimes I like to copy and paste paragraphs from articles when posting on online forums, but many times when I copy something and try to paste it, the paste animation disappears very quickly (less than a second) and it doesn't allow me to post the text that I have copied over. Sometimes it is almost a race between the animation disappearing and me hitting the paste button. I have never had this issue with any of the previous iOS versions and my work flow hasn't really changed at all.

    Anybody else face this issue? Is there a work around?
     
  2. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #2
    At first I thought it was just a buggy iOS 8.0.0. When it was still there in iOS 8.1 I thought it was just me and my 5S. So yes, I've experienced this issue :(
     
  3. Traverse macrumors 603

    Traverse

    Joined:
    Mar 11, 2013
    Location:
    Here
    #3
    Bugs. It's so annoying when I double tap a text entry filed and the "Cut Copy Past" pop up shows up for a fraction of a second and then vanishes
     
  4. I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    What Exit?/Saguaro Country
    #4
    Yes, I've noticed this as well. And I agree annoying.
     
  5. bandofbrothers macrumors 601

    bandofbrothers

    Joined:
    Oct 14, 2007
    Location:
    Uk
    #5
    Hi



    I have noticed that on occasion the whole section I've Copy and Pasted isn't complete. It may just be a few letters or word missing but it's still annoying.
     
  6. sviato macrumors 68020

    sviato

    Joined:
    Oct 27, 2010
    Location:
    HR 9038 A
    #6
    I haven't tried the double tap method, I usually hold the highlighted text and the menu pops up and works.

    An issue I'm having is that quite often it just won't copy what I selected and when I paste, it instead pastes either nothing or something I've previously copied. And it does highlight "Copy" when I hit it in the menu so it seems like it just does nothing sometimes. It happens often enough to be annoying now.
     
  7. sanke1 macrumors 65816

    sanke1

    Joined:
    Nov 9, 2010
    #7
    The same thing happens to me in Evernote iOS 8.1.1 on iPhone 5c

    The damn menu disappears in fraction of a second.
     
  8. Rhonindk, Dec 1, 2014
    Last edited: Dec 1, 2014

    Rhonindk macrumors 68020

    Rhonindk

    Joined:
    Oct 3, 2014
    Location:
    Bloom County: Meadow Party
    #8
    Been a pita since 8.0.0
    Have this and similar issues on my 6+ and Mini 2.

    on the Mini 2 I also have the opposite: the menu won't go away unless I select an option.
     
  9. poe diddley macrumors regular

    Joined:
    Jun 5, 2005
    Location:
    greensboro nc
    #9
    I experince the same issue daily. Along with other Safari problems that did not exist until ios 8.
    IPad mini 1st gen
     
  10. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #10
    This is perhaps one of the main issues I run into often enough to find it at least annoying. Been happening on and off on my iPhone 5 since 8.0 days (being on 8.1.1 now).
     
  11. dannyyankou macrumors 604

    dannyyankou

    Joined:
    Mar 2, 2012
  12. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #12
    [MOD NOTE]
    Lets get back on track, this is not a discussion about Android, so those posts were removed.
     
  13. MartyCan macrumors 65816

    MartyCan

    Joined:
    Oct 31, 2012
    Location:
    Near Toronto, ON
    #13
    I have the same problem as the OP.

    In addition to that I am having terrible time trying to locate the cursor correctly when filling a form on a forum such as this. It is not dropping in the right place relative to where it was in the magnified area.

    Another issue is that when the keyboard pops up it covers the area where I intend to type so I can't see what I am typing without manually scrolling the web page. This used to happen automatically.

    There are serious problems here and it is causing a very negative user experience.
     

Share This Page