Why is Finder so slow?

Discussion in 'macOS' started by Fancuku, Nov 29, 2015.

  1. Fancuku macrumors 6502a

    Fancuku

    Joined:
    Oct 8, 2015
    Location:
    PA, USA
    #1
    I have only been using Macs since February so I am somewhat new. One thing that really pisses me off is how slow Finder is especially when opening folders from a network share. It car take a minute or two sometimes to open folders from my NAS that have lots of files in them (anywhere from 200-500 pictures).
    Why is Finder so slow? Is it a Unix thing? I also run Linux on my mid 2014 rMBP and it's the same thing there too.
    Windows Explorer has no trouble opening these same folders. It usually takes 3-4 seconds to open folders that have lots of files in them.

    I find Finder unacceptable. I don't really like using 3rd party programs but I may have to try a 3rd party file manager. Any suggestions?
     
  2. prisstratton, Nov 29, 2015
    Last edited: Dec 4, 2015

    prisstratton macrumors 6502

    prisstratton

    Joined:
    Dec 20, 2011
    Location:
    Winnipeg
    #2
    I cannot give you a definitive answer, but I will recount my personal experience and hope that you find it useful.

    When I was using a Time Capsule (basically a NAS) as a repository for all of my files, the one thing that always bothered me was that it was VERY SLOW to access any files. I was always surprised by this seeing as it was another Apple device on the network.

    I eventually switched to a dedicated (Mac) server and response times are very much improved (in fact, great).

    I can still see that the OS takes time to connect to the server (I let the server sleep the drives), but once the connection is established (literally seconds at most) my browsing of the files is the same as if they were on my local HDD.
     
  3. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #3
    Try:

    Go to the root share, right click -> Show Vew Options and turned off Show Icon Preview.

    Unmount and remount the share.
     
  4. MacGizmo macrumors 6502a

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #4
    This is most likely a server-to-Mac issue. I run an iMac and a new MacPro at work, both maxed-out on processor, RAM, video card and SSD drive, and connect to a Windows server. It's staggeringly slow to access folders & copy files—even folders with just a few files in them.

    Turning icon previews off will help, but it's still going to be slow. The only fix is to run an Apple server, or have an I.T. guy who knows what he's doing to configure the server properly.

    Of course, it also depends on what version of the Mac OS you're running and the hardware configuration...
     
  5. Fancuku thread starter macrumors 6502a

    Fancuku

    Joined:
    Oct 8, 2015
    Location:
    PA, USA
    #5
    It can't be a server issue. Windows Explorer has no problem. Everything opens quickly.
    I am running El Capitan on a mid 2014 15" rMBP. It's a Western Digital MyCloud EX2 NAS which runs on Linux.
     
  6. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #6
    So, did you try turning off "Show icon preview"?
     
  7. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #7
    Also, on the Mac, go to System Preferences>Spotlight>Privacy and add the NAS to the privacy settings so that Spotlight does not try to index it.
     
  8. Fancuku thread starter macrumors 6502a

    Fancuku

    Joined:
    Oct 8, 2015
    Location:
    PA, USA
    #8
    Yes and it made no difference.
     
  9. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #9
    BTW, can you tell us about your network configuration? Are you connected by wireless or ethernet?

    If wireless, what protocol are you connecting with, N or AC? What brand router do you have? Use free Netspot (www.netspotapp.com/) to check for signal strength and post back a screenshot here.).

    If wired, is your Mac connected through a switch or router and is it a Gigabit router? Check to make sure your cables are either CAT5e or CAT6. (You won't get Gigabit speeds if you use CAT5 cables).
     
  10. Fancuku thread starter macrumors 6502a

    Fancuku

    Joined:
    Oct 8, 2015
    Location:
    PA, USA
    #10
    The router is an Asus RT-AC68P. It's a 2015 model and cost me $200 in February. I am using the wireless AC connection.
     
  11. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #11
    Are you connected on the 2.4 Gig channel or the 5 Gig channel?

    Also, is the NAS connected to the USB3 port on the router (I understand it has both USB3 and USB2 ports).

    Does it make a difference if you move the Mac right beside the router?

    Also have you tried excluding the drive from Spotlight indexing?
     
  12. Fancuku thread starter macrumors 6502a

    Fancuku

    Joined:
    Oct 8, 2015
    Location:
    PA, USA
    #12
    5GHz channel. NAS is connected to one of the gigabit ports on the router. It makes no difference where the Mac is.
     
  13. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #13
    Is the cable between the router either CAT5e or CAT6? You won't get gigabit speeds if the cable is CAT3 or CAT5. (It should be written on the cable)
     
  14. campyguy macrumors 68030

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #14
    I've got several servers and NAS units in my office and home office and have had issues. I narrowed it down to the cloudd process, and now periodically clear out the caches on my Macs. I could write more, but it's pretty much laid out here:
    http://osxdaily.com/2015/04/17/fix-slow-folder-populating-cloudkit-macosx/

    I usually clear out those cache files every other week. As an alternative try using the 3rd-party app named Path Finder.
     
  15. Fancuku thread starter macrumors 6502a

    Fancuku

    Joined:
    Oct 8, 2015
    Location:
    PA, USA
    #15
    Thanks for the suggestion. I already tried that but there is no cloudkit folder in ~/Library/Caches
     
  16. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #16
    Try typing cloudkit into the Spotlight search box and select "show all in finder".

    Then in the finder window, hit the +button on the top right to add another search criterion and added criterion to

    System Files - Are Included

    and see if the cloudkit folder shows up.
     

Share This Page