Why is Java not working?

Discussion in 'OS X Mountain Lion (10.8)' started by Nermal, Feb 1, 2013.

  1. Nermal, Feb 1, 2013
    Last edited: Feb 1, 2013

    Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #1
    After Apple blocked Java a few weeks ago, I went into Sys Prefs > Software Update and I turned off the options to automatically download updates and to automatically install security updates.

    I just tried to use a Java-based site and got the message that Java has been blocked. As you can appreciate, I'm not happy. What's the point of having an option to disable automatic security updates if the system just goes ahead and installs the updates anyway even when you tell it not to?

    I know how to reverse the block by editing the plist, but how do you *actually* stop automatic updates in the first place?

    Edit: Update 13 makes the plugin work again, but my question still stands.
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    Apple shut down Java because there was another serious problem with Java. Thankfully, the particular problem has apparently been fixed.
     
  3. g4 powerbookboy macrumors regular

    Joined:
    Aug 10, 2010
    #3
    be happy Apple blocked it...saves a whole nightmare of problems
     
  4. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    Yes, my post mentions that. My question was not "why has Apple blocked Java?", it was "why is Java not working when I disabled automatic updates?".

    I am not happy that Apple can arbitrarily block legitimate software (using a feature that was advertised as being for stopping malware). It's my computer, not Apple's, so I should have a working choice as to whether I want this software blocked or not.
     
  5. nephron8 macrumors regular

    Joined:
    Apr 24, 2012
    #5
    Their were two vulnerabilities in java update 10.
    With update 11, oracle fixed just one and second remained as it is.
    So it's still recommended that keep java disabled.

    You won't believe but even my Indian govt. bank also is running ticker on its site that you don't need java and remove it from your pc.
    That was last place I expected to see java alert.
    It's serious issue.

    I removed java from all my computers.
    And I did not face any issue.
     
  6. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #6
    Am I the only one which understands your question here.:eek:

    I think the only real way to stop it is to block a certain url/executable from getting internet access from your computer, like blocking this with Little snitch.
    Which one to block, I don't know, I don't have 10.6-10.8 so I can't check this for you.

    Edit: There should also be another file with a time set to check for an updated file, this I think is set to 24 hours.

    Bad thing here is that if you disable this all security contained in this file will not be updated.
     
  7. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #7
    Apparently!

    10.8 has a specific option called "[Automatically] install system data files and security updates" and I was under the impression that disabling it would prevent Xprotect updates. Since that didn't stop Xprotect, I wonder what it's for. The help file conveniently says "Select the checkbox to have your Mac install system files and security updates automatically" :rolleyes:

    I wonder whether another option is to change permissions on Xprotect.plist so that Software Update can't actually change it in the first place, but that seems like overkill. I wonder whether this is actually a bug...

    My 10.6.8 machine has "Download updates automatically" turned off and the Java plugin was not blocked. I'm running Apple Java 6 on there though; I thought I'd read that Apple had blacklisted that one too but I'm not sure.
     
  8. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #8
    Yeah, setting it to No Access would also do the trick.

    Agree, it's probably a bug.
     

Share This Page