Why is "Join Tracks" greyed out on Mac itunes

morkmango

macrumors newbie
Original poster
Feb 22, 2005
8
0
Hi,

I cant for the life of me get this to work.. i want to import the new Mars Volta CD and the last song is 30min and broken into multiple tracks and i want to import it as 1 track so their are not gaps with the ipod.. but on my mac this option is greyed out.. on the PC it works fine..! whats up with that?
 

yellow

Moderator emeritus
Oct 21, 2003
16,033
1
Portland, OR
Is it greyed out when you select multiple songs on the CD and then select "Join Tracks on CD"? Otherwise, you can always cat them together in the command line.
 
Comment

morkmango

macrumors newbie
Original poster
Feb 22, 2005
8
0
YES! I searched! .. No, those threads dont help me.. if you look at them the guy does not get his question answered.. I AM doing it before the CD is ripped.. I know how to do it.. I do it on windows all the time.. but when i try on the mac, under the "advanced" tab.. the "join tracks" remains grey.. I have talked to another user and he can do it fine on windows but not on mac..
 
Comment

morkmango

macrumors newbie
Original poster
Feb 22, 2005
8
0
"Otherwise, you can always cat them together in the command line."

Is this an alternate way to using the "Advanced" tab?? or is there?
 
Comment

Loge

macrumors 68030
Jun 24, 2004
2,683
1,151
England
I'm sure you must have checked, but I'll say it again in case it got missed. ;) You have to have the tracks sorted by track number - the left most column in iTunes must be blue at the top to indicate it is the sorted field. If you have sorted by Album the tracks will look like they are in the right order, but the join tracks option will be greyed out.
 
Comment

sparkyguy

macrumors newbie
Mar 3, 2005
1
0
Greyed out for me too

I'm in the same situation.

There's a CD in my CD-ROM drive, and I've selected the CD from the list on the left of the ITunes screen (I'm in Windows XP). The list of tracks is on the right. The tracks are sorted by track number. I've selected several adjacent tracks and would like to join them as one track.

But "Join CD tracks" is greyed out. Any idea why?
 
Comment

Minus Blindfold

macrumors newbie
Jun 23, 2003
17
0
From my experience you have to select (either with Ctrl + click or apple + click) all of the tracks to select the ones you want joined and then while they're highlighted go to the menu and Join CD tracks should be available.

Sidenote: I got the new Mars Volta album too, especially love Cassandra Gemini (the 30 min song). Nice to see another Mars volta fan.
 
Comment

atassina

macrumors newbie
Feb 3, 2009
3
0
CD Tracks still will not join

I have been to several sites and continue to read the same instructions regarding joining CD tracks. I have scrupulously adhered to the instructions and "Join CD Tracks" is still greyed out. I have iMac Leopard version 10.5.6 Other people are having the same problem and so far nobody has 1) Explained why the problem is happening and 2) Nobody has explained how to correct the greying out problem. Thanks for your help
 
Comment

Cinematographer

macrumors 6502a
Sep 12, 2005
900
4
far away
From my experience you have to select (either with Ctrl + click or apple + click) all of the tracks to select the ones you want joined and then while they're highlighted go to the menu and Join CD tracks should be available.
I'm sure you must have checked, but I'll say it again in case it got missed. ;) You have to have the tracks sorted by track number - the left most column in iTunes must be blue at the top to indicate it is the sorted field. If you have sorted by Album the tracks will look like they are in the right order, but the join tracks option will be greyed out.
I'm on Leopard 10.5.6 too, and with the above advice I was able to solve the problem. Have you tried with another CD?
 
Comment

shadowrider

macrumors newbie
Mar 26, 2009
1
0
I found that I also saw the option grayed out. I finally determined the name column was selected. Once I selected the track number column, I was able to select the Join option. Hope that helps.
 
Comment

KAREN4390

macrumors newbie
Sep 28, 2009
1
0
This Thread Actually Helped

THANKS SPARKGUY!! THIS ACTUALLY HELPED SOLVE THE PROBLEM OF JOINING TRACKS. I HAVE BEEN DOING IT FOR YEARS AND NEVER HAD A PROBLEM BUT BY CLICKING THE LEFT COLUMN AS YOU SUGGESTED---VOILA

I CAN NOW JOIN TRACKS AGAIN!!!:eek:
 
Comment

MMcB

macrumors newbie
Oct 18, 2011
2
0
Here's why it's confusing

My track numbers WERE in the right order but the "Name" column was selected. I guess that was possible because the track names were just "Track 01, Track 02, Track 03" so in my case the Names being in alphabetical order automatically put the track NUMBERS in order. But until I actually selected "Track number" by clicking on the Header of the track number column, (which results in that header turning dark gray), I kept finding the "join CD tracks" menu item grayed out.

In the past, sometimes "join CD tracks" would work, sometimes it was grayed out." It was just by accident that it was set correctly to work. Thanks to this discussion thread I finally realize what to do to make it work every time.

I-tunes help said nothing about making sure the Track Number column was actually selected, but rather just select a series of adjacent tracks. I was doing everything their instructions said, and yet was continually thwarted by the gray-out.
 
Last edited:
Comment

michaelaos

macrumors newbie
Dec 3, 2011
1
0
Answer for Join Tracks greyed out

I had problems with Join Tracks greyed out in Itunes. What I discovered is that when I accidently clicked out The track column. I was no longer able to join. I clicked on Artist, name etc; nothing worked.

ANSWER: The very first column that numbers your music or tracks must be highlighted, by click on the small triangle. Once this column is activated; go ahead highlight your tracks and then the Advanced:Join CD tracks will appear.

weird setup but it works
 
Comment

Similar threads

  • tranceking26
8
Replies
8
Views
974
  • zqbobs
0
Replies
0
Views
507
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.