Why is Mail.app showing an extra alias?

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by maclover001, May 16, 2009.

  1. maclover001 macrumors 6502a

    maclover001

    Joined:
    Mar 25, 2008
    Location:
    Vancouver, Canada
    #1
    Hi,

    I'm using MobileMe email with two aliases (making three names, including the account name.

    But for some reason, in the "From" field in "New Message", I'm seeing this odd 4th duplicate option for one of my aliases, but showing my name instead of the company name. How can I get rid of that last one showing my personal name? The MobileMe web UI is showing what I want.

    Thanks
     

    Attached Files:

  2. vandozza macrumors 6502a

    vandozza

    Joined:
    Jun 14, 2006
    Location:
    Australia
    #2
    How many "outgoing mail servers (SMTP)" do you have set up?

    Mail > preferences > accounts > Outgoing Mail Servers (SMTP) - click the dropdown box and select "edit".

    You may have too many SMTP entries?
     
  3. maclover001 thread starter macrumors 6502a

    maclover001

    Joined:
    Mar 25, 2008
    Location:
    Vancouver, Canada
    #3
    Just one, MobileMe.

    I'm noticing that that extra alias comes and goes. When I hit "reply" or "new message", it's sometimes there and sometimes not. What really bugs me is when it is there, it's the default, so I always have to check the thing to make sure I'm using the address I want to use.
     
  4. tschur macrumors member

    Joined:
    Sep 21, 2007
    #4
    This exact same thing is happening to me. I'm surprised that more people aren't discussing this problem. In fact, this is the only report of the problem I could find on the web. I'm just hoping it will go away with an update to MobileMe or OS X, as it seems no one has a solution -- no one even seems to understand the problem.
     
  5. Macsterguy macrumors 6502a

    Macsterguy

    Joined:
    Jun 5, 2007
    Location:
    Texas
    #5
    Try this, go to: Mail > preferences > accounts - look in "accounts information" in the email address window. If the unwanted email address is in there - remove it.
     
  6. tschur macrumors member

    Joined:
    Sep 21, 2007
    #6
    Folks don't seem to understand. The OP's pics are an excellent demonstration of the problem: add an alias in MobileMe and it works as expected in MobileMe, but often in Mail an extra alias is created that will show the From name of the original .me account (especially when the user tries to reply to a message sent to the alias). See how in the pics, there are 3 options to send from in MobileMe, but 4 in Mail? (Also, you can't remove aliases in Mail, only in MobileMe.)
     

Share This Page