Why is Mail downloading 32,854 messages?

Discussion in 'macOS' started by jwjsr, Mar 14, 2014.

  1. jwjsr macrumors 6502

    jwjsr

    Joined:
    Mar 15, 2012
    Location:
    Fairhope, Alabama
    #1
    I've seen it do it before too, but haven't seen it in awhile until today. Seems like a waste of something.
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    This is why I will never use IMAP, so long as POP remains as an option to me...
     
  3. jwjsr thread starter macrumors 6502

    jwjsr

    Joined:
    Mar 15, 2012
    Location:
    Fairhope, Alabama
    #3
    Could you tell me more. Apple tech insinuated pop was dead/inferior, one reason being that pop doesn't sync across devices? example: if you delete an email on your mac with pop mail you would also need to delete it manually on your other devices?
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    IMAP is far better than POP for the reasons you mentioned. I don't think you will find many users claiming POP is better.

    Who is your email provider and can you think of anything you changed or did recently that may have caused this.

    It is definitely not normal for this to just happen all on its own.

    Are you using Gmail under Mavericks by any chance? There have been some bugs with that combination.
     
  5. jwjsr thread starter macrumors 6502

    jwjsr

    Joined:
    Mar 15, 2012
    Location:
    Fairhope, Alabama
    #5
    I'm using mavericks mail with gmail set up as an account under it. I had hoped they worke the bugs out but around the same time my mail activity box showed 32,850 emails being downloaded I had a four hour delay between the time an email was sent to me and when I received it.
    Damn I may have changed something recently but can't remember for sure, I'll have to stew on that.
    While I've got you, how do you grab just part of a quote when replying here on the forum"
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    When you hit that quote button it quotes the whole message, then I just mouse drag through the parts I don't want and hit the delete key to remove the unwanted text.

    I still see a fair number of users posting here using the Gmail Mavericks combo with troubles, so I suspect this is not all worked out yet.

    I have seen some Gmail users saying they switched to Airmail and they are happy with it. Maybe worth a try.
     
  7. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #7
    Google's implementation of IMAP leaves a bit to be desired. One of the problems is that it presents a folder called "All Mail" which as you might guess contains every single email that you have stored in gmail. Apple Mail dutifully tries to cache this for you, unfortunately.

    I've stopped using Google mail, but you can sign in to gmail on the web, go to gmail settings/labels, and tell gmail to not show All Mail (and other folders) when using IMAP. That should help.

    A.
     
  8. jwjsr thread starter macrumors 6502

    jwjsr

    Joined:
    Mar 15, 2012
    Location:
    Fairhope, Alabama
    #8
    I have seen some Gmail users saying they switched to Airmail and they are happy with it. Maybe worth a try.[/QUOTE]
    Thanks for your help
    remembered a couple of changes i made under mail
    1. ticked the box-"Use only this server" under accounts->account information->OutgoingMail Server(SMTP)
    2. Under "Composing"->"send new messages from" I changed it from iCloud to gmail

    ----------

     
  9. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #9
    With Mail on Mavericks the suggested setup is no longer to disable "All Mail" in Gmail's IMAP folder settings. Mail will download and index everything and there will only be one copy of each message and not two like in previous Mail versions with Gmail. There are a couple long articles here and also an update here delving into all this.

    I suspect Apple trying to adapt OS X Mail to Gmail's non-standard IMAP setup with this All Mail business is part of why things are so messed up.
     
  10. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #10
    I think this is a moving target. There are articles after the TidBits one where users have to disable All Mail again to get things to behave. I believe my solution is the most pleasing: stop using gmail.

    A.
     
  11. jwjsr thread starter macrumors 6502

    jwjsr

    Joined:
    Mar 15, 2012
    Location:
    Fairhope, Alabama
    #11
    Wouldn't that mean you. Know longer have a gmail account and have to let everyone know your new email?
    If you use straight gmail, like put the gmail icon in the dock, will it then behave.?
     
  12. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #12
    The second article I linked is after the 10.9.2 release and if you read through the comments by the author, leaving "All Mail" on is still the suggested setting on Mavericks.

    I do agree dumping GMail all together is the preferred solution, but many users have a lot of time and effort investing in their GMail account.
     

Share This Page