why is my 'Drafts' mailbox so full?

Discussion in 'Mac Apps and Mac App Store' started by chrisman9, Nov 29, 2016.

  1. chrisman9 macrumors member

    Joined:
    Nov 13, 2016
    #1
    Dear Tech aquaintances, I just now noticed that my 'drafts' mailbox has 68 emails in it. Arent drafts evidence of not-having-been sent? If yes, do you know what may be causing the problem? (my 'sent' mailbox Always shows the email I have presumably sent) But now Im concerned that all of these havent been mailed out. Thanks, chrisman9
     
  2. mrkramer macrumors 603

    mrkramer

    Joined:
    Jul 11, 2006
    Location:
    Somewhere
    #2
    I'm not sure of the reason why, but mail seems to save drafts every few seconds and doesn't remove them when the email is sent. Your emails most likely sent fine though.
     
  3. MacGizmo macrumors 6502a

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #3
    yet another minor bug that is majorly annoying.
     
  4. monokakata macrumors 68000

    monokakata

    Joined:
    May 8, 2008
    Location:
    Hilo, Hawai'i
    #4
    I see this regularly and indeed it's majorly annoying. Even though I'm confident that the email was actually sent, I always do inspect Sent, which is a waste of time. And yet I don't like deleting a draft before I'm confident that it's been sent. I hope they fix this.
     
  5. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #5
    The conditions that cause such behavior are dependent on your account setup/settings and the email provider. Provide those for help.
     
  6. monokakata macrumors 68000

    monokakata

    Joined:
    May 8, 2008
    Location:
    Hilo, Hawai'i
    #6
    Perhaps not entirely. I maintain several email addresses at the same hosting company, all IMAP but with different domains, all of which Mac Mail knows about and all of which are regularly used. It's not rare for me to receive an email to an address at one domain, but to reply to it using an address at another. Typically this is to shift further exchanges to the other domain; I simply use the drop-down list in the "From" field for this.

    I can reproduce the problem in this way:

    1. reply to an email that has come to (say) xyz@xyz.net

    2. begin composing the reply

    3. after the email shows up in Drafts (but while I'm still working on it), change the From to another one of my email addresses (say, abc@abc.com).

    4. complete the email and send it; it sends properly

    5. in Drafts there will be a copy with text up to the time I changed from From address, and I have to delete it manually.

    It seems clear to me that Mac Mail follows an internal rule that says "Put a draft in the Draft folder for the From account and if that changes, put a new one in the new From account and don't delete the one in the old From account."

    Perhaps the thing to do is to specify a Drafts folder in "On my Mac" but that does defeat the point of IMAP.
     
  7. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #7
    I have one Exchange (Office 365) hosted email and one Google Apps hosted domain email set up in Mac Mail. Duplicating your steps, I do not get a residual "draft" email anywhere.

    I'm on El Capitan.

    In both accounts I've selected the proper server Drafts folder in Mail>Mailbox>Use this mailbox as.

    Settings in Google Apps:
    Screen Shot 2016-12-04 at 5.33.01 PM.png

    Settings in Exchange:
    Screen Shot 2016-12-04 at 5.33.15 PM.png
     
  8. monokakata macrumors 68000

    monokakata

    Joined:
    May 8, 2008
    Location:
    Hilo, Hawai'i
    #8
    I'm on Sierra, and I don't see those options.

    My plate is rather full at the moment (surprise house renovation issues, sink that won't fit, unexpected need to cut into sheetrock, unexpected need to find somebody with a diamond saw who can deal with granite, all happening of course on a Sunday afternoon) and so because I know how to deal with the issue, I don't want to be in a discussion of exactly what causes it and how to fix it.

    Please don't take offense, and thanks for your exploration.
     
  9. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #9
    No offense. Those settings are in your Mail Account settings.
     
  10. steve23094 macrumors 68000

    steve23094

    Joined:
    Apr 23, 2013
    #10
    This bug has been around a while. It typically occurs when you send your email at the same time the account is syncing.

    Try turning off storing draft messages on the server.
     
  11. leprechaun macrumors newbie

    Joined:
    Feb 25, 2012
    #11
    In common with monokakata, I do not have those two displays on my iMac either. I am running Sierra 10.12.3. I find when I call up a draft email using my IMAP gmail account to continue working on it, it refreshes itself every 5 seconds or so. Eventually I finish the email and send it, and it sends cleanly and the drafts count shows empty, which is as it should be. I also have an iPad 2 and an iPhone, both running IOS 10.2.1. When I get a reply to my email, I am finding a great number of draft emails displayed on my iPad 2 ranging from the full draft right back to its opening line. The worst so far is 360 of them! This happens on my iPad only - not on my iMac and not on my iPhone. I have checked the gmail advanced settings on my iPhone and my iPad and the settings appear to be identical. I have also checked my iMac. All three show drafts being stored on the Server. Could a kind person please help this very elderly novice to stop this happening and also to get rid of all the intermediate drafts wherever they are hiding?
    I am grateful for any assistance please.
     
  12. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #12
    You're not running iOS 10 on your iPad 2, if it is indeed an iPad 2. iOS 10 won't run on an iPad 2.

    On an iPad 2 running iOS 9, Settings>Mail, Contacts, Calendars>[a Gmail account]>Account>Advanced>Drafts Mailbox should have the "Drafts" folder under "ON THE SERVER" checked and not the one under "ON MY IPHONE".

    I don't know if that helps.
     
  13. leprechaun macrumors newbie

    Joined:
    Feb 25, 2012
    #13
    Sorry Brian. My mistake. It is in fact an iPad Air. Regarding your second paragraph, the ticked Drafts folder is the one "On the Server". This is true of my iPhone and of my iMac. Thank you for your response but in view of my correction, have you any other suggestion please?
     
  14. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #14
    Since it's a Gmail/IMAP account I'd just see if removing and re-adding it clears it up.
     
  15. leprechaun macrumors newbie

    Joined:
    Feb 25, 2012
    #15
    Thank you for your patience Brian. Although I read emails on my iPad Air I do not write emails on my iPad Air because it is more convenient to use the physical key pad on the iMac - but it is on the iPad Air where the stored intermediate drafts show themselves. So do I delete the gmail client from the iPad Air or from the iMac?
     
  16. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #16
    You'd delete the Gmail account in Settings>Mail on your iPad. Wait for the account to be deleted, then re-add it.
     
  17. leprechaun macrumors newbie

    Joined:
    Feb 25, 2012
    #17
    I deleted the gmail account from my iPad Air and reloaded it successfully. Sadly, the duplicated part-drafts are still there. I have just sent a few emails to ascertain whether the original problem (storage of all stages of drafts on the iPad following updating of a draft email on the iMac) remains or has been overcome by that manoeuvre, and it seems that the displaying of duplicated drafts has stopped. I just need to get rid of those earlier ones, which I can do manually.
    I am grateful for your assistance.
     
  18. leprechaun macrumors newbie

    Joined:
    Feb 25, 2012
  19. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #19
    It sounds like those Drafts aren't at Gmail and exist on your iPad only. I'm wondering if you had deleted your Gmail account and then added a different Gmail account if they would have re-appeared.

    This Gmail account is your only email account on the iPad?
     
  20. leprechaun macrumors newbie

    Joined:
    Feb 25, 2012
    #20
    Not at all. I have several email addresses using icloud, hotmail, gmail et cetera on all 3 of my facilities. I have been into Google and opened Googlemail and there are no signs of multiple copies of drafts there, nor on my iMac nor on my iPhone 6. You are right to surmise that they are only to be found on my iPad Air. As you suggested earlier, I deleted the gmail facility on my iPad and whilst still on the iPad I selected "Add new account?" and chose the only Google on display.
    The problem was only occuring when I opened an existing draft on my iMac having needed to come away from it earlier prior to completing and sending. If I type an email on my iMac and send it without needing to call up a draft, those sent emails do not have multiple draft copies associated with them.
    I will make some more experiments to see if I can narrow down the circumstances.
     
  21. leprechaun macrumors newbie

    Joined:
    Feb 25, 2012
    #21
    Hi Brian.

    Sorted at last.

    On my iMac, I opened Mail and chose Preferences and from them I chose my Gmail account. I opened the "Mailbox behaviours" tab and the Trash setting was saying "Gmail/Bin" so I altered it to say "Trash" and came out (which auto saves).
    Then I opened Google and I went into my Google account and opened Gmail. I clicked on "Drafts" in the left hand column and got 3 pages worth of emails with drafts associated with them. I selected them all, page by page, and did a right click on one of them which gave me some options including "Delete drafts", which I did and eventually cleared all three pages.
    Then I opened Settings on my iPad Air, selected "Mail', then navigated to my gmail account and deleted it. (It only deletes the account from the iPad - not the entire Gmail server's worth). Then I clicked "Add account" and chose Google, calling for my gmail address and password in the process, everything else being automatic. Then I powered down the iPad and restarted it.
    I opened Mail and checked and all the saved drafts no longer show up in my main Inbox. I shall know in a day or two whether the problem is entirely cleared, bur at least I now know what to do even if they reappear in the future.

    This has been a long investigation but I hope it will help others to overcome the problem of draft emails showing up in the Inbox, and I thank you, Brian, for your patience and assistance.
     

Share This Page