Why is my external monitor stuck in power save mode?

Discussion in 'Mac Accessories' started by oxband, Aug 25, 2011.

  1. oxband macrumors 6502

    Joined:
    Sep 10, 2009
    #1
    I am connect a VGA Dell monitor to my 17" MBP with a DVI>VGA connector. It was working fine. I plugged it in for the first time in a week and now it wont work. The display goes on OK but when I connect it, the green power button goes orange and it goes into power saver mode. It tells me to hit the keyboard or mouse to work but I'm doing that and nothing happens. The computer is clearly detecting the display. It shows up in Displays in System Preferences and I can drag my mouse and windows to the other screen. The external monitor is just stuck in a black, power saver mode.

    Any thoughts?
     
  2. CylonGlitch macrumors 68030

    CylonGlitch

    Joined:
    Jul 7, 2009
    Location:
    SoCal
    #2
    It's broken.

    Sounds like it thinks that there is no signal on the inputs when, obviously there is. Are there multiple input types (DVI, VGA, etc) if so, try one of those and see if it fixes the problem. It is a very common problem and you can get it repaired, but most likely not worth the cost.
     
  3. oxband thread starter macrumors 6502

    Joined:
    Sep 10, 2009
    #3
    So, you think it's the monitor? I think you might be right. I just tried plugging the connecting my video camera to the monitor through a VGA cable and when I have everything hooked up, the screen again goes into power saver mode.

    Is there anything I can do to try and save it? Is this an irreparable problem?
     

Share This Page