why is my fan going crazy speeds?

Discussion in 'macOS' started by sagnier, Jul 26, 2010.

  1. sagnier macrumors regular

    Joined:
    Sep 19, 2007
    #1
    in the last 48 hrs iv noticed that the fan on my mbp 13.3 is going crazy. that is, its constantly at 3300-4000rpm, whereas before it was at 1998rpm most of the time. added to this, my cpu is running at about 50-60% all the time. im checking activity monitor and there is nothing hogging the cpu as far as i can see. i've switched off everything but the browser, and i have no other accounts active. iv not downloaded anything recently that i would think has done this. and certainly iv dl'd nothing in the last few days.

    previously, sometimes firefox would sometimes (although rarely) send it racing up to 80%, but im watching it and its taking up no more than 5% of the cpu right now. base of the enclosure is really warm.

    its all very odd. any ideas why this might be?

    nb i am running low on hd space ( i have 22gb of 320gb left) but its been this way for a few weeks. i realise i should clear out some stuff, but i dont think this is causing the problem here.

    thanks
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
  3. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
    #3
    When I upgraded to 10.6.4. I suddenly started experiencing the fan racing problem and high CPU usage too.

    First thing I did was clear my desktop - or at least tried not to have it too cluttered (esp. pics, it's best not to have too many of them on your desktop). Secondly, I tried running OnyX and resetting PRAM, and apparently eventually it helped!

    Here's how to reset PRAM: http://support.apple.com/kb/HT1379

    You can give it a try.
     
  4. sagnier thread starter macrumors regular

    Joined:
    Sep 19, 2007
    #4
    solved

    thanks for the advice. i found the culprit under All Processes in activity monitor. something to do with some printer driver. Dodgy rubbish:mad: it was very resilient - even though i was in my admin account and tried quit process three times, it kept returning. i had to log into the account that did the printing and then open activity monitor and then authorise the force quit using my admin name. very odd.
     

Share This Page