Why is my internet so much slower than my roommates?

Discussion in 'macOS' started by johnbro23, Aug 27, 2008.

  1. johnbro23 macrumors 6502a

    Joined:
    Apr 12, 2004
    Location:
    Pittsburgh, PA
    #1
    I'm going through the same wireless router to get our Comcast cable internet, but my internet is 3-4 times slower. For example, MacRumors.com consistently takes 16-17 seconds to load on my computer and 4-5 seconds on my roommates'.

    In Network System Preferences, I've selected "Automatic" in the "Location" field, so I think all of my settings are pretty standard. My 3 roommates are all using Windows XP, with the standard internet settings.

    Can you think of anything I can do to fix this problem? Thanks in advance for your help.
     
  2. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #2
    Windows for some reason typically allocates itself a certain amount of bandwidth, stealing it from others. I've noticed this on several Windows/Mac home setups.
     
  3. Hawkeye411 macrumors 68000

    Hawkeye411

    Joined:
    Jun 6, 2007
    Location:
    Canada EH!!!
    #3
    Thats odd .... I get the same speed with my MacBook and my wires XP Laptop. It's got to be related to a setting or a third party software. I had problems with my internet connection being slow because of a widget called Jywire (I think that's the correct spelling). Took me a year! to figure it out. Apple even replaced the wireless card LOL.

    Not sure if it the cause of your slow connection or not, but you might want to have a close look at the software that's running on your machine.

    Cheers.
     
  4. johnbro23 thread starter macrumors 6502a

    Joined:
    Apr 12, 2004
    Location:
    Pittsburgh, PA
    #4
    I really keep my computer pretty clean. All software is kept to a minimum. I run two widgets in the background - calculator and dictionary.

    The difference in speed is so drastic that I doubt it is merely a matter of operating system. I think it has to do with some of my settings. Like IP or DNS...? To be honest, I don't know what most of that stuff means, but I figured a couple of tweaks there would do the trick...
     
  5. GreatDrok macrumors 6502a

    GreatDrok

    Joined:
    May 1, 2006
    Location:
    New Zealand
    #5
    You might want to see if there is a proxy on the network that Windows is automatically detecting. Firefox can autodetect proxies but Safari doesn't but if you know the address you can point Safari at it. A local proxy can significantly improve the performance of web page loading.
     
  6. NeoMayhem macrumors 6502a

    Joined:
    Aug 22, 2003
    #6
    How is the speed on your iPhone on this wifi connection? How about if you plug your computer into the router? What about your signal? If it is weak it is going to be slower.

    Is this a B, G or N network?

    Did you Turn off IPv6? That can speed up networking on OS X a lot.

    You sure your roommates didnt cap your speed so they can download their porn faster?
     
  7. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #7
    Maybe this should become a sticky thread.

    My Mac is slower than Windows on the same Internet connection, but downloads seem just fine

    Problem is either in OS X, DNS server, or your home router.

    Check that your home router (if any) has latest firmware.

    Try turning off IPv6 on your network interface. It is usually set to Automatic.

    Try manually setting your DNS server(s) to something else, such as OpenDNS' at 208.67.222.222 and 208.67.220.220

    For the sake of completeness, note that it has been reported that installing a nightly build from WebKit.org makes the problem go away as well, but I wouldn't recommend it as a first step.

    If your downloads are slow in OSX, while Windows is fast, then you have an entirely different problem.
     
  8. johnbro23 thread starter macrumors 6502a

    Joined:
    Apr 12, 2004
    Location:
    Pittsburgh, PA
    #8
    Thank you for the help. I added those two DNS Servers to the list under System Preferences > Network > Airport > Advanced > DNS. My pages now load in 1/4 of the time as they used to.

    I agree, this should be a sticky thread!
     
  9. Steelkickface macrumors newbie

    Joined:
    Mar 14, 2009
    #9
    Nice one this has been giving me grief for ages and now its sorted..
     

Share This Page