Why is my world clock stuck at "Cupertino"?

Discussion in 'Apple Watch' started by Juan007, May 2, 2015.

  1. Juan007 macrumors 6502a

    Juan007

    Joined:
    Jun 14, 2010
    #1
    On my watch face, I'm stuck with "CUP" for Cupertino. If I click "CUP", I'm brought to the World Clock - Cupertino. I then hit "back" and hey, there's my city! I don't have even have an entry for Cupertino. Then I go back to the watch face and yup -- "CUP" is still there?!?

    How to fix this? I don't live in Cupertino, I never go there. I don't want "CUP" on my watch face.
     
  2. ckiggins macrumors 6502

    Joined:
    Mar 15, 2012
    Location:
    Richmond, VA
    #2
    It took me some time to figure this out too. Go yo the clock app on your iPhone and select world clock. You can edit your cities there.

    I kept thinking this was inside the watch app, but it is inside the CLOCK app.
     
  3. Juan007 thread starter macrumors 6502a

    Juan007

    Joined:
    Jun 14, 2010
    #3
    Thanks. I did clear my world clock Cupertino entry on my phone before making my post, and it didn't help at all. I'm convinced this is a bug -- maybe it's stuck on Cupertino because my "real" city (the only one I had listed in world clock) is in the same time zone (actually 10 miles away) from Cupertino.

    Anyway, I wiped / reset my watch, and now it's fine.
     
  4. leesweet macrumors demi-god

    leesweet

    Joined:
    Feb 1, 2009
    Location:
    Northern Virginia, USA
    #4
    It shows the first selection in the world clock which you can also adjust in the watch face complication setup: scroll through them until you come to the time zone you want.
     
  5. TxRN macrumors member

    TxRN

    Joined:
    Apr 22, 2015
    Location:
    On the move
    #5
    Think it was a default setting. It was on my watch until I selected another city on my iPhone.
     
  6. redman042 macrumors 68020

    Joined:
    Jun 13, 2008
    #6
    I think they just REALLY want to make sure the world knows where their headquarters are. They have always used Cupertino for the Pacific time zone which I've always found odd.
     
  7. diablo2112 macrumors 6502

    Joined:
    Apr 16, 2010
    #7
    Click "customize" on the watch face, click the box around the world time, use the scroll wheel to select another city (or another complication, for that matter).
     
  8. SoCalAppleWatch macrumors member

    Joined:
    Apr 24, 2015
    #8
    Not any truly correct replies in here yet. To remove cupertino from your World Clock, you need to open the clock app on your iPhone and tap the "world clock" tab. Apple Watch syncs whatever you add or remove from right there, on the iPhone. :cool:
     
  9. wepiii macrumors 6502

    Joined:
    Sep 22, 2012
    #9
    Actually, I believe this was already state above, but you are incorrect. To change the CUP (Time) on the watch face, you have to go back and re-customize the time complication on the watch face and scroll to the city you want.
     
  10. wesk702 macrumors 68000

    wesk702

    Joined:
    Jul 7, 2007
    Location:
    The hood
    #10
    You can fix it in both. In the watch highlight the complication and use the crown to scroll through your preselected cities which originates from the iPhone's world clock.
     
  11. wepiii macrumors 6502

    Joined:
    Sep 22, 2012
    #11
    Exactly... But just changing the position of a city on your phone in world clock will not automatically update it on your watch face. You mush go in and "customize" it again.
     
  12. wesk702 macrumors 68000

    wesk702

    Joined:
    Jul 7, 2007
    Location:
    The hood
    #12
    Yeah, just use the crown
     
  13. Cuyler macrumors 6502

    Joined:
    Jun 16, 2009
    Location:
    Chicago
    #13

Share This Page