Why is Safari page zooming not fixed yet?

Discussion in 'OS X Mavericks (10.9)' started by Krayzkat, Dec 2, 2013.

  1. Krayzkat macrumors member

    Krayzkat

    Joined:
    Apr 22, 2011
    #1
    This is ridiculous!

    I'm fed up having to (cmd +) zoom in to web pages again and again!

    It used to be that if i zoomed in to a web page, it stayed zoomed in even if i navigated away to another website or bookmark. it hasn't worked like this since Mavericks was released

    Surely I'm not the only person who does this?

    Surely I'm not the only person with a 27" imac who wants webpages to fill the whole screen with useful text/pictures, and not just and expanded background?

    It just doesn't work!!!

    I'm fed up having to re-zoom in continuously all the time.

    Before Mavericks, i spent 2 years navigating the internet usually with my feet up on the desk and only having to use the mouse to point and click links/bookmarks etc.... Now every time i click on a link or bookmark i have to re-zoom in.

    This is not simplicity, this is annoying
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Try the Safari extension AllPagesZoom. It will do exactly what you want.
     
  3. Krayzkat thread starter macrumors member

    Krayzkat

    Joined:
    Apr 22, 2011
    #3
    Thank you Weaselboy, that has fixed the problem.

    I'm still pissed off i've had to install an extension just to be able to do this though.....
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Yeah... seems like each OS update adds 37 new features then takes away two of your favorite features. :)
     
  5. Krayzkat thread starter macrumors member

    Krayzkat

    Joined:
    Apr 22, 2011
    #5
    That extension did fix the problem although it created another one by having website pop ups loading up offscreen, i.e. pop up log ins

    But now i've discovered the extension seems to be breaking certain websites or causing them to load slow or in 'text' mode (or whatever you call it), so i have disabled it and am back to being frustrated and pissed off at this annoying Safari bug.

    I am also bamboozled how only a few people seem to be affected by this!
     
  6. Robisan macrumors 6502

    Joined:
    Jan 19, 2014
    #6
    If you can't get this resolved you might want to look at Firefox plus the NoSquint add-on. NS will let you set custom page zoom and/or text zoom for every website and will remember your settings. You can also set default zoom settings so that newly visited sites will load at the default instead of 100%/normal.
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    I have been using the extension Quickstyle to address small fonts on web pages. It is a little more complex to use than the earlier mentioned extension, but it seems to get better results. You can tell it exactly which portions of the text on page you want enlarge. I don't have any trouble with it breaking things on sites.
     
  8. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #8
    You can try this : go to Safari / Preferences / Advanced.

    "Style sheet" : choose one of the zoom (download below, 120 = 120%, 140 = 140%, etc...)

    The change takes effect immediately, no need to quit / launch Safari.

    I can create another zoom if you wish.

    http://demo.ovh.eu/fr/c7276bdd41c3c68b2662dd6234d19d41/
     
  9. Krayzkat thread starter macrumors member

    Krayzkat

    Joined:
    Apr 22, 2011
    #9
    Thank you Bruno. That has worked :)

    I've used the 200% file and now every webpage i go on is twice as big (even saved bookmarks woohoo)

    I will report back after a few days to highlight any issues.

    Thanks again. You don't realise how annoying it was before. Also I'm still curious as to how no one else seems to be bothered by this bug....
     

Share This Page