Why is safari so bad at handling pdfs

Discussion in 'macOS' started by mashinhead, Jul 8, 2007.

  1. mashinhead macrumors 68030

    Oct 7, 2003
    Its slow in downloading them, moving through, them and printing them. Why can i set it to a default that downloads pdfs rather than the painstakingly ancient process of viewing them in the browser
  2. AlBDamned macrumors 68030


    Mar 14, 2005
    You're right, Safari is appalling at PDF handling.
  3. pianoman macrumors 68000


    May 31, 2006
    i agree that it needs some work.

    if you're unsatisfied with Safari's handling of PDFs, there are options. if you know you're clicking on a PDF link, right click instead and open in Preview. similarly, you can right click an already-open PDF and choose to open in Preview. you could also download Adobe Reader.
  4. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    Schubert-It is certainly also an option. In most respects, I find Schubert-It to be a better option than Adobe's plugin on Windows.... The only thing I like about the newest Adobe plugin is that it has a nice in-browser search engine, but usually, by that point, I've used Schubert-It's excellent feature of automatically opening the PDF in Preview. :)
  5. Scottyk9 macrumors 6502a

    Jun 18, 2004
    I used this after upgrading to Tiger, which changes the default handling of pdf's so that they are downloaded.


    here is the text of the article:
    Some people do not like Safari's new ability to open PDF files in the browser window. Here is the default to change in the Terminal to switch back this behavior:
    defaults write com.apple.Safari WebKitOmitPDFSupport -bool YES
    [robg adds: To use this hint, first quit Safari, open the Terminal, and type the above command. Restart Safari, and you should find that PDFs are treated as they were before. To restore Safari's handling of PDFs, repeat the above command, changing YES to NO. Remember to quit Safari first. Note that I haven't tested this one; I use the Acrobat PDF plug-in and haven't had a chance to disable it in order to test...]

Share This Page