Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

ZipZilla

macrumors 6502
Original poster
Dec 7, 2003
441
613
M2 Mac Mini 16GB/512GB.

Known issue where the computer doesn't reflect the imessage activity on other devices on the same Apple ID

I have done everything....still not fixed.

Awful, just terrible Apple. I guess I have to downgrade to Ventura for my computer to work properly?
 

fisherking

macrumors G4
Jul 16, 2010
11,179
5,515
ny somewhere
M2 Mac Mini 16GB/512GB.

Known issue where the computer doesn't reflect the imessage activity on other devices on the same Apple ID

I have done everything....still not fixed.

Awful, just terrible Apple. I guess I have to downgrade to Ventura for my computer to work properly?
this is not a common problem, and you could choose to get it sorted. messages stay sync'd here on my mac & iphone.
& give us more info which mac? is 'enable messages in iCloud' on or off? (i don't use it).

or call apple, and get this fixed. saying 'sonoma is worse than catalina' just because your messages aren't syncing is... pretty over-the-top... 🙄
 
  • Love
Reactions: Jay Tee

ZipZilla

macrumors 6502
Original poster
Dec 7, 2003
441
613
It isn't over the top. It's a known issue with the Apple forums filled with people having the same problem.

The mac is listed above. I've had 'enable messages in iCloud on and off." Still not syncing. I've clicked the sync button. Stood on my head. Rebooted the Mac. Signed out of iMessage, signed back in. Toggled Do not disturb on and off (it's off.)

I'm really at the end of my rope with it.
 

Wando64

macrumors 68020
Jul 11, 2013
2,224
2,885
For the record, it also works fine for me.

Sometimes the Messages iCloud connection can get broken (ironically it happened to me while I was on Catalina).
There is a process to follow to restore it, and it is detailed on the Apple support pages.
Basically, if I remember correctly, it involves disconnecting messages from iCloud on all your devices, and then reconnecting them.
In all likelihood the main culprit is your phone.
 

fisherking

macrumors G4
Jul 16, 2010
11,179
5,515
ny somewhere
It isn't over the top. It's a known issue with the Apple forums filled with people having the same problem.

The mac is listed above. I've had 'enable messages in iCloud on and off." Still not syncing. I've clicked the sync button. Stood on my head. Rebooted the Mac. Signed out of iMessage, signed back in. Toggled Do not disturb on and off (it's off.)

I'm really at the end of my rope with it.
what did apple say when you called them?
 

FreakinEurekan

macrumors 603
Sep 8, 2011
6,002
2,971
M2 Mac Mini 16GB/512GB.

Known issue where the computer doesn't reflect the imessage activity on other devices on the same Apple ID

I have done everything....still not fixed.

Awful, just terrible Apple. I guess I have to downgrade to Ventura for my computer to work properly?
You’ve done EVERYTHING? Wow - I guess Sonoma really does suck! I’ll have to delete it from my four Macs - too bad, it’s working so smoothly… oh well.
 
  • Like
Reactions: Slix and fisherking

haralds

macrumors 68030
Jan 3, 2014
2,932
1,223
Silicon Valley, CA
Try This: set up another account on the same Mac and link it to your iCloud account and Messages.
I have had it that some hidden preference or cache/container setting screwed things up. Do not migrate your user, since it will migrate your problem.
 

Jay Tee

macrumors regular
Mar 17, 2023
245
432
this is not a common problem, and you could choose to get it sorted. messages stay sync'd here on my mac & iphone.
& give us more info which mac? is 'enable messages in iCloud' on or off? (i don't use it).

or call apple, and get this fixed. saying 'sonoma is worse than catalina' just because your messages aren't syncing is... pretty over-the-top... 🙄

I was having this sync problem, and, upon reading your suggestion, called Apple: it's all working now !
 
  • Like
Reactions: fisherking
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.