Resolved Why is startup still slow with SSD?

Discussion in 'MacBook Pro' started by serb, Jul 30, 2012.

  1. serb, Jul 30, 2012
    Last edited: Jul 30, 2012

    serb macrumors newbie

    Joined:
    May 29, 2012
    #1
    I just installed a Crucial M4 256gb SSD into my cMBP, everything looks fine but the startup is 40-45 seconds. I think it might be SLOWER than before when I had my HDD. I enabled Trim and apps start up quickly (one bounce), but its just the startup time is bad. Do I need to reset the PRAM? Any other things I need to do? I'd like to fix this

    EDIT- what is also weird is that all my files (about 25 gb, i don't have much) is under other, even though it includes music, movies, photos, etc. i cloned with superduper, does that usually happen?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Delete any non-essential items from the following locations:
    • System Preferences > Accounts > yourusername > Login Items
      (Lion users: System Preferences > Users & Groups > yourusername > Login Items)

    • /Library/LaunchAgents/ and ~/Library/LaunchAgents/
      (Lion users: In Finder, click Go > Go to Folder > then enter the path)

    • /Library/StartupItems/
      (Lion users: In Finder, click Go > Go to Folder > then enter the path)
    It may help. It can't hurt.
    If you're wondering what "Other" category in the Lion storage tab is about, this may help explain:

    If you're having performance issues, this may help:
     
  3. inf0rmer, Jul 30, 2012
    Last edited: Jul 30, 2012

    inf0rmer macrumors newbie

    Joined:
    Jul 30, 2012
    #3
    I just installed the same Crucial M4 SSD and was also having issues with slow booting. I reset the PRAM and right after that the boot time went to 8-9 seconds. I'm on an early 2011 Macbook Pro 13".

    EDIT: Just remembered, I also cloned my HD to my SSD. I think it might have something to do with your startup disk not being properly set. Go into Startup Disk in System Preferences, choose your SSD and click Restart. It might help!
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Go to System Preferences and in Startup Disk select your new disk as the boot disk then restart. That will fix you up.

    By changing the boot drive and not setting the boot disk, the system is searching for a boot disk at each start and this is why you are seeing the delay.
     

Share This Page