Why is streaming quality on TV jumpy (from MacBook Pro)

Discussion in 'MacBook Pro' started by rarchy, Feb 7, 2016.

  1. rarchy macrumors newbie

    Joined:
    Oct 4, 2010
    #1
    I am streaming a football match from Sky Sports (I'm logged into Sky Go so it's official and legal streaming). I've connected my laptop to my tv via an HDMI cable. The quality generally is good - clear and sharp - however it's jumpy and kind of jerky and I'm not sure why and if I can stop it.

    I sometimes stream Amazon prime on my tv from my laptop and have occasionally noticed the same but as there isn't constant quick movement in a normal film it's fine, however for football it's really annoying and noticeable!

    My internet speed is really good (128mbps on a good day) and on my laptop it doesn't jump. Equally if I watch football directly on the TV from Sky it is fine (unfortunately I can't do that for this match for various reasons)

    My laptop is a MacBook Pro (2015 model), and the tv is Samsung, it is a bit old (maybe 2011 or 2012), however it's usually good with normal HD

    Is it the laptop or TV, or even the HDMI cable, and can anything be done?

    Please note, I am not very tech savvy so any suggestions in simple terms are appreciated :)

    Thanks,

    Rachel
     
  2. steve23094 macrumors 68000

    steve23094

    Joined:
    Apr 23, 2013
    #2
    I'll just say up front that I don't know the answer to your problem, but I have some ideas.

    I have used a similar setup. Sky Go, mid-2012 rMBP. I first tried mirroring Sky Go set as full screen on my laptop via Airplay. I only watch sport, specifically rugby so related to football in the sense of a fast moving ball sport on a green pitch. The performance on the TV was terrible, all jerky with the sound out of sync.

    I then set up like you with a HDMI cable. It made it watchable and the sound was in sync but still exhibits some slight blurring/jerkiness which is not present on the laptop screen.

    I now have Sky Go on my games console, so when the season begins I'm expecting it to operate perfectly, but it will certainly be interesting when I first test it out.

    Something I haven't bothered doing, try running a video file from your laptop to TV. It will at least help try to narrow down the problem. If that runs okay it suggests there is something screwy with Sky Go. Other thoughts: it's unlikely to be a fault with the cable, it might be how Apple implements the HDMI out, if your TV has different screen settings try those (turning digital processing off or on, game mode etc).
     
  3. LIVEFRMNYC macrumors 603

    Joined:
    Oct 27, 2009
    #3

    Try lowering the resolution on your Macbook from display settings. Maybe 1280 x 800 might play smooth.
     
  4. steve23094 macrumors 68000

    steve23094

    Joined:
    Apr 23, 2013
    #4
    When you hook it up the resolution will automatically change to match the TV and a 2015 MacBook Pro should be able to handle 1920*1080. If it can't there is something screwed up with Apple's implementation of HDMI out.
     
  5. LIVEFRMNYC macrumors 603

    Joined:
    Oct 27, 2009
    #5
    I always found it does that poorly. I end up manually adjusting the resolution. I just suggested trying differ resolutions to see if it helps. I personally never had the problem you have. What Plug-in does Sky Sports use? Or is it directly from an app?
     
  6. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #6
    In the display preferences do you have the resolution set to "default for display" and the monitor arrangement set to "mirrored"?
     
  7. steve23094 macrumors 68000

    steve23094

    Joined:
    Apr 23, 2013
    #7
    It uses Silverlight.
     
  8. LIVEFRMNYC macrumors 603

    Joined:
    Oct 27, 2009
    #8
    Have you tried other sources, such as html5 videos like on Youtube. Or maybe it's the browser, try a differ browser too.
     
  9. steve23094 macrumors 68000

    steve23094

    Joined:
    Apr 23, 2013
    #9
    I tried different browsers with the same result. I suggested trying a video too, see what happens.
     
  10. rarchy thread starter macrumors newbie

    Joined:
    Oct 4, 2010
    #10
    Thanks everyone! I think it is only with streaming it does this, but I will try out with a video to see and also try with different resolutions incase it helps and then update on here.

    I have also watched DVDs using this method, as my DVD player is broken but I have an external DVD drive so connected it to my laptop and laptop to the TV, I don't remember it being jerky but it wasn't in HD so not sure if that also makes a difference, plus its harder to tell with a film anyway.
    --- Post Merged, Feb 9, 2016 ---
    John - I checked and resolution is set to "default for display" and when I connect the cable in the preferences which automatically show, it has "Mirror Samsung" ticked. (Other option are Mirror Built in Retina Display, or Use as Separate Display)

    I have also found the following incase it means anything under the Display preferences when the HDMI cable is plugged in

    Optimise for -> Samsung
    Best for Samsung is selected (as opposed to Scaled)
    Rotation -> Standard
    Refresh rate -> 60 Hertz (NTSC) (other options 24 - 50)
    Underscan -> Off

    Don't know if any of these have anything to do with it?
     

Share This Page