Why is streaming so slow from rMBP?

Discussion in 'Apple TV and Home Theater' started by Fzang, Jun 20, 2016.

  1. Fzang macrumors 65816

    Fzang

    Joined:
    Jun 15, 2013
    #1
    Both the ATV4 and my rMBP are connected to the same router, and all devices are just a few meters apart. The wifi tool also tells me my transfer rate is 200-300 Mbps (= at least 25 MB/s), which is at least 3x the bitrate of an average movie. Using Spotify I even get slight stuttering at times!

    What's going on? The wifi is fast, the channel is not crowded, and the hardware is by no means ancient.
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Is it the router that supports 200-300Mb/s wirelessly, or are those the speeds from your ISP?

    There are a few things you can try. Change your wireless router's encryption to WPA2-PSK (may be called AES rather than PSK). You can also try using the 2.4GHz band instead, assuming that you've got a dual-band router and you're connected to the 5GHz band.

    Other things would be to try would be to ensure your OS is fully up-to-date. You can also reset PRAM/SMC on your rMBP. If things get that desperate, even creating a new user account on your Mac can help towards diagnosing if it's software or hardware.

    EDIT: crumbs, I thought you were talking about your rMBP rather than your Apple TV. You can ignore most of my suggestions. Sorry :oops:
     
  3. benjitek macrumors 6502a

    benjitek

    Joined:
    Sep 23, 2012
    #3
    Something with your configuration -- I get extremely fast streaming performance with the same hardware.
     

Share This Page