Why is the location services on the camera such a pain?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by JMG, Jul 27, 2009.

  1. JMG macrumors 6502a

    JMG

    Joined:
    May 4, 2006
    #1
    Every time i turn on the camera on my 3GS it asks if I want to use my current location. FINE.... but it does it EVERY SINGLE TIME. Is there a way to make it REMEMBER that I want it OFF?! I can turn off location services but then I have to turn it on every single time for google maps. WTF?! It's so annoying!
     
  2. FXT 1 macrumors 6502

    Joined:
    Jul 14, 2009
    Location:
    UK
    #2
    Why do you want location services for every single app except Google Maps turned off anyway?

    There is no way to single out which apps you'd like location services off for except by manually entering this option, every time.

    Just say you want it ON when you use the camera app and all should be well, it will trouble you no more.
     
  3. AiralynRose macrumors 6502a

    Joined:
    Jun 3, 2008
    Location:
    Pittsburgh, PA
    #3
    well if there was a way to have it always be off in camera, there currently isnt any way to turn it back on.

    Why does it matter if camera knows where you are or not? Personally, i enjoy having geolocations on my pictures for use with iPhoto's places feature.
     
  4. JMG thread starter macrumors 6502a

    JMG

    Joined:
    May 4, 2006
    #4
    The problem is that even when i tell the camera i want it to use the location services, it still asks me everytime i open the camera app. Only with location services off does it not keep asking me every single time.
     
  5. AiralynRose macrumors 6502a

    Joined:
    Jun 3, 2008
    Location:
    Pittsburgh, PA
    #5
    It should only ask you twice and then save the setting. Same with all other apps using location services, they should only ask you twice. If you say "yes" twice in a row, then it shouldn't ask you anymore.
     
  6. JMG thread starter macrumors 6502a

    JMG

    Joined:
    May 4, 2006
    #6
    Weird. I read this a week ago and tried it and it didn't work. I turned locations services off then on, then said yes twice and now it works... ?!
     

Share This Page