Why is Wifi on the Touch so touchy?

Discussion in 'iPod touch' started by TheSpaz, Nov 10, 2007.

  1. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #1
    I get so frustrated when I find a wifi spot that has FREE access and yet my iPod touch connects to it but, it doesn't actually connect to the web. So, check this out. I brought my iPod to my girlfriend's house and she as Wifi there but, it was locked (which is understandable) so I had her Mom type in the password for me. BINGO! It connects to the router but, that's it... Safari won't load pages and can't use YouTube or Wifi Store... nothing. After connecting to her router, the settings seem a little weird. I get this weird IP address that doesn't seem like a local network address like 192.168.1.xx. Also, the Subnet Mask number is 255.255.0.0 while my network at home is 255.255.255.0.

    Also, when I connect it doesn't list a router address or DNS server.

    This same thing happened to me last night at her high school and this morning at the barber shop. It really makes me mad when there's wireless access and it pretends like it's connected yet, still doesn't work. Are there custom settings I'm supposed to go in and change? It connects to my network just fine as well as my neighbors network and a few others but most of the time when I'm in public... I can't get the freakin' thing to work.

    Also, I should note... The FIRST time I connected to my girlfriends wifi, it worked but, it won't anymore. Anyone else having this problem?
     
  2. urrl78 macrumors member

    Joined:
    Oct 26, 2006
    #2
    Happens all the time with me. I'm sitting across from an Apple store right now to find out, but first I am trying to unjailbrake my iPT.

    Anyway, at home before the jailbreak sometimes my iPT would connect with my MBP using a Sprint Expresscard shared, in OSX, but most times it will not. In Bootcamp XP it works good but only if I have my Powerbook on with my MBP to share the Wifi signal. Last time I was here in the Mall I could get on the free Mall Wifi. Now there are problems.
     
  3. PowerFullMac macrumors 601

    PowerFullMac

    Joined:
    Oct 16, 2006
    #3
    I went to a public WiFi access point yesterday and the same thing happened. Type in this DNS server address and apparently it works fine, havent tested it though: 208.67.222.222

    The ironic thing was that I was using the Apple Sore WiFi and Safari didnt work BUT Installer.app did! :D
     
  4. maestrokev macrumors 6502a

    maestrokev

    Joined:
    Apr 23, 2007
    Location:
    Canada
    #4
    That DNS server you quoted is maintained by OpenDNS. I use it at home but I don't recommend using it as a default if you're always hopping on to Hot Spots. The reason being that some Hot Spots require you to use their DNS server to redirect you to a logon page before you can access WiFi.
     
  5. Sweetbike40 macrumors 65816

    Sweetbike40

    Joined:
    Aug 29, 2007
    Location:
    NY/NJ
    #5
    Drives me nuts how the touch rarely is able to load anything. I'll get a full signal, connected yet i can't access anything. It's such a letdown. It's fine at home.
     
  6. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #6
    I think it has to do with how the wireless router is configured. Not everyone configures their router correctly. Plus, the iPod doesn't connect to 802.11x networks I heard and there's problems there too.

    I think it definitely sucks when you get all excited to find a free hotspot only to find out that you can't do any internet things besides have a little wifi icon in your header. Sucks.

    The strangest thing is... My iPod connected to my girlfriend's router a few weeks ago, then something happened to it and I had to restore it (I think I was messing with SummerBoard) and ever since the restore and re-jailbreak, I haven't been able to connect to her network. I think the weirdest thing is that I typed in a password and just guessed "Karen" and it accepted the password and logged me onto the network but, I couldn't use Safari or anything... so I chose "Forget This Network" and had her Mom type in the password... still nothing... so the other night I was trying to figure out the password and I tried some other things... some of the passwords came out with "Couldn't Connect" dialogs but, then I tried another GUESSED password (different than Karen) and it accepted it AGAIN but, I still couldn't use Safari. I even tried typing in all the router settings manually as well as tried different DNS servers... I don't know what was going on.

    Maybe there's a bug where the iPod THINKS I used the correct password but, the router knows that I didn't so it blocks my device from joining it's network. By the way, I get a 167 IP address.
     
  7. DataThief macrumors member

    Joined:
    Jul 30, 2007
    Location:
    Somewere in Washington State
    #7
    yes its a pain, right now at home I am typing this from the deck of my house with great wifi connection. When I go to a coffee house close by that has free wifi its a crap shoot weather it will work or not, I can have my laptop and ipaq right next to me and they both connect. Arrg
     
  8. shigzeo macrumors 6502a

    shigzeo

    Joined:
    Dec 14, 2005
    Location:
    Japan
    #8
    better than ezra

    my touch connects to networks that my macbook pro will not - that and it will find some fainter signals but for some reason, will not connect to a signal near my house that my macbook pro can -overall, quite a good wireless experience
     
  9. PowerFullMac macrumors 601

    PowerFullMac

    Joined:
    Oct 16, 2006
    #9
    Same sort of thing here, theres a hotspot my PSP always connects to, but I noticed that sometimes it connects fine, sometimes I have to hold it up to connect, but sometimes it wont even find it. All at the same place...
     
  10. verbalist macrumors member

    Joined:
    Nov 9, 2007
    #10
    reselecting the router or putting the touch to sleep then back up works some times
     
  11. Ipoderman macrumors newbie

    Joined:
    Jan 3, 2008
    #11
    I think I know how to fix that

    If you want to fix this I think I know how, first try sleeping the touch than turn it on if that didn't work go to the wifi tab in settings and sellect the connection that you want than try selecting the tabs that say bootP and static and leave it on there than try it and if that didn't work than maybe I was lucky a couple times
     
  12. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #12
    I figured it out. I was using the wrong password and it pretended like I was connected but, the router was still blocking me out.
     
  13. delude macrumors 6502

    Joined:
    Dec 27, 2007
    Location:
    UK
    #13
    I have connected to Wifi points before on my PSP and PDA but cannot browse the net at all. It drives me mad! There is every sign on the device that it is properly connected, but will not function like it should.
     
  14. mrgreen4242 macrumors 601

    mrgreen4242

    Joined:
    Feb 10, 2004
    #14
    You mean 802.1x, not .11x.
     

Share This Page