Why is youtube so damn slow?

Discussion in 'iPhone' started by yalag, Aug 31, 2011.

  1. yalag macrumors 65816

    Joined:
    Nov 18, 2007
    #1
    Why is youtube so damn slow on the iphone/ipad? If I go to the youtube website on a computer, even if I set it to the highest resolution (1080), it starts streaming within a few seconds. But on the iphone/ipad, it buffers for MINUTES before it starts to play. What's going on?

    I have an iphone4, ipad2. Thanks.
     
  2. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #2
    It's hard to say. I have an iPhone 3GS and YouTube works great for me. It starts playing in seconds.

    Someone else was complaining of this recently and I don't think a resolution was found.
     
  3. Carl G35c macrumors 6502

    Joined:
    Aug 14, 2008
  4. dwguertin macrumors newbie

    Joined:
    Feb 7, 2011
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_10 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8E600 Safari/6533.18.5)

    My Verizon iPhone is too slow for YouTube. I think that they are trying to push us to 4g and there new data caps. :(

    For some reason my old Droid x (last fall) was faster.
     
  5. yalag thread starter macrumors 65816

    Joined:
    Nov 18, 2007
    #5
    sorry just to clarify, I'm saying youtube is slow even on the SAME wifi. Is it the app or something on the youtube side?
     
  6. Shockwave78 macrumors 65816

    Shockwave78

    Joined:
    Jul 10, 2010
    #6
    its better on iOS 5 but not much better. The mobile site is 10x faster than apples built in app.
     
  7. wesk702 macrumors 68000

    wesk702

    Joined:
    Jul 7, 2007
    Location:
    The hood
    #7
    Same here. Sucks on wifi sometimes for no good reason. I switch to 3G then it's faster. Seems like it's always been that way for me.
     
  8. aziatiklover macrumors 68030

    aziatiklover

    Joined:
    Jul 12, 2011
    Location:
    8.8.8.8 and 8.8.4.4
  9. wkw macrumors 6502

    wkw

    Joined:
    Mar 23, 2004
    Location:
    Eugene, OR
    #9
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_5 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8L1 Safari/6533.18.5)

    Might be your DNS setting. Try 8.8.4.4
     
  10. yalag thread starter macrumors 65816

    Joined:
    Nov 18, 2007
    #10
    No it's not dns its the actual bar moving really slow
     
  11. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #11
    Nope.

    Nope.

    Yep.

    The OP is using his phone on the same network as his computer, yet has very different results. I've seen others with the exact same problem. It has to be something with iOS.

    I have the 3GS and YouTube works great for me. I don't think the OP's problem is his network or DNS, but iOS or even maybe the hardware acceleration on the phone.
     
  12. itsmemuffins macrumors 68030

    itsmemuffins

    Joined:
    Jun 23, 2010
    #12
    Can't say I have a problem on my iPhone 4 and iPad 2. Videos start within seconds just like they do on my computer.
     
  13. psywzrd macrumors 68030

    Joined:
    Feb 6, 2008
    #13
    I think the problem is the app. If I go open up safari on my phone and go to m.youtube.com the videos load very quickly; however, videos take forever to load in the youtube app (if they even load at all). Very annoying.
     

Share This Page