Why Macbook Pro 13" (09) Cant find ANY hard drive in Disk Utility???

Discussion in 'MacBook Pro' started by alphadog111, Jun 7, 2011.

  1. alphadog111 macrumors member

    Joined:
    Aug 31, 2010
    #1
    I bought a macbook pro 13" late 2009 model I believe on ebay and there was a hard drive issue which I thought I can fix....However I came upon some issues..When I put in a new Toshiba 500gb hd in this laptop and reinstall Mac OS X SL I can not find the hard drive in disk utility NOR any other hard drive I put inside on disk utility... What is the problem?? Is it the hard drive cable that I would need to have replaced? Or is it a logic board problem ( which I hope is not as everything else seems to be working...)

    I did install a new MAC OS X using the 500gb hd on another mac and switched it back into the macbook pro 13" and it did boot up but NOW it just gets blank folder over and over.... Please help! Thank you!
     
  2. mac8867 macrumors 6502

    Joined:
    Apr 5, 2010
    Location:
    Saint Augustine, FL
    #2
    Replacing the cable will cost you $30 to find out... well worth trying IMHO
     
  3. alphadog111 thread starter macrumors member

    Joined:
    Aug 31, 2010
    #3
    Have you encountered this issue before? Such as the hard drive not being able to be read...and replacing the cable fixes the problem?
     
  4. mac8867 macrumors 6502

    Joined:
    Apr 5, 2010
    Location:
    Saint Augustine, FL
    #4
    Yes a as a matter of fact, I have. Freaked me out. I bought a new cable and all was good.
     
  5. alphadog111 thread starter macrumors member

    Joined:
    Aug 31, 2010
    #5
    Is there a possibility that since it can not find a hard drive that there might be a liquid damage? I got the macbook pro 13" 2.26 w/ 8gb of ram for $470 on ebay...Is this worth keeping or shipping it back for a refund??
     

Share This Page