Why my printer wouldn't print.

Discussion in 'macOS' started by Bill McEnaney, Jun 24, 2010.

  1. Bill McEnaney macrumors 6502

    Joined:
    Apr 29, 2010
    #1
    Hi everyone,

    Long ago, I told you that my iMac wouldn't print anything when I gave it the "lp" command. So I renamed my printer because a consultant asked me to rename it. If I printed a document with an application program, I would see the name name when the HP LaserJet 1200se's icon appeared on the dock. But the machine still wouldn't recognize the new name when I typed, say, "lp -d LaserJet1200 getints.c". Why not? Because despite the name change, the printer's real device-name was "HP_LaserJet_1200". Had the computer shown me the underscores before I tried to rename the printer, the "lp" command would have caused printing. But the machine didn't display them in the name-change window. The problem would have been solved long ago if I had remembered to type "lpstat -a" in a Terminal window.

    Bill
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    So you are so important to our lives that you take for granted that we will remember what you posted "long ago"?

    That said, the thing that jumps out at me is that you expect this printer to just know how to print your file. Generally, command line print commands work only for files in a data type that the printer recognizes. For example, you can direct a PostScript file to a PostScript printer. If the printer does not understand the file type, then you need an application that does.
     

Share This Page