Why sending out email has lagged time

Discussion in 'OS X El Capitan (10.11)' started by novetan, Oct 31, 2016.

  1. novetan macrumors 6502

    Joined:
    Sep 3, 2010
    #1
    I have an iMac 27" coming to 3 mths. I'm facing this problem since day one. It didn't really bother me initially but felt quite strange as it should not happen this way.

    Whenever I send out an email, it will take between 30 to 45 sec before it send off even if the mail merely contains a few words. I checked my server speed and everything is fine as I'm able to download images pretty fast. It never happen before to my previous old MBP.

    My iMac is EC.
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    Are you using MacMail ? Outlook? Webmail?

    There is a setting in Google web mail which delays sending out mail for a short period of time to allow you to change your mind.
     
  3. novetan thread starter macrumors 6502

    Joined:
    Sep 3, 2010
    #3
    I'm using MacMail.
     
  4. MC6800 macrumors 6502

    Joined:
    Jun 29, 2016
    #4
    That's unusual. With Apple Mail and my iCloud IMAP account, sending to myself takes about 2 seconds to get it back in my inbox.

    You might be able to see what's going on using Mail's Connection Doctor (in the Window menu).
     
  5. ivanwi11iams Contributor

    ivanwi11iams

    Joined:
    Nov 30, 2014
    Location:
    Atlanta, GA
    #5
    More details needed...
    Albeit you're using Mac Mail, what email server is it connecting to?
    - Outlook.com
    - Office 365 (now the same as Outlook.com)
    - Yahoo
    - Gmail
    - iCloud

    Also, do you have more than one email account (multiple domains)? If so, remove BOTH accounts, then add one back and test sending emails. If that one works fine, add the other account and test that.

    Lastly, if you don't have another email account, and the removing of the current account and re-adding still causes the same issue, create a dummy Outlook.com account, add that and test.

    Go, we'll wait... ;)
     
  6. novetan thread starter macrumors 6502

    Joined:
    Sep 3, 2010
    #6
    I'm using a local server but has a Google account attached to my Mail. One reply mentioned "There is a setting in Google web mail which delays sending out mail for a short period of time to allow you to change your mind." But i'm sending out using Mail thru the local telco. Does the Google server affect the delay? Anyway I tried to find the "delay setting" but could not locate.
     
  7. ivanwi11iams Contributor

    ivanwi11iams

    Joined:
    Nov 30, 2014
    Location:
    Atlanta, GA
    #7
    I believe the delay send for GMail is merely from the web interface. You can set it to X seconds, in case you're about to send the email to the wrong person.

    Again, do you have more than one email account on your computer? If no, remove the account, add it back, and then test...

     
  8. novetan thread starter macrumors 6502

    Joined:
    Sep 3, 2010
    #8
    I will do the removal of the gmail account on the later part. Firstly I like to check on the delay setting on my gmail. Can you be so kind to direct me where is the setting as I could not locate it. Tks so much.
     
  9. ivanwi11iams Contributor

    ivanwi11iams

    Joined:
    Nov 30, 2014
    Location:
    Atlanta, GA
    #9
    Check this:

    To enable Undo Send:
    • Click the gear in the top right .
    • Select Settings.
    • Scroll down to "Undo Send" and click Enable.
    • Set the cancellation period (the amount of time you have to decide if you want to unsend an email).
    • Click Save Changes at the bottom of the page.
    But, I don't think this has anything to do with your issue, since this is mainly from the web interface if GMail...
     
  10. novetan thread starter macrumors 6502

    Joined:
    Sep 3, 2010
    #10
    Tks.

    Done the setting and retested.Still lag. Ok, I'll try to figure out how to remove the embedded gmail that linked to Mail. I'm not very good at this
     
  11. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #11
    What may be happening is that you have the wrong setting for your SMTP server for that account. When you try to send mail, the Mac waits for the primary SMTP server to time out, then sends with a secondary server.

    Go to Mail > Preferences > Accounts (NOT Mail > Accounts). Click on the account in question in the left hand pane. In the right hand pane you will see a line for outgoing mail server. Click on the server name and then select Edit List. Make sure the settings for your SMTP server are correct according to your mail provider.

    For Gmail, the settings are:
    Server name: smtp.gmail.com
    Click on the advanced button
    Then put in your Gmail e-mail address in full and your Gmail password
    Uncheck "Automatically detect and maintain account settings"
    Use Port 587 and check SSL
    Uncheck Allow Insecure Authentication
    Click OK

    A second thing you can do is to pull down the Window menu to Connection Doctor and see if any smtp connections show as timing out.
     

Share This Page