Why will new 2010 Macbook Pro not sleep with lid open?

Discussion in 'MacBook Pro' started by acribb, May 4, 2010.

  1. acribb macrumors regular

    Joined:
    Nov 30, 2007
    #1
    I have noticed that even with my Battery power settings set to sleep at 15 min, that the machine doesn't ever actually sleep, when the lid is open.

    I will wake up in the morning and try to use it, and it will be completely dead. When I plug power back in, it restores from the hibernate status.

    I believe that Logmein and Better Touch Tools are running in the background, oh and **iStat**. Could these be the culprits?

    I checked the Console logs and didn't see any error messages indicating sleep prevention.

    ** Edit ** - It may be the USB card reader I left plugged in?
     
  2. drew0020 macrumors 68000

    drew0020

    Joined:
    Nov 10, 2006
    #2
    My 2010 does something similar. I reset the system and then sleep worked again. Maybe a firmware glitch?
     
  3. realz macrumors member

    Joined:
    Apr 16, 2009
    Location:
    New York
    #3
    My 2009 Plastic Macbook, 2008 13" Aluminum Macbook, 2009 15" Macbook Pro and 2010 i5 Macbook Pro all act the same way.
    They do not sleep when idle. Resetting SMC sometimes fixes but after 3-4 sleep cycles the problem comes back.
    I have had this problem since 10.5.6

    I've also tried resetting PRAM, checking console logs for any application that may be preventing sleep. I do not run flash and kill it immediately if i see the process.
    here are the apps i am running usually.
    Safari
    Adium
    NetNewsWire
    Entourage
    Echofon
    Things

    Its definitely a bug Apple needs to fix.
     
  4. acribb thread starter macrumors regular

    Joined:
    Nov 30, 2007
    #4
    Sounds like I just need to close the damn lid if I want it to really sleep.

    Too bad- sometimes I want something to run when I walk away and then sleep when it's idle.

    Windows 7 sleep works.... , why can't the almighty OSX sleep??
     
  5. tekmoe macrumors 68000

    Joined:
    Feb 12, 2005
    #5
    It's gotta be something running in the background because mine has had no issues at all going to sleep with the lid opened. Try killing everything you can in the background and set the sleep timer to 1 minute (so you don't have to wait so long for it to go to sleep while troubleshooting.)
     
  6. realz macrumors member

    Joined:
    Apr 16, 2009
    Location:
    New York
    #6
  7. realz macrumors member

    Joined:
    Apr 16, 2009
    Location:
    New York
    #7
    Been there, done that... No fruits ;)

    I do see that if I create a new user, MacBook sleeps.
    I fixed my issue by deleting a bunch of plist files. It worked great for the first few times but then the problem came back. Its definitely a bug, I've seen it on many computers (I myself have 4 macs with issues). On the other hand my MacMini doesn't have this issue ( I run almost the same set of applications on MacMini).
    Plus if you google this, you'd find hundreds of people with the same issue.
     
  8. JimAtLaw macrumors 6502

    Joined:
    Sep 26, 2006
    Location:
    Bay Area, CA
    #8
    Mine sleeps with the lid open, no problem - you must have an app that is preventing this.
     
  9. realz macrumors member

    Joined:
    Apr 16, 2009
    Location:
    New York
    #9
    Code:
      UID   PID TTY           TIME CMD
      501    89 ??         0:08.98 /sbin/launchd
      501   417 ??         0:00.01 /System/Library/PrivateFrameworks/KerberosHelper.framework/Resources/LKDCHelper
      501 10672 ??         0:01.29 /System/Library/CoreServices/Dock.app/Contents/MacOS/Dock
      501 10673 ??         0:01.34 /System/Library/CoreServices/SystemUIServer.app/Contents/MacOS/SystemUIServer
      501 10674 ??         0:01.28 /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder
      501 10675 ??         0:00.01 /usr/sbin/pboard
      501 10677 ??         0:01.86 /System/Library/Frameworks/ApplicationServices.framework/Frameworks/ATS.framework/Support/fontd
      501 10684 ??         0:00.26 /usr/libexec/UserEventAgent -l Aqua
      501 10690 ??         0:00.08 /System/Library/CoreServices/AirPort Base Station Agent.app/Contents/MacOS/AirPort Base Station Agent -launchd -allowquit
      501 10691 ??         0:00.33 /Library/ScriptingAdditions/SIMBL.osax/Contents/Resources/SIMBL Agent.app/Contents/MacOS/SIMBL Agent
      501 10693 ??         0:00.18 /Users/realvarez/Library/Application Support/1Password/Agent/1PasswordAgent.app/Contents/MacOS/1PasswordAgent
      501 10699 ??         0:01.12 /System/Library/CoreServices/FileSyncAgent.app/Contents/MacOS/FileSyncAgent -launchedByLaunchd
      501 10702 ??         0:00.34 /Library/PreferencePanes/Growl.prefPane/Contents/Resources/GrowlHelperApp.app/Contents/MacOS/GrowlHelperApp -psn_0_3695494
      501 10703 ??         0:00.05 /Applications/iTunes.app/Contents/Resources/iTunesHelper.app/Contents/MacOS/iTunesHelper -psn_0_3699591
      501 10704 ??         0:05.49 /Applications/Adium.app/Contents/MacOS/Adium -psn_0_3703688
      501 10706 ??         0:00.24 /Applications/Evernote.app/Contents/Resources/EvernoteHelper.app/Contents/MacOS/EvernoteHelper -psn_0_3707785
      501 10710 ??         0:00.15 /usr/sbin/aosnotifyd
      501 10712 ??         0:00.19 /System/Library/PrivateFrameworks/DiskImages.framework/Resources/diskimages-helper -uuid 72B86816-C594-4DDD-A1C7-729275A61EAB -post-exec 4
      501 10727 ??         0:32.26 /Applications/Microsoft Office 2008/Microsoft Entourage.app/Contents/MacOS/Microsoft Entourage -psn_0_3720076
      501 10730 ??         0:01.35 /Applications/Microsoft Office 2008/Office/Microsoft Database Daemon.app/Contents/MacOS/Microsoft Database Daemon -psn_0_3724173
      501 10731 ??         0:00.05 /Library/Application Support/Microsoft/MAU2.0/Microsoft AutoUpdate.app/Contents/MacOS/Microsoft AU Daemon.app/Contents/MacOS/Microsoft AU Daemon -psn_0_3728270
      501 10734 ??         2:08.95 /Applications/Safari.app/Contents/MacOS/Safari -psn_0_3736464
      501 10740 ??         0:08.32 /Applications/Mail.app/Contents/MacOS/Mail -psn_0_3744658
      501 10746 ??         0:00.81 /System/Library/Services/AppleSpell.service/Contents/MacOS/AppleSpell -psn_0_3761046
      501 10768 ??         0:00.98 /System/Library/CoreServices/Dock.app/Contents/Resources/DashboardClient.app/Contents/MacOS/DashboardClient
      501 10769 ??         0:00.97 /System/Library/CoreServices/Dock.app/Contents/Resources/DashboardClient.app/Contents/MacOS/DashboardClient
      501 10770 ??         0:00.74 /System/Library/CoreServices/Dock.app/Contents/Resources/DashboardClient.app/Contents/MacOS/DashboardClient
      501 10786 ??         0:00.29 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker MDSImporterWorker com.apple.Spotlight.ImporterWorker.501
      501 10799 ??         0:00.08 /Applications/Microsoft Office 2008/Office/Alerts Daemon.app/Contents/MacOS/Alerts Daemon -psn_0_3806113
      501 10801 ??         0:00.11 /System/Library/Frameworks/CoreServices.framework/Frameworks/Metadata.framework/Versions/A/Support/mdworker32 MDSImporterWorker com.apple.Spotlight.ImporterWorker.i386.501
      501 10804 ??         0:01.45 /Applications/Utilities/Terminal.app/Contents/MacOS/Terminal -psn_0_3814307
        0 10806 ttys000    0:00.02 login -pf realvarez
      501 10807 ttys000    0:00.02 -bash
    
    Anything strikes out to you?
     
  10. deleon macrumors newbie

    Joined:
    Apr 17, 2010
    #10
    Is it both display sleep and computer sleep, just curious? Mine will only have the display sleep but the computer won't go to sleep. I am pretty sure that it is Firefox for me. It seems to fully sleep when I restart (even with Firefox open) but after surfing for a while, the computer will no longer sleep unless I close the lid, only the display turns off.
     
  11. realz macrumors member

    Joined:
    Apr 16, 2009
    Location:
    New York
  12. pricej636 macrumors 6502

    Joined:
    Mar 30, 2010
    Location:
    Colorado
    #12
    New MBPs have an issue where the ethernet port is changing states once every minute or so. It is preventing machines from sleeping.

    If you are curious about it, open network preferences and watch the status of the ethernet port (if its not being used). Every 70 seconds or so it will switch from "Not Connected" to "Unknown State" and back.
     
  13. realz macrumors member

    Joined:
    Apr 16, 2009
    Location:
    New York
    #13
    No such issues here....
    Mine's showing connected continuously. Also no logs in console mentioning any change of state of NIC
     
  14. pricej636 macrumors 6502

    Joined:
    Mar 30, 2010
    Location:
    Colorado
    #14
    It might not do it if you have an ethernet cable plugged into it. Or you might be just lucky :confused:
     
  15. realz macrumors member

    Joined:
    Apr 16, 2009
    Location:
    New York
    #15
    Doesn't do that with Ethernet unplugged either.
     
  16. King Apple macrumors regular

    King Apple

    Joined:
    Mar 17, 2010
    #16
    i have no problem having my macbook pro sleep w/ the lid open
     
  17. holmgard macrumors newbie

    Joined:
    Dec 4, 2008
    #17
    I had the same issue which migrated with my user account from a Macbook Air to a new MBP.

    The issue was only ever present with the lid open - the computer would go to sleep automatically when running it with the lid closed.

    Preventing Dropbox (v0.7.110) from starting at log-in resolved the issue for me. Whenever Dropbox is running, the computer won't sleep when the lid is open (but _will_ when it is closed, which is strange).

    Of course, thats just one piece of software that could cause the issue, but in my case it was the culprit (running 10.6.3, btw).
     
  18. espressoroast macrumors member

    espressoroast

    Joined:
    Feb 3, 2008
    Location:
    Amsterdam
    #18
    I have the no-sleep issue after playing a game from the Steam client. Neither the display not the machine itself would sleep after quitting a Steam game. The only way to go back to normal is a restart. Very annoying.
     
  19. rockstarjoe macrumors 6502a

    rockstarjoe

    Joined:
    Jun 2, 2006
    Location:
    washington dc
    #19
    My new 13" MBP won't sleep with the lid open. I can't figure out what software is causing it, but I also have the problem where my ethernet port flips on and off every 70 seconds, so that may be causing it.
     
  20. klab233 macrumors newbie

    Joined:
    Jan 25, 2011
    #20
    I don't know if a fix for this has been found, but i have searched every where for an answer and finally think ive come up with what i think was my problem.

    I have a brand new 2010 macbook pro that i bought for mainly video editing. but like a lot of people that are new to the world of computers and what not i had a friend that loaded me (my mac) with all the "good stuff." Not knowing what he ment, i let him have it, work his magic and presto!!! all of the sudden i had all this amazing software!!!

    well then along with that came the little problem that we all seem to be bitching about. it was frustrating as hell and after a lot of thought, i decided to not just do a re-install of the os, but to format the drive and start over.....and what do ya know, takin all that pirated crap off my box made all the difference. i havn't narrowed it down to exactly what program it was but i have read that some installs of adobe photoshop can cause this problem somehow. so my suggestion, number one stay legit, and don't use ripped off software but also keep a log and after everything that you install, test all your normal functions (to make sure they are still there), and that way you can maybe narrow it down to what is causing this.
     
  21. klab233 macrumors newbie

    Joined:
    Jan 25, 2011
    #22

Share This Page