why won't embedded .MOV file autoplay? have to double-click.

needlnerdz

macrumors regular
Jun 10, 2006
174
0
switzerland
Hm maybe you fixed it in the meantime because it auto-started for me [using Safari 4.0.1].

- Nevertheless, I didn't wait for the entire thing to load, but is it simply a slideshow of fading images throughout the entire .mov?? It's a bit crazy and illogistical expecting people to download a 60 meg file to look at still images. I imagine the plain .jpg version of the whole set would barely reach a meg or two.. you should consider adopting a simple javascript fading slideshow such as this:

http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

- just tell the script the name of all the images.. how long the fades are.. even offer people the ability to skip forward when impatient.
 

Oats

macrumors regular
Original poster
Jan 8, 2003
192
1
New York
Hm maybe you fixed it in the meantime because it auto-started for me [using Safari 4.0.1].
Still doesn't work for me... also tried Firefox on Windows... have to double-click for the movie to start. I even waited for the whole movie to load, and still it does not start until I double-click.

- Nevertheless, I didn't wait for the entire thing to load, but is it simply a slideshow of fading images throughout the entire .mov?? It's a bit crazy and illogistical expecting people to download a 60 meg file to look at still images. I imagine the plain .jpg version of the whole set would barely reach a meg or two.. you should consider adopting a simple javascript fading slideshow such as this:

http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

- just tell the script the name of all the images.. how long the fades are.. even offer people the ability to skip forward when impatient.
Agree... but the artist eventually wants more of a dissolve effect which javascript may not do. We'll see. There's got to be a better movie encoding, though, which compresses better.
 

needlnerdz

macrumors regular
Jun 10, 2006
174
0
switzerland
Agree... but the artist eventually wants more of a dissolve effect which javascript may not do. We'll see. There's got to be a better movie encoding, though, which compresses better.
Hm, the link I gave you has quite nice dissolve fading for me..? Otherwise, I would suggest jumping to flash. Because then you are really only loading the actual images and using the persons processor to handle a fade.. not much.. but if you keep relying on quicktime, you have to understand that you are then capturing anywhere from 12-24 frames per second for each of those images. They may not take up as much space when nothing changes.. but still far more than another media.. i'd really look up simple slideshows in flash. ideally you will find a 'dynamic loading' one, where you store the images in a folder, and simply tell a parameter of flash where they are - easy to clone for each gallery.
 

elitesouth

macrumors member
Nov 24, 2009
67
0
Savannah GA
It's not auto-playing for me in Firefox 3.5.5 - I took a look at your code, and I think your conditional IE comments aren't being used properly... They're closing themselves before the non-autoplaying .mov can even be contained by it.

This is what I see:

Code:
<object height="400" width="900" codebase="http://www.apple.com/qtactivex/qtplugin.cab" classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B">
<param value="http://www.chrisandersonart.com/dqnew/D%26Q%20Website%20Presentation_small.mov" name="src"/>
<param value="true" name="controller"/>
<param value="true" name="autoplay"/>
<param value="true" name="autostart"/>
<object height="400" width="900" data="http://www.chrisandersonart.com/dqnew/D%26Q%20Website%20Presentation_small.mov" type="video/quicktime">
<param value="false" name="autoplay"/>
<param value="true" name="controller"/>
</object>
</object>
It looks like you're embedding an object within an object, and that messes the whole thing up (for my browser).

Here's what your conditional ie comments look like when they're included in the code:

Code:
 <!--[if !IE]>-->
  <object type="video/quicktime" 
    data="http://www.chrisandersonart.com/dqnew/D%26Q%20Website%20Presentation_small.mov" 
    width="900" height="400">
    <param name="autoplay" value="false" />
    <param name="controller" value="true" />
  </object>
  <!--<![endif]-->
Should it not look something like this? (according to Microsoft):

Code:
 <!--[if !IE]>
  <object type="video/quicktime" 
    data="http://www.chrisandersonart.com/dqnew/D%26Q%20Website%20Presentation_small.mov" 
    width="900" height="400">
    <param name="autoplay" value="false" />
    <param name="controller" value="true" />
  </object>
  <![endif]-->
Even then, I assume you're trying to tell the user agent that:

IF you're IE, autoplay the movie.
IF you're NOT IE, then don't autoplay.
If that's correct, you'd want to change your "if not ie" code to the following:

Code:
 <![if IE]>
  <object type="video/quicktime" 
    data="http://www.chrisandersonart.com/dqnew/D%26Q%20Website%20Presentation_small.mov" 
    width="900" height="400">
    <param name="autoplay" value="false" />
    <param name="controller" value="true" />
  </object>
  <![endif]>
Since there is no "--" after "<!", browsers will simply ignore the tag, since it doesn't mean anything. However, IE will pick up on this and NOT display anything that's inside those two conditional tags.

PS. Your work is excellent
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.