Why won't FCPX let me export anything?

Discussion in 'Digital Video' started by iRobz, Jul 27, 2011.

  1. iRobz macrumors newbie

    Apr 17, 2010
    I'm at a total loss. I cannot export any footage out of Final Cut Pro X, the entire 'share' menu is constantly greyed out. I've tried selecting my project and exporting, selecting individual clips and exporting, opening a new project and exporting and trying to export only audio or video.

    I have app zapped Final Cut and reinstalled it in the hope it was an installation error but still it won't let me export anything.

    Does anyone have any suggestions?
  2. linuxcooldude macrumors 68020

    Mar 1, 2010
    I had a similar problem. I just clicked the playhead to various locations in the timeline till the export menu would allow me to select anything.
  3. iRobz thread starter macrumors newbie

    Apr 17, 2010
    Is that normal though? do you have to have it placed in a specific spot in order to export?
  4. mBox macrumors 68020

    Jun 26, 2002
    Set an In and Out and try again.
    Strange that this happens for you.
  5. dbhertel macrumors newbie

    Aug 6, 2011
    I'm having same problem - Share menu grayed out

    I've followed all the various tips in this forum and others, complaining about the exact same thing. The Share menu in FCPX has all options grayed out. None of the tips (restart/rebook, click project, etc.. ) have made a difference.

    Apple's website is moot on the point too, but yet i've found numerous folks having same issue. Frustrating..

    Anyone have any tips beyond the obvious ideas already posted?

    Thanks in advance...
  6. mBox macrumors 68020

    Jun 26, 2002

    Are you trying to share from the Events or Project?
    Cant do it from Events Library.
  7. dbhertel macrumors newbie

    Aug 6, 2011
    FCPX Project folder

    i'm trying while having the project selected within the Projects folder. this is the most common suggestion -- and one i've tried many times.

    i've did all the common suggestions for this issue -- which it seems a lot of people are having. i've ran across at least a dozen folks reporting same issue - all share menu options are grayed out but haven't found anyone yet reporting what solved it :(
  8. cgbier macrumors 6502a

    Jun 6, 2011
    Did you run Software Upgrade in between? FCP X doesn't contain any codices out of the box. The codices are an extra download.
  9. mBox macrumors 68020

    Jun 26, 2002
    All my FCPX installs were over FCS3 workstations.
    If that is true, Ill be testing it on a clean MBP tomorrow and see if this is the case.
  10. cgbier macrumors 6502a

    Jun 6, 2011
    All you have to do is to run Software Update.
  11. dbhertel macrumors newbie

    Aug 6, 2011

    I wish it were that simple. Software update reports everything up to date. I also went to apple's support site, selected specific updates and same result - no help.

    I also updated the codec pan - again, no help. share menu is completely greyed out.

    I'm on lion 10.7 and FCPX - haven't found any mention of compatibility problems on the net in any forums... but something is clearly wrong. :(

    I also didn't upgrade from any prior version. this is a brand-new OS install of v10.7 and brand new FCPX install. would love to hear any other ideas besides the generic 'software update' and 'be sure you are in the projects folder... etc.'
    I've read about at least a dozen people all reporting same problem w/share menu being greyed out. obviously there is a solution, just haven't found it
  12. mBox macrumors 68020

    Jun 26, 2002
    This happens on a particular system?
    Can you test on a different one ?
    Did you list your specs?
  13. dbhertel macrumors newbie

    Aug 6, 2011

    my specs: mac mini 2010 (2.4Ghz dual proc/intel), 2gb ram, 650g drive (575gb free)
    OS: 10.7 - fresh install last month. only 1 app (FCPX loaded)
    FCPX - brand new install
    Motion 5 - brand new install (never used)
    Compressor 4 - brand new install (never used)

    no upgrades performed - everything installed from scratch on this system
    apple system update reports everything is up to date.

    thats it. system is as vanilla and clean as it can be, items above were all loaded in last month or so. nothing else. system was new/unused when i bought on craigslist w/FCPX already installed. I don't have orig disks, hence I'm leery to remove/reinstall the app. I've had no other issues, system acts & works perfectly fine - just share menu of FCPX is unavailable.
    FYI: iMovie on this machine works fine to create/save movies.
  14. rock6079 macrumors 6502

    Jan 6, 2004
    iRobz, you find any solution? I'm having the same problem.
  15. Borjan macrumors regular

    Sep 28, 2004
    For me this happens occasionally as well, but seems to be a quirk about how FCPX should be used. As mentioned before, moving the player head about usually solves it for me. Feels more like perhaps I was not selecting/making active my project as I needed to before FCPX allows me to render.

    But then again, what happens with me might not be the issue you guys are having.
  16. cgbier macrumors 6502a

    Jun 6, 2011
    Yeah, that seems to be a bug. Happens to me also some now and then. It just gets unresponsive and doesn't let me select anything. Moving the playhead helps.
  17. rock6079 macrumors 6502

    Jan 6, 2004
    unfortunately seems to be a little more permanent for me.

    if anyone else has a solution, please share.
  18. xizar macrumors regular

    Dec 17, 2009
    I have no idea if this would matter, but did you "Download Additional Content"? (from the menu).

    It may be this was already taken care of via "Software Update".

    If you want to avoid re-downloading FCP X from the App Store (for whatever reason), you should be able copy the program to a DVD and put it back without a loss of functionality. I moved a copy from my desktop to laptop this way. YMMV.
  19. csmosk macrumors newbie

    Oct 2, 2012
    same issue

    Is there an answer for this? It is happening to one specific project, but on multiple computers. It is project specific. The only thing I did was detach the audio.
  20. mBox macrumors 68020

    Jun 26, 2002
    Drive perm issues?
  21. davdchai macrumors newbie

    Aug 15, 2003
    New York
    camera icon in clip

    I had this issue and it was driving me nuts as only one project from one event had this problem. For me anyway, it was to do with the fact that if you import a file from a camera archive, and it somehow got stopped or did not import correctly, you will have a HAZARD sign on the event, and a little camera icon on the clip that did not import correctly. If you backed up the camera archive you have a chance to go to FILE>REIMPORT FROM CAMERA ARCHIVE. This is how you can get that clip back and imported correctly, and voila! You should be able to export again... Not sure what happens if you don't have the original folder anymore... luckily I had mine backed up.

    Backing up the camera archive means that you would copy everything off the SD card straight off the camera, and paste that into a folder maybe called DAY1 CARD1, etc... for your job. Then you would import from camera and OPEN ARCHIVE, choosing the folder that you need the imported file from. Here is a great article explaining the re-import procedure.
  22. Jippus macrumors newbie

    Nov 8, 2012
    This worked for me when I was having this issue. Thanks!
  23. nateo200 macrumors 68030


    Feb 4, 2009
    Northern District NY
    I noticed my copy of FCPX did this sometimes for some reason...sort of weird...youd expect if your in a timeline your in a timeline and you shouldn't have to select anything if theres content in the timeline, especially if its all rendered out (not that it needs to be).
  24. frankacano macrumors newbie

    Dec 22, 2008
    This worked for me too. Import got interrupted and FCPX left the files on the camera. Selecting File>Import...>Reimport from camera/archive solved the problem. BUT I never say a little camera icon next to the clip previously or any other warning sign.
  25. Zwhaler macrumors 604


    Jun 10, 2006
    Just to clarify, if you click on a clip in your project timeline are the share options still greyed out? The only time I've seen this happen is when something isn't selected in the project timeline, which a must in order to tell FCP X you want to export your project's contents.

Share This Page