Why won't iMovie open?

Discussion in 'Digital Video' started by je1ani, Nov 22, 2007.

  1. je1ani macrumors 6502

    Joined:
    Sep 19, 2007
    #1
    When I open iMovie 08 from the dock it doesn't seem to want to open... it says it's open but the main screen won't open up! it just says iMovie in the toolbar.. any help>?
     
  2. Stike macrumors 65816

    Stike

    Joined:
    Jan 31, 2002
    Location:
    Germany
    #2
    Force-quit the iMovie application...

    ...then go to <yourusername>/Library/Quicktime/
    ---and remove the "DivX5.component" file.

    If necessary, remove other DivX-related codec files too.

    Start iMovie, and WOW! it works ;) :eek::D

    Yep, it´s a bug...
     
  3. mich8261 macrumors newbie

    Joined:
    Oct 16, 2007
    #3
    DivX not the issue (for me)

    I have seen this recommended fix (removing DivX component from ~/Library/QuickTime, but in my case there is nothing in that folder. Any other help would be appreciated.

    I tried launching a past project (iMovie 08 project) that was created with this machine, but the same thing happens. Only the toolbar appears and most of the items are grayed out.

    Thanks
     
  4. Stike macrumors 65816

    Stike

    Joined:
    Jan 31, 2002
    Location:
    Germany
    #4
    Hummm, try deleting the Preferences (.plist) file. Maybe that one does the trick.
     
  5. je1ani thread starter macrumors 6502

    Joined:
    Sep 19, 2007
    #5
    yeah no use :( oh well I have final cut pro at least
     
  6. Stike macrumors 65816

    Stike

    Joined:
    Jan 31, 2002
    Location:
    Germany
    #6
    You can still try to completely delete and then reinstall it.

    Delete iMovie with an app like AppDelete (it makes sure that every related file is deleted, check the trashcan at the end of this operation to make sure that no other unrelated file will be deleted)

    Thenget your iLife DVD and look at its contents. Somewhere you will find "iMovie.pkg" and install it.

    Who knows... if all else fails, this could work.
     
  7. pdpfilms macrumors 68020

    pdpfilms

    Joined:
    Jun 29, 2004
    Location:
    Vermontana
    #7
    Let me guess... you recently installed leopard?

    There have been some reported issues with opening Apple apps in leopard. My friend has been having issues with all his, including even FCP and address book.
     
  8. je1ani thread starter macrumors 6502

    Joined:
    Sep 19, 2007
    #8
    yeah sadly I think this might be the problem.. worked perfectly before leopard
     

Share This Page