Why won't mail get pushed?!

Discussion in 'iOS 5 and earlier' started by Hephaestus, Nov 24, 2011.

  1. Hephaestus macrumors 6502

    Joined:
    Apr 4, 2010
    #1
    Is anyone else having this problem? I don't recall having it in iOS 5.0, but since 5.01 its becoming more and more prevalent.

    Mail just won't get pushed, I have to load Mail for emails to come through. Sometimes it works, but most of the time it doesn't. Also, I have the Mail App running in the background but it doesn't seem to help. This never happened before iOS 5, seems like Apple is slipping here.
     
  2. sedril macrumors member

    Joined:
    Feb 11, 2009
    #2
    Mine works most of the time, but somewhat often, it doesn't work until I open the mail app.... Never used to do this before ios 5 and the icloud change
     
  3. Sankersizzle macrumors 6502a

    Sankersizzle

    Joined:
    Jun 5, 2010
    Location:
    Canadadada
    #3
    Mine has never pushed on any of my iPhones since iOS2. I've got everything configured correctly across all my accounts and everything is set to push, but it only ever updates when I go to the app.
     
  4. wolfshades macrumors 6502

    wolfshades

    Joined:
    Nov 1, 2007
    Location:
    Toronto, Ontario Canada
    #4
    Mine just stopped today for no apparent reason on both of my devices: iPhone 4S and iPad 2. Not the first time this has happened either. Frustrating.
     
  5. ideal.dreams macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    OH
    #5
    I am having the same issue with my iCloud mail. It only tells me I have new mail sometimes, I have to open the app and press the refresh button to see if I have anything new.
     
  6. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #6
    I've had the same issue but only with my iCloud based email account. Until the issue is resolved I'm forwarding all mail to an old Gmail account this is working normally.
     
  7. baller1308 macrumors 6502a

    Joined:
    Dec 8, 2009
    #7
    You've set them up as an exchange account correct?
     
  8. KenOzz macrumors member

    KenOzz

    Joined:
    Aug 2, 2011
    Location:
    Lincoln UK
    #8
    Yes same for me, I've had to forward all my iCloud email to Gmail

    I have found iCloud so unreliable some days it works others not and the main annoyance is that it will not update the email read status across all devices

    Meaning I read and delete an email on my Mac, but an hour later when I use my iPhone or iPad the same message is still showing up as unread

    I really had hopped I could move over to iCloud for my emails so I was entirely Apple but at the moment I just dare not trust it
     
  9. Hephaestus thread starter macrumors 6502

    Joined:
    Apr 4, 2010
    #9
    So I'm not the only one. I have three mail accounts on my iPhone - iCloud, Exchange and Gmail.

    I haven't noticed one pushing and the others not, for me I think its either they all push or none do. Today some emails pushed, but a few times I had to load the App. Its quite annoying, especially for someone like me that gets tons of emails, which are important.
     
  10. kuhtang macrumors regular

    Joined:
    Oct 20, 2011
    Location:
    Ontario
    #10
    I'm getting the same issue. I woke up this morning and thought it was odd that I didn't have any emails (not even my subscriptions!) waiting for me on the lock screen...then I loaded the mail app and then my emails started flooding in.

    Any clue on the issue?

    Another question I have is: if I've got a work email set up, can emails be pushed to two separate iPhones via exchange? It seemed to be working early on but just yesterday only one of the iPhones was getting the emails pushed to it.
     
  11. Ashwood11, Nov 25, 2011
    Last edited: Apr 16, 2012

    Ashwood11 macrumors 65816

    Joined:
    Nov 10, 2010
    Location:
    US
    #11
    My Yahoo Mail gets pushed on my iPad with iOS 5.0.1 even when Mail is not running in the background so this is not an Apple problem. Now I have upgraded to 5.1 and it still works.
     
  12. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #12
    I think it is only a 5.0.1 issue I have two phones one running 5 and one 5.0.1.
    They are both set up exactly the same and mail is successfully pushed to the one running 5 and I can see it on the lock screen.
     
  13. Sankersizzle macrumors 6502a

    Sankersizzle

    Joined:
    Jun 5, 2010
    Location:
    Canadadada
    #13
    No.... I set them up as what I thought were normal emails -my university email from the "other" menu and the GMail with the GMail wizard from the email account selection menu. Will an exhange account solve my woes...?
     
  14. gh0001 macrumors member

    Joined:
    Sep 10, 2008
    #14
    unless you configure gmail as exchange, the normal gmail does not push emails.
     
  15. ericrwalker macrumors 68030

    ericrwalker

    Joined:
    Oct 8, 2008
    Location:
    Albany, NY
  16. aeryk71 macrumors newbie

    aeryk71

    Joined:
    Oct 27, 2007
    #16
    Same issue for me...

    I am having this issue with my corporate exchange account. Set up for push. it pushes for a day or so, then stops and only Fetches until i restart the phone. Then push works for a while and fails again. It usually fails overnight and I wake to no emails.

    I am unsure if this is an IOS issue or a phone issue, but plan to call Apple next week to at least report it.

    If anyone finds a solution that sticks, please let us know!
     
  17. Sankersizzle macrumors 6502a

    Sankersizzle

    Joined:
    Jun 5, 2010
    Location:
    Canadadada
    #17
    Well that is hugely ridiculous. Why not have another screen after I'm setting up my GMail that says "if you want to push your mail do this". Rather than me coming here and embarrassing myself :eek:.

    Thanks for your help guys!
     
  18. kuhtang macrumors regular

    Joined:
    Oct 20, 2011
    Location:
    Ontario
    #18
    I'm getting the same issue with my corporate exchange account....but it's shared between two iPhones so I'm not sure if one is overriding the other.
     
  19. ericrwalker macrumors 68030

    ericrwalker

    Joined:
    Oct 8, 2008
    Location:
    Albany, NY
    #19
    LOL I used the gmail setup for a while, but for the last couple of years I've been using exchange. I don't know how I came across it at first, but it sure was a lifesaver.

     
  20. andy2141 macrumors 6502

    Joined:
    May 29, 2010
    Location:
    UK
    #20
  21. ShrubbySoup macrumors regular

    ShrubbySoup

    Joined:
    Mar 1, 2012
    Location:
    UK
    #21
    hi, this worked for me. if you have more than one account it doesnt push the mail to you but if you just use your hotmail, gmail on its own then it works fine :). sorry im a bit late on posting :)
     
  22. Böhme417 macrumors 6502

    Joined:
    Mar 11, 2009
    #22
    I newly have this problem. It's with my Yahoo mail. It used to push just fine, and now it only fetches when I open Mail. Everything is still set the same, but Yahoo mail refuses to push anymore.
     
  23. 2807 macrumors member

    Joined:
    Jan 9, 2011
    #23
    My brother and I have had this problem too. In the morning it will show no messages, and then I open mail and BOOM-- 5 or 6 pop in right away..

    Here is what I found/read somewhere that has really seemed to fix it--

    There is a problem with the "push" timing out when mail is running for a long time. If you close the mail app (double tap home button...) it seems to allow the push feature to work again.

    I have tested this and it does seem to be making a difference! You can actually have no mail badge, double tap--close mail, and boom... they will pop in.

    Hope it helps
     

Share This Page