Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

Jamiednm

macrumors newbie
Original poster
Oct 18, 2012
26
0
On a brand new Retina MBP, if Safari is in full screen mode when I close it, it always reopens in a window. How do I get it to open in full screen mode (or whatever mode I left it in when I last quit)?

Thanks
 

LV426

macrumors 65816
Jan 22, 2013
1,137
725
On a brand new Retina MBP, if Safari is in full screen mode when I close it, it always reopens in a window. How do I get it to open in full screen mode (or whatever mode I left it in when I last quit)?

Thanks

I rarely quit it, myself. Easier just to do a 4-finger swipe to the right.

But when I do go to the trouble of quitting, starting it up again will show the last page in whatever mode it was in before the quit. Unless I had private browsing selected, in which case it starts up small-screen.
 
Comment

Jamiednm

macrumors newbie
Original poster
Oct 18, 2012
26
0
I rarely quit it, myself. Easier just to do a 4-finger swipe to the right.

But when I do go to the trouble of quitting, starting it up again will show the last page in whatever mode it was in before the quit. Unless I had private browsing selected, in which case it starts up small-screen.

I'm not in private browsing mode, just tried it again and it still won't open full screen.

----------

I've just found the answer.

In System Preferences, go to 'General' and make sure where it says 'Close windows when quitting an application' is unchecked.
 
Comment

LV426

macrumors 65816
Jan 22, 2013
1,137
725
I'm not in private browsing mode, just tried it again and it still won't open full screen.

----------

I've just found the answer.

In System Preferences, go to 'General' and make sure where it says 'Close windows when quitting an application' is unchecked.

Odd, because that's the default situation. How did it get ticked, I wonder?
 
Comment

Jamiednm

macrumors newbie
Original poster
Oct 18, 2012
26
0
Odd, because that's the default situation. How did it get ticked, I wonder?

Haven't got a clue. That's what flummoxed me because I expected that sort of thing to be a default setting...but it wasn't on mine. Hmmmmm...sinister goings on deep inside my MBP.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.