Why won't my Mac automatically join my WiFi network?

Discussion in 'macOS' started by BudgetBaby, Jun 22, 2010.

  1. BudgetBaby macrumors member

    Joined:
    Jun 22, 2010
    #1
    If I start-up my Mac and forget to switch on my Airport it brings up a box showing available networks. But when I then switch on my Airport, it finds my network but doesn't join it unless I click on it.

    If I do the same with my iPhone or iPad, when my network appears on the airwaves, they see it and join it without any input from me. So why won't my £1600 MacBook Pro? Is there a setting I've missed?
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    Do you have your Mac setup to automatically join the network?
     
  3. brijazz macrumors 6502

    brijazz

    Joined:
    Jul 31, 2008
    #3
    This might help:

    1) open your "Network" System Preference pane
    2) highlight "AirPort" from the left-hand column
    3) click on the "Advanced" button (near the bottom-right-hand corner)
    4) check the box labelled "Remember networks that this computer has joined"

    In the future, your MacBook will automatically connect to any Wi-Fi network that you have previously connected to, and they will appear in the "Preferred Networks" list (which is also part of the "Advanced" settings). Hope this solves your problem.
     
  4. BudgetBaby thread starter macrumors member

    Joined:
    Jun 22, 2010
    #4
    Thanks guys - my Mac is set to remember previous networks.

    If my network is on when I start-up/wake my Mac, it'll see and join it.

    My issue is if I start-up/wake my Mac and THEN switch on my network. If that is the case it'll appear in the drop-down network list but my Mac won't join it til I click on it.

    Could someone recreate this and confirm that their Mac DOES automatically join their network?

    Does seem odd that my Mac doesn't do what my iPhone and iPad do do.
     
  5. brijazz macrumors 6502

    brijazz

    Joined:
    Jul 31, 2008
    #5
    I'm not quite sure what you mean by "switch on my network". I'll assume that you mean turning your AirPort on; this begs a further question though: why are you turning off AirPort before you sleep/shutdown your Mac? If you just leave AirPort on all of the time, your Mac should reconnect automatically after a reboot/wakeup. Also, please note that it can take around 15 seconds to rejoin the network after waking up (less if you are running OS 10.6).
     
  6. BudgetBaby thread starter macrumors member

    Joined:
    Jun 22, 2010
    #6
    I turn off my Airport overnight. Then I wake up, bleary eyed, the following morning, switch on the Airport and wake my Mac. But because the Airport takes a couple of mins to actually start, every morning I have to select my network once it appears in the network list.

    I recently left it about 10mins and it still hadn't joined (I'm on 10.6.4).
     
  7. Thraun macrumors regular

    Thraun

    Joined:
    Dec 18, 2008
    Location:
    Abbotsford, BC
    #7
    I'd like to second this question. I'm pretty sure this is where your issue is coming from. Is there a particular reason you switch off your network at night? You could avoid this problem by just not doing that.
     
  8. BudgetBaby thread starter macrumors member

    Joined:
    Jun 22, 2010
    #8
    I turn off everything at night.

    There's nothing in the specs or instruction manual that says the unit will not work properly if it's switched off so I'm not sure why this is an issue.
     
  9. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #9
    Home network equipment doesn’t really consume that much power though. It’s an absolute trickle compared to your computer, TVs, or incandescent light bulbs.
     
  10. brijazz macrumors 6502

    brijazz

    Joined:
    Jul 31, 2008
    #10
    Just to test things out, I pulled the plug on my router (an Airport Extreme Base Station), which of course caused my MacBook Pro and iPhone to lose their Wi-Fi connections. I then plugged the router back in, and all devices automatically rejoined the network. Since I can't reproduce your issue, I'm afraid that I can't offer any advice other than to just keep your router on overnight (you won't even notice the difference in your electricity bill).
     
  11. BudgetBaby thread starter macrumors member

    Joined:
    Jun 22, 2010
    #11
    A trickle x 100million = a waterfall.

    Every little helps.
     
  12. LongPhi macrumors newbie

    LongPhi

    Joined:
    Jun 26, 2010
    #12
    Well, ur problem sounds strange to me. How about going to "Control Panel" => Network => Airport =>Check the box "Ask to join new network", and then click Advance => TCP/IP, and change the box of configure Ipv6 to Automatically.

    Don't know if it work or not :confused:
    Well,
     

Share This Page