Why won't my MacBook recognise my new internal hard drive?

Discussion in 'MacBook' started by miscreantics, May 16, 2011.

  1. miscreantics macrumors newbie

    May 16, 2011
    Hi guys,
    I realise that similar problems are posted all through these forums but I can't find one that has actually made a difference yet.
    I've today installed a new 500g WD Scorpio Blue drive into my early '09 aluminium macbook. The install DVD will not recognise the new drive, and it does not show up in Disk Utility either - I just have a "Media" drive with a capacity of 0 bytes. I've tried a PRAM reset which hasn't helped, checked the SATA connection several times and am still getting nothing.
    I'm hoping that it's just not formatted correctly and that for some reason this is why disk utility isn't recognising the drive, however I have never had this problem with any of my other WD gear so it seems quite strange.
    Any help/advice will be very much appreciated.
  2. miscreantics thread starter macrumors newbie

    May 16, 2011
    oh and yeah, the drive is the right way up...
  3. blevins321 macrumors 68030

    Dec 24, 2010
    Winnipeg, MB
    Is the "Media" drive that you mentioned the drive that you installed? Or something else? If it's the right one, try to make a partition on it.
  4. miscreantics thread starter macrumors newbie

    May 16, 2011
    Hey, thanks for the fast reply.
    No it isn't the new drive. This "Media" drive's total capacity is 0 bytes, and SMART status is unverified. DU will not allow me to partition/format because the "disk is too small". I guess I could boot from DVD with no drive connected and see if "Media" is still there, but I'll assume for the moment that it will be - besides, I've just put my old drive back in and it is working perfectly...
    Could this be an issue with the way the WD drives come formatted from the factory? Or have I just got a faulty hard drive?
  5. blevins321 macrumors 68030

    Dec 24, 2010
    Winnipeg, MB
    Hmm, no it probably came as bare (no format). Either that for FAT/NTFS. Whichever of those, the Mac would have recognized it at least, and allowed you to format it. It's possible you got one that was DOA..did you happen to notice if it was 'clicking'?
  6. jsilas macrumors regular

    Dec 6, 2010
    Washington State
    There's no obvious reason the MAC wouldn't recognize the new disk. It's possible (and perhaps even likely at this point) that you got a DOA disk. If you have access to another disk (aside from the original), try that and see what your computer does.
  7. miscreantics thread starter macrumors newbie

    May 16, 2011
    Nah, it wasn't making any noticeable noises...
    It seems really strange because it's come straight out of the box and was installed perfectly - my computer just doesn't want to recognise it. When I boot from the DVD, I get the "Choose your disk" screen or whatever it is...and there's nothing there!
    Any other suggestions very welcome :)
  8. nabberooski macrumors newbie

    Aug 18, 2011
    Same problem

    miscreantics, were you able to resolve this issue? I am having the same problem with my '09 aluminum macbook pro.

  9. Mayo90, Aug 29, 2011
    Last edited: Aug 29, 2011

    Mayo90 macrumors newbie

    Aug 28, 2011
    Same Issue

    I'm having exactly the same issue with my sisters Macbook Pro, only it's not only the new Fujitsu HD it doesn't recognise in DU but the old one, which is why I pulled it apart in the first place, it is however re-installing the OS X operating system back onto the Old HDD but in an external caddy, both HDD have been erased and re formatted correctly, the Macbook just doesn't know they are there when installed. Im beginning to accept that it could be a logic board problem, in which case I assume at present I just as well disassemble the damned thing and use it for spare parts where possible, though I haven't as yet figured out how to suss out whether it is the Logic board yet
  10. zmason00 macrumors newbie

    Sep 20, 2011
    Same thing...

    Hi I'm having the exact same issue. I have tried two new drives now, a Hitachi 500 gb 7200 rpm and a 750 gb 5400 rpm. I am able to access both with my external adapter, but when I install them into my '09 macbook pro they do not show up in disk utility. Also nothing when using the os x discs. This is starting to get frustrating. Any help or advice would be much appreciated.
  11. Alpj89 macrumors newbie

    May 14, 2010
    Also the same problem

    Hi, I have the exact same symptoms on my MacBook 4,1 (early 2008)! DU (from the dvd installer) is telling me there is a media device with 0 B capacity. I purchased a new 0.5 TB HDD yesterday. Yesterday it worked perfectly! I installed my mac OS from my backup and then I wanted to install Windows with bootcamp. This is where all the tragedy started last night! After several failures of installing windows, and shutting down my macbook by force, mac wont recognize the HDD anymore. At startup it makes a strange sound periodically, and after a while it show a folder with a question mark on the screen.
    I also don't have any problems with my old HDD, that 120 GB HDD works perfectly! But I wonder if there's a fix for this symptom?
    I'll try to bring it back to the shop tomorrow, maybe they'll get me a new one. But for now if anyone knows a fix.. Please tell!
  12. zmason00 macrumors newbie

    Sep 20, 2011
    Found the problem...

    So after much searching and talking to people (professionals and normal folks alike) I finally found the issue with my machine. It was buried somewhere in the specs on the apple website for my serial number. This model is apparently only designed to use a 250 or 320 gb 5400 rpm drive. Anything faster or larger isn't recognized. I'm sure there is some way to get around it, but I don't know what it is. Feels to me like Apple is limiting upgradability to increase the purchase of a new machine...:mad:
  13. sehnsucht77 macrumors 6502

    Dec 26, 2008
    do you know where I might be able to find a resource to check the largest compatible capacity drive for my mac? I am thinking of upgrading my mac drive size but I don't know the capacity headroom.
  14. nicklad, Oct 3, 2011
    Last edited: Oct 3, 2011

    nicklad macrumors 6502

    Jun 13, 2007
    Nottingham, UK
    Are you sure it's not because you need to use a plain SATA drive, or manually set a SATA 2 capable drive to use SATA only and not to try to negotiate SATA 2 (usually using a jumper)?

    Is the drive one that uses 4KB sectors?

    The RPM definitely won't have anything to do with it.
  15. kaydot macrumors regular

    Sep 15, 2011
    This sounds a little suspect. I installed a 500gb HD into my mid-07 MacBook 2,1 without issue.
  16. simsaladimbamba

    Nov 28, 2010
    What exact Mac do you have?

  17. marshy459 macrumors newbie

    Oct 26, 2011
    mb late 2009 - similar issue

    I'm going to chime in here as I have experienced similar folly -

    With a full 250 MB drive, I ordered a replacement Seagate Momentus 750 GB 7200, Sata II, 3.0 mbit unit.

    Before everyone jumps up and down immediately, here is my learing and experience summary: (spoilers - I failed)

    1. I used superduper to make a copy of the drive using my Rosewill external usb drive kit. All went well, I could boot from the drive using the alt/option command and selecting the external usb drive.

    2. Installed the drive into the mb expecting success and I got the dreaded folder with question mark.

    3. Booting from the old hd from the usb and selecting the recover partition allowed me to see the drive in the mb but the drive utility reported a 93 mb fat partition with no write permissions? woe.

    4. I spent some time googling and reading forums and read about the firm ware inability to successfully down-negotiate to 1.5 mbit speeds - seagate has a section where they indicate jumpering two of the pins to force 1.5 mbit speeds.

    5. tried that and attempted to re-partition the drive - lots of issues, EFI partition errors, and worse. No dice.

    6. I tried different permutations and swapped the Hdd in and out lots of times.

    7. The last straw was an attempt at a clean format and install of lion via external usb and re-install. No go.

    I'm sending the drive back (currently successfully zeroing the drive via usb).

    I'm open to opinions. My path forward is to search for people who have actually installed a specific hdd model into an identical machine and buy that one. (Never could determine if it was a bad drive (don't think so) or an apple firmware problem (my vote).

    Thanks for reading.

  18. stormaes macrumors newbie

    Dec 14, 2011
    I just had success with replacing the hard drive in an older macbook. With a 500gb seagate momentus.
    When I tried to install Lion on it, it would not show up on the list of drives to install to however i fixed this by formatting it (using a different mac and a sata to usb adapter) to GUID and OSX Extended, journaled non-case sensitive. Reinstalled the drive and installation worked perfectly!
  19. o0yoshi0o, Mar 14, 2012
    Last edited: Mar 14, 2012

    o0yoshi0o macrumors newbie

    Mar 14, 2012
    I just installed a new 500g seagate and same problem.
    the solution is easy.
    partition your hard drive by even 5g.(495.11g) rename it. and go back to install.
    you can than install snow leopard. when it is finished installing repartition to the full 500.11g and your good to go.
    I just did it and it worked perfectly.
  20. tonixtonix macrumors newbie

    Apr 6, 2012
    Finally got it to work

    I was having the no hard drive found issue as well. I used a SATA connection to format my new hard drive with another Mac, journaled, and my macbook saw it right away the next time I tried to install from the Snow Leopard disk. Crucial dot com guarantees the drives they sell will work with your macbook. I am using their M4 Solid State drive and it's amazingly fast. Good luck!
  21. srq.systems macrumors newbie

    Jul 26, 2012

    I was having the same issue and was able to fix it by attaching it to another mac via usb and format it. I searched all over the net for a diff way to do this and couldn't find one. Hope this helps.
  22. Finntastic macrumors newbie

    Aug 2, 2012
    Same Problem - Easy Fix

    So I am an IT Tech and I was installing a new HDD in an iMac 7, 1 today and the brand new WD320GB drive was not being recognized when I was attempting to load the OS. The issue is usually due to new HDD being bare drives and not being formatted to any specific file system. The way I solved this was I connected the HDD to another system (I used a PC) and formatted it from within the OS (does not matter what file system you use). Then after installing it in the Mac the OS X installer recognized the drive and prompted me to format it using the erase feature in disc utility. Pretty easy but also a little frustrating. You can easily avoid having to do this if you purchase a drive that is Mac Ready, meaning it has been formatted for HFS file system already. Hope this helps someone.
  23. johnpearson macrumors newbie

    Aug 2, 2012
    this is what works for me

    I sell laptops and macbooks on ebay (jpea3631)

    I sell quite a few macbooks but am no expert on them in fact I would say I know very little about them.

    I have had the same problem as most people are mentioning on here and probably visted the site to try and work out away to solve this problem.

    The obvious one for you who know about macs is to get a replicator and duplicate the drive (which I cant do)

    As I sell macbooks and laptops I swap a lot of hard drives a lot of the time these are from working laptops (i.e not mac) and put them into macbooks

    These obviously are in the wrong format as they have windows on them.

    This is the crucial bit as they have the wrong format the apples OS then recognises the drive.

    Not exactly evidence but am doing one right now have put new drive into toshoba p300 loaded windows removed hd put in macbook and it has recognised it straight away

    After you have done that you install as normal reformatting the drive to extended through utilities.

    I have done this successfully on all macbooks from 2006 to 2008 and macbook pros same age.

    I have only tried this on one unibody macbook pro and it didnt work but in this case I think it is down to sata cable.

    I have only joined here to leave this message so if you try it and it works email me johnspearson33@yahoo.co.uk and let me know or if you have any questions

    It honestly seems to work all the time I would like to know if anyone gets anywhere on a unibody with this technique as it will give me an idea whats wrong with the unibody i have]]

    good luck
  24. THRochester macrumors newbie

    Jan 8, 2013
    Connecting the WD320Gb to a PC

    Hi Finntastic, I have the same problem on my PowerBook 12". Installer doesn't recognise the hard drive which is brand new. Thank you for your help on the forum but I can't see how I can connect the HDD to the PC to reformat it first:confused:

    Does this require specialist knowledge?
    I'm about to give up all hope... Thanks

Share This Page