Why won't my Mini wake-up for incoming network requests?

Discussion in 'Mac OS X Lion (10.7)' started by Heateris, Jan 24, 2012.

  1. Heateris macrumors member

    Joined:
    Jul 27, 2011
    Location:
    SEPA
    #1
    I trying to figure this out. I have Brother printer hooked up via USB and optioned as "share on network", I use The AirPrint Activator app for wireless iOS printing, and use Team Viewer HD app for remote access. All they things function perfectly when my mini is awake, but none work when it's asleep.

    I have selected "wake for network access" in the System Prefenances.

    Also, my router is a Xfinity supplied SMC-D3GNV gateway.

    Any ideas?
     
  2. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #2
    What year is your Mac Mini. I think someone told me my early 2009 mini won't WOL, even if you have the wake for network access checked.

    Wait found it (kind of):
    http://forums.macrumors.com/showthread.php?t=695626

    Scroll down to the longer post. It is not that it won't WOL, it won't WOL if it's wireless, it needs to be wired. That seems to be it and I believe that is what I was told by a couple people I talk to on twitter.
     
  3. Heateris thread starter macrumors member

    Joined:
    Jul 27, 2011
    Location:
    SEPA
    #3
    Sorry, here's some more info -- 2010 mini running Lion. It's also wired via a Ethernet cable. I keep the wifi off. Also, all apps/ SW are up-to-date.
     
  4. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
  5. Heateris thread starter macrumors member

    Joined:
    Jul 27, 2011
    Location:
    SEPA
    #5
    NP, thanks for your time.
     
  6. robgendreau macrumors 68030

    Joined:
    Jul 13, 2008
    #6
    It's complicated.

    Not every kind of remote access will wake every kind of computer on certain kinds of network. i.e., it depends.

    The wake on demand feature Apple touts is for bonjour services, and it requires their network hardware. So if you have a non-apple router that won't work.

    Other types of access can work with a remote Mac, but you have to have the appropriate application running so that it can "hear" the triggering packet coming down the pike. Not sure that TeamViewer knows how to do this, but I would expect it should. Check with their support. And try other services; I found when I had problems if I used my iPhone to connect via one service (like remote login) then it would be awake and I could switch to printing or whatever.

    Another work around involves your router. Set up a static IP on your Mac instead of a changing one (note this is for your local address, not the internet). The reason is that for some routers this makes them keep the info about where that computer is for longer and hence the packet telling the computer to wake gets where it's going. If you had noticed that the wake feature worked immediately after sleep but not hours after sleep this might help.

    Along the same lines you can set up port forwarding to send a wake packet; 9 is commonly used and you can find web sites that will send the packet for you.


    Rob
     
  7. Heateris thread starter macrumors member

    Joined:
    Jul 27, 2011
    Location:
    SEPA
    #7
    Rob, thanks for the info.

    I read on the Comcast support forums that their new gateways have lots of problems. I also read that I can get the wifi and router functions turned off via Comcast support. I plan to go this and pickup a AirPort extreme. Hopefully this will fix my problems.

    The saga continues.....
     

Share This Page