Why won't my music play in iTunes after transfer to 6S Plus?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ok3wire, Sep 26, 2015.

  1. ok3wire macrumors member

    Jun 15, 2009
    The new 6S Plus is my fifth iPhone. In every upgrade I've always backed up the old phone in iTunes on my Mac and then transferred all the data to the new phone via iTunes. In all previous instances, my extensive music library and playlists have migrated flawlessly.

    This time however, most (but not all) of my music is viewable on the 6S Plus, but the text is grayed out and can't be clicked on to play. Most of the music in my iTunes was downloaded directly to my Mac from my CD collection. I've since determined that it is those songs that are unavailable now. The relatively small number of songs that I've downloaded from the iTunes Store over the years will all play without problem on the 6S Plus.

    During the initial data transfer to the new phone, I received no indications that anything was amiss. I suspect the problem has something to do with this effed up iCloud bs. And for the record, I don't have anything stored in "the cloud" (that I'm aware of), I don't want anything stored in "the cloud", I wish "the cloud" didn't exist.
  2. XT550 macrumors regular


    Sep 30, 2014
    Did you try turning iCloud Music Library off from both your iPhone and iTunes?
  3. ok3wire thread starter macrumors member

    Jun 15, 2009
    Thanks for the assist, XT.

    Where would I find the settings for the iCloud Music Library?

    I see "iCloud Drive" under settings on my phone, but have it set to off.
  4. AppleRobert macrumors 603

    Nov 12, 2012
    To to Settings > Music, you will find that option there.
  5. ok3wire thread starter macrumors member

    Jun 15, 2009
    Update: The issue seems to have resolved itself. As soon as I got home, I resynced the phone with iTunes on my Mac and this time all the music files transferred.

    The strange thing is that all the artists, all the albums, all the songs and all the playlists were visible before, the majority of them were just grayed out and non-clickable.
  6. XT550 macrumors regular


    Sep 30, 2014
    For future reference,

    On your Mac: From the menu bar at the top of your computer screen, choose iTunes > Preferences.
    On your PC: Press Control+B to open the iTunes menu bar. Choose Preferences.
    Under the General tab, deselect the option for iCloud Music Library. Click OK to accept the change.

    On your iPhone:
    In Settings, tap Music.
    Turn off iCloud Music Library.
  7. mdawid macrumors regular


    Mar 14, 2011
    I had the same issues. I had started a thread asking for help. Another person steered me to making sure iCloud Music was off on the phone. Upon doing so and reconnecting my phone to iTunes, it seemed to work. I've never had this kind of trouble when swapping phones before. Not digging this whole cloud bs.

Share This Page

6 September 26, 2015