Why won't redsn0w work for me?

Discussion in 'Jailbreaks and iOS Hacks' started by Knowlege Bomb, Aug 1, 2009.

  1. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #1
    I see all kinds of success stories with redsn0w. It won't do anything with my phone. I tried it a couple times on 3.0 and now with 3.0.1 and the same thing is happening. It just sits in the "waiting for reboot" stage.

    I saw something about unplugging and reconnecting but that does nothing for me either.
     
  2. UngratefulNinja macrumors 68000

    UngratefulNinja

    Joined:
    May 9, 2009
    Location:
    Pennsylvania
    #2
    I asked someone this before and I can't remember if it was you or not, so excuse my forgetfulness, if so :D Is your computer a ppc mac? Vs. intel? I never could get redsn0w to work on my ppc ibook. I finally had to try it on a windows machine. Maybe that could be it?
     
  3. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #3
    Are you sure you are doing DFU mode correctly? I think the lame text/soundless instructions for DFU in redsn0w is atrocious. They should have given it a Pwnage Tool interface. Boo to the Dev-Team for that. :p
     
  4. Knowlege Bomb thread starter macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
  5. BergerFan macrumors 68020

    BergerFan

    Joined:
    Mar 6, 2008
    Location:
    Mos Eisley
    #5
    It stopped working halfway once for me, and I thought I bricked my 3G, but it worked a charm the second time.
     
  6. Knowlege Bomb thread starter macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #6
    Pretty sure. The screen is black and I have to hold home+power for about 15 seconds to get it to turn back on after redsn0w fails...
     
  7. madmak macrumors member

    Joined:
    Jul 27, 2009
    #7
    http://www.quickpwn.com/2009/07/jailbreak-and-unlock-iphone-301.html

    Update: If your iPhone 3GS is stuck on “Waiting for reboot” unplug your USB cable and plug it back in.

    If it doesnt work, you have to go the DFU route
     
  8. mikehockenballs macrumors member

    mikehockenballs

    Joined:
    Nov 6, 2007
    Location:
    Greater Manchester, England
    #8

    Hi mate,

    I am on Windows Vista as well and had a couple of unsuccessful attempts with redsnow, even after I had got the latest version 0.8.
    I followed the redsnow instructions but got the timings all wrong a couple of times and then when I put the phone back into the cradle it just kicked in and started redsnow automatically.
    I had to untick 'icy' or redsnow would crash for me!

    My advice to you would be keep trying cos I dont think it will do any harm to your phone.

    Good luck!
     
  9. Knowlege Bomb thread starter macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #9
    Tried this twice. First time I unplugged the cable from the phone and it didn't do anything. Then I thought "maybe if I unplug the cable from the computer I'll get a different result...". Nope. Then I switched between my three USB ports. Still nothing.
     
  10. Che Castro macrumors 603

    Joined:
    May 21, 2009
    #10
    i have vista, my comodo firewall was intefering with the process so i turned that off until the jailbreak was done



    are you doing it liek this

    in itunes hold shift,press restore, select the new update file, I got the new update from vamdon not itunes
    after restore is done open redsnow,Right click exe file open as administrator

    turn the phone off

    now select the 3.0 firmware
    do the 3 steps hold power for a few seconds then hold both power & home, release power button while still holdin home

    then the iphone stars downloadin ram

    then after 2 or 3 minutes is done


    are you doing it like this?
     
  11. ltldrummerboy macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #11
    When it got stuck on "waiting for reboot" I unplugged the cable from the computer and quickly switched USB ports (didn't plug it into the same one). This seemed to do the trick.
     
  12. toughluck macrumors member

    Joined:
    Jun 21, 2009
    Location:
    Austin, Texas
    #12
    Try restarting the computer. Seriously. Give Vista a break. lol
     
  13. techage14 macrumors regular

    techage14

    Joined:
    Aug 4, 2007
    Location:
    California
    #13
    The exact same thing happened to me when I tried to update to 3.0.1
    I tired to jailbreak with redsn0w on my intel Mac and it would get stuck exactly as you described. Idk what happened. I retried over 5 time and still, it would get stuck at the rebooting process. I finally gave up, and used pwnage tool to create a custom firmware and jailbroke using that method. Idk why redsn0w didn't work. It worked for me before. Sad. Oh well, the important thing is, i have my phone back and now, i don't care about the SMS bug. I just need my phone back.
     
  14. just21 macrumors member

    Joined:
    Jan 16, 2009
    #14
    Use purple ra1n instead. Just run the program, no buttons to press, much simpler.
     
  15. The General macrumors 601

    Joined:
    Jul 7, 2006
    #15
    You're not supposed to put your phone in DFU mode. You're supposed to put it in recovery mode.

    @OP Maybe that's your problem?
     
  16. jenzo macrumors member

    Joined:
    Nov 23, 2008
    #16
    make sure your using the 3gs firmware and redsn0w version 8.0.

    i was going nuts with the same issue and i was not only using the wrong firmware ( 3.0 for 3g ) but i had version 7.2 which wont recognize 3GS firmware.

    after i got both of those squared away, no more waiting for reboot freezes :)

    hope this helps!

    -jenzo
     
  17. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #17
    Yeh, if you knew what you were talking about, you would know that purplera1n doesn't work with 3.0.1. Fail

    I had the same problem in my Mac, would get to 'Waiting for reboot' after 'entering second stage'

    Tried everything. Downloaded the IPSW with a download manager, so re-downloaded with Firefox, and that didn't work. Did multiple resets. Cable in and out multiple times.

    Then, unplugged the USB cable, plugged it back in, then BAM, instant success!

    It went through and worked fine. Up and running on 3.0.1 with Ultrasn0w unlock, MMS and tethering all working.

    I think it's just luck. I have always used Pwangetool, and will be again after this.

    All I can suggest is keep going.

    Are you running as Administrator?
     

Share This Page