Why wont spell check work for Pages?

Discussion in 'Mac Basics and Help' started by sandk2k, May 7, 2008.

  1. sandk2k macrumors newbie

    Joined:
    May 7, 2008
    #1
    Hi,

    Could anyone help....I have had iwork for a few weeks now and all of a sudden the spell check wont work! I have tried turning on and off the "check as you spell" function and still its not working! Does anyone have any ideas of what I need to do? I'm tearing my hair out!!

    Sandk2k
     
  2. Mr.Noisy macrumors 65816

    Mr.Noisy

    Joined:
    May 5, 2007
    Location:
    UK™
    #2
    Hi, Edit > Spelling > Check spelling as you type,
    with that ticked it works great, i had a play around but no matter what it did, onc i re-ticked the check spelling as you type it worked ok, your not ticking check spelling are you, just a thought :) Just a thought.
     

    Attached Files:

  3. sandk2k thread starter macrumors newbie

    Joined:
    May 7, 2008
    #3
    Hey, nah that's the thing, clicking the spell check as you type doesn't work! Ive tried clicking it off and on again,and it wont make any difference?????!!!!

    Spell check works on everything else (ie its happening now as i type), but just not on pages! In fact it works on some pages documents and not on others! Weird. Someone mentioned something like deleting preferences or something?? DO you have any idea what that means? I certainly dont!! Something like com.apple.pages.plist or something?

    Help would be much appreciated....i cant hand in a university project full of spelling mistakes!!

    sandk2k
     
  4. satty macrumors 6502

    Joined:
    Mar 1, 2004
    Location:
    You can't beat Wellington on a good day
    #4
    Check also the Language settings of your text:
    Inspector => T- Text => More => Language

    I assume if it's set to "None" no check is happening.
     
  5. sandk2k thread starter macrumors newbie

    Joined:
    May 7, 2008
    #5
    Wow thats it!! Why does it always have to be something as simple as that so when someone tells you how to fix it you look like an idiot?!!

    For some reason it had switched to "none" for some parts of the text, so some paragraphs were spell checked and some were not. All i had to do was highlight the text not spell checked and select "british english".... that did the job! Doh!

    Thanks, thats saved a lot of me messing around like a blithering idiot.

    sandk2k :)
     
  6. saintstryfe macrumors member

    saintstryfe

    Joined:
    Apr 23, 2009
    #6
    I registered just to tell you that YOU ARE A GOD.
     
  7. hmarkow1 macrumors newbie

    Joined:
    Sep 2, 2009
    #7
    i also registered to say thanks a lot u r the man
     
  8. Kamahana macrumors newbie

    Joined:
    Sep 21, 2009
    #8
    same here i am now registered and inspired :)

    Oh Em Geee... U Rule! Thanks
     
  9. sprestonchase macrumors newbie

    Joined:
    Nov 14, 2009
    #9
    Pages spell check still not working

    --hey hey-- I've tried the above and still no go. I reset language/ rechecked 'check spelling as you type' --Any more ideas out there?
     
  10. appleboi91 macrumors newbie

    Joined:
    Feb 10, 2010
    #10
    Ok seriously I just registered to tell u that ur amazing ! just spent 5 pounds on the phone with ***** applecare losers who told me to do random crap when i should just do what u said!
     
  11. TEls8910 macrumors newbie

    Joined:
    Feb 21, 2010
    #11
    I'm with all the other guys on this one. I always had to copy all of my text to Mail and check the spelling there and search for it again in Pages to correct it. Wow! Man, u are the man!
     
  12. afrizen macrumors newbie

    Joined:
    Mar 24, 2010
    #12
    Respect Pile-on

    Yet another brand new registrant who did it all just to say:
    THANK YOU!

    This issue has finally, finally, finally embarrassed me for the last time!

    BTW, if this fix didn't work for you, note that it seems to apply at the paragraph level. I selected an entire doc and set it to English, but then selected a paragraph within the doc and it was still set to 'None'.

    Apple should be pimp-slapped!:mad: Why would they do this to us!?!
     
  13. dubhe macrumors 65816

    dubhe

    Joined:
    May 1, 2007
    Location:
    Norwich, UK
    #13
    It also happens when you insert a page break, the new page will be set to 'none'. This has been an issue for years, come on apple, fix it!
     
  14. CyrusOz macrumors regular

    Joined:
    Mar 15, 2009
    #14
    I am so confused, I have no idea of how to actually do what you are saying.... i'm having one of those annoying super dumb days and I can't work it out...... does this look correct?

    Any further assistance would be greatly appreciated
     

    Attached Files:

  15. davidnssbm macrumors regular

    Joined:
    Oct 23, 2009
    #15
    I've done everything in this thread and SOMETIMES the spellcheck works :(

    What gives?!
     
  16. mickmacforums macrumors newbie

    Joined:
    Aug 11, 2010
    #16
    setting the langauge

    One more of the many that are willing to bow down to our new saviour, thankyou!!!

    For those who are still having a problem, just make sure to select the whole text before changing the language, otherwize it only effects a small part of the text or inserted object.

    regards
     
  17. qianhuiwenyi macrumors newbie

    Joined:
    Nov 14, 2010
    #17
    :)

    a new registered user just to say THANK YOU!!!! you rock!
     
  18. Dave1R macrumors newbie

    Joined:
    Mar 13, 2011
    #18
    Spell Check problem and work-around

    PROBLEM

    A. Select Edit > Spelling > Check Spelling as you Type.
    B. Open Inspector > Text > More; set Language to English.
    C. Click back in the document text and watch the Language reset itself to None!


    WORK-AROUND

    [1] Same as step A, above.
    [2] Enter a few words of text in the document, then Select All (Cmd-A).
    [3] Set Language to English, as in B, above
    [4] Click back in the document text and continue typing; it stays set on English.

    This is what worked for me in Pages 09, version 4.0.5.
    When I did this it also seemed to set the preferences so new documents are created with 'Check Spelling as you Type' active.

    Let us know how it works for you...
     
  19. Chanzy11 macrumors newbie

    Joined:
    Mar 31, 2011
    #19
    none of these work for me

    have read full thread and tried them all.
    Basically if i type in "teh" by accident, it does not correct it to "the".
    Isn't this f*king ridiculous?
    Yes, i've gone through edit, spelling, check spelling as you type.
    and yes, i've opened inspector, text, more, and selected English.
    Both were set correctly in the first place so no change was required.

    I should mention however that it does put the red dashes underneath the "teh".

    Any help out there?
     
  20. Chanzy11 macrumors newbie

    Joined:
    Mar 31, 2011
    #20
    oh wait..

    does it simply not auto-correct as you type?
    I assumed it did..
    I should expect this in this impatient, A.D.D. world..
    by the way i posted like 20 minutes ago.. no answers yet??

    teasing.
    :p
     
  21. Chanzy11 macrumors newbie

    Joined:
    Mar 31, 2011
    #21
    found it.

    auto correction is under Pages, preferences, autocorrection.
    Works fine once enabled.
    There is a warning somewhere on this site that you have to be careful of letting the program insert its words over your own, as in it doesn't always get it right.
    Such as i would assume the 'correct' canadian english.
    multicoloured came up underlined as wrong.
    would be nice to set the language to canadian english.. possible?
     
  22. GNT macrumors newbie

    Joined:
    Apr 8, 2011
    #22
    Why it doesn't save the setting of the English?

    I followed Dave1R instruction, it works when I'm writing a document, but if I close it and re-open it again, or open a new document - it goes back to the NONE setting in the inspector.

    Thanks
     
  23. GadgetJunkyChic macrumors newbie

    Joined:
    Aug 10, 2011
    Location:
    TN
    #23
    none of these work for me either

    Unfortunately I'm having the same exact problem as Chanzy11. I have Pages 09 and my spell check will not work. My language was correctly set and check spelling as you type as well. I tried all the steps in this thread too. I guess I'll call Apple Care. Pray for me. I'm new to the world of Mac. I love my MacBook Pro but will have to admit this problem is ridiculous and I'm disappointed in Apple. I bought my Iworks 09 this past March and the problem should have been fixed BEFORE continuing to sell more copies. From looking at the dates of this thread, this problem has been going on for quite some time.
     

Share This Page